Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: .NET Framework 4.0 Will not Install on Win 7 64(error code 643)

10 Jun 2012   #1

Windows 7 64-bit Home Premium
.NET Framework 4.0 Will not Install on Win 7 64(error code 643)

Hi, everyone. I'm new here but really hoping that someone can help me because I'm at my wit's end with this. My problem is that I cannot get the .NET framework 4 to install for anything.

On Friday night I began installing Sharepoint Server 2010. Below are the following related products I had installed at the time:

- SQL Server 2008 Express
- SQL Server 2012 Developer
- Visual Studio 2011 beta
- Visual Studio 2012 RC
- .NET Framework (All installed through 4.5)

I had a lot of problems getting Sharepoint to install since I'm on Windows 7. I ended up having to download the EasyScript on MSDN which appeared to finally work by installing all the prerequisite files that were needed. However, it installed Visual Studio 2010 Trial on my machine which then prompted SQL Server 2012 to ask for the Visual Studio SP1 before it would run. Thus begins all the frustrations that have haunted me this entire weekend.

I cannot get VS 2010 or SP1 to install for anything. It is giving me an error every time (error code 643 - .NET 4.0). I have tried everything I can think of at this point. This is what I have tried:

- All Windows Updates (Visual Studio 2010 SP1 keeps failing)
- Uninstalled all .NET Framework files, ran .NET Framework Cleanup tool
- Ran Microsoft 'FixIt' tool for MSI files
- Uninstalled all Visual Studio versions
- Tried installing standalone .NET files
- Tried reinstalling Visual Studio 2010

Here's a screenshot of the failed install on VS 2010:

I also ran the collect.exe tool to gather the error log files but am not sure what needs to be posted as the error log files are VERY long. Here is a snapshot of one of them (I have many as I've been trying to get this installed all weekend):

OS Version = 6.1.7601, Platform 2, Service Pack 1
OS Description = Windows 7 - x64 Home Premium Edition Service Pack 1

CommandLine = C:\2ea9fda06fa4b6adae7c07d8498f0c\\Setup.exe /q /norestart /
KeepAUPaused /ChainingPackage "Microsoft Visual Studio 2010 Ultimate - ENU" /CEIPconsent /pipe SectionName_1186466144 /x86 /x64
TimeZone = Eastern Daylight Time
Initial LCID = 1033
Using Simultaneous Download and Install mechanism
Operation: Installing
Package Name = Microsoft .NET Framework 4 Setup
Package Version = 4.0.30319
User Experience Data Collection Policy: AlwaysUploaded
Number of applicable items: 11
Exe (C:\2ea9fda06fa4b6adae7c07d8498f0c\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
ServiceControl operation succeeded!
ServiceControl operation succeeded!
Exe (C:\2ea9fda06fa4b6adae7c07d8498f0c\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null).
Exe (C:\2ea9fda06fa4b6adae7c07d8498f0c\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
MSI (C:\2ea9fda06fa4b6adae7c07d8498f0c\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20120610_171757325-MSI_netfx_Core_x64.msi.txt
Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:00:11).

Thanks for any help that you can offer.

My System SpecsSystem Spec
13 Jun 2012   #2
Dell Rajeev A


Hi Codemastr,

My name is Rajeev and i work for Social Media and Community Team at Dell.

I see you can not update .Net framework 4.0 on windows7 64bit,

Kindly run a FixIt mentioned in the link given below

Error codes

Dell Social Media Outreach
My System SpecsSystem Spec

 .NET Framework 4.0 Will not Install on Win 7 64(error code 643)

Thread Tools

Similar help and support threads
Thread Forum
4.0 Framework installation :Error Code 643
also known as: .NET Framework update installation error: "0x80070643" or "0x643" I've googled and tried everything I've came across and still no luck with installing 4.0 Framework this only started happening once I used a tool to change my Windows install from professional to home, (i...
Windows Updates & Activation
unable to install .Net framework 4.5.2 error code (0x80070643)
I have trouble with installing .net framework 4.5.2 for my OS: Windows 7 home premium 64bit each time I run the installer it states a fatal error has occured and the installation has been terminated, ofcourse that would get you to google the error code and try those solutions, to no avail. ...
0x643 .Net Framework Error... Can't install ANY net framework
Tried everything. From adding full user control to trusted installer and creator/owner in Windows/Microsoft. net and Program Data directories to therepair service verifier, making sure virus scanner is off, fixit solutions, sfc /scannow's clean bill of health, uninstalling a few upgrades mentioned...
Net Framework 4.5.1 install failed. Code 643
There doesn't seems to be for me a way of installing this update (KB2858725), i tried with windows update and downloading the installer from microsoft´s website. i tried some things related with the permissions but i don't have a clue what to do. I attach the logs if someone has some time to...
.NET Framework 3.5.1 failed to update error code: 80075070
error code: 80075070 Security Update for Microsoft .NET Framework 3.5.1 on Windows 7 and Windows Server 2008 R2 SP1 for x64-based Systems (KB2972211) Download size: 12.8 MB is 35mb max upload limit is 8mb this is a laptop i have been removing addware on for a freind it now seems to...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:58.
Twitter Facebook Google+