Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win7 SP1 Update not installing - mismatched Mail file. 0x80004005

10 Jul 2012   #31
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Quote   Quote: Originally Posted by NoelDP View Post
Quote   Quote: Originally Posted by Layback Bear View Post
I'm back with no head ache but no smarter. Validation code zero (0) means the operating system has not been validated by Microsoft and needs to be validated.
No it doesn't :)
In an MGADiag report, 0x0 implies 'no error'.

In fact the clue comes later - where the line
LegitcheckControl ActiveX: N/A, hr = 0x80070002
appears - the AcitveX control hasn't been installed (or has been removed)
Thank you for the info. Have a nice day.

My System SpecsSystem Spec
10 Jul 2012   #32

Windows 7 Pro x64

Just for kicks, I renamed the Program Files\Windows Mail folders and re-ran the SP1 installer. NO CHANGE.
This suggests to me that it is not looking at the files in this location ... we are dealing solely with the registry. Does that sound right?

Concerning the note above, in IE8, I think I have ActiveX controls on "Prompt" and third-party controls disabled. Should I change this and re-run?

Event viewer says "Event log service is unavailable. Verify that the service is running.
Opening Services.mcp - There is no listing under the "e"s for Event anything, either Standard or Extended tab.
Where do I go from here?

IE - Internet Options - Security Settings - Internet Zone shows:
Allow Active X Filtering - Enable
Allow previously unused controls to run without prompt - Disable
Allow Scriptlets - Disable
Automatic prompting for ActiveX controls - Disable
Binary and Script Behaviours - Enable
Display video and animation on a webpage that does not use external media player - Disable
Download Signed ActiveX controls - Prompt (recommended)
Download unsigned ActiveX controls - Disable (recommended)
Initialize and script ActiveX controls not marked safe for scripting - Disable (recommended)
Only allow approved domains to use ActiveX without prompt - Enable
Run ActiveX controls and plugins - Enable
Script ActiveX controls marked safe for scripting - Enable
I rarely use IE, so these have not been tuned. I don't know what half of them mean.
I suspect they are the IE8 defaults for Medium-High security.
Does this help?
My System SpecsSystem Spec
10 Jul 2012   #33

Windows 7 Pro x64

Opening msconfig.exe, I don't see an "Event*" service listed here either. Is it called something other than "Event log service"?

Scanning msconfig, found a "Windows error reporting service" that was disabled. I have enabled, rebooted, re-ran MGADiag, no change to screenprints above.

I am now rerunning CheckSUR and will update when it completes.

Any thoughts about the CBS log from last november and the repair that is reported in it? Would it make sense to try removing registry entries that reference the msoe file and/or the Windows Mail folder?
My System SpecsSystem Spec

10 Jul 2012   #34
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

This might help you but if it doesn't don't be mad at me.
Windows Mail
My System SpecsSystem Spec
10 Jul 2012   #35

Windows 7 Pro x64

No joy with enabling "Windows error reporting service."
CheckSUR is unchanged - still saying "Unable to open the Event Log - Interface unknown.

@Bear - Why would I be mad? I am incredibly grateful for any ideas that might lead to a solution. My alternative is a Repair install or, 100 times worse, a clean install! Bring on any and all ideas.

I am studying that thread now - looks promising. Thanks!
My System SpecsSystem Spec
11 Jul 2012   #36

Windows 7 Pro x64

Happy Dance!

@Bear That thread lead to the solution! I was not alone in having the issue. It was hard to wade through as there are multiple causes of the 80004005 error but I finally found a recipe that worked for me.

For those that follow, what worked for me was mostly the "Gobbledegeek solution" at post 958. Note that my CBS.log file specifically points to msoe.dll as the trigger of the error. Others suggestions (and frustrations) in that thread were associated with other triggers. My variation of His solution follows:

1) (Probably optional) Delete the Windows Mail folders and let sfc /scannow rebuild them.

2) If it was renamed per other suggestions, restore the SoftwareDistribution folder (disable the Windows Update Service to make the change, then re-enable it.)

3) Go to Windows Update, Installed updates and remove the update KB978542. For me it was applied in May 2010; others reported August 2010.

4) Once again delete the Windows Mail folders and run sfc /scannow in an elevated command prompt to rebuild them. This restores both the files and the version of the registry entries relating to msoe.dll that SP1 is trying to locate and uninstall.

5) Per the suggestion in comment 968 and others in that thread, use the RTM ISO version of the SP1 update (link in that comment.) Apparently it is coded a bit differently than both the Windows Update and downloadable .exe versions. This was not tested and isolated as essential, but it was one step within my final recipe for success.
I still have issues with the Event Log, but huge steps forward!
My System SpecsSystem Spec
11 Jul 2012   #37

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

I just responded to this - and the response sems to have gotten lost somewhere in webland....

run the following commands in an elevated command prompt.


copy and pates the results to your reply, and we'll se what happens
My System SpecsSystem Spec
11 Jul 2012   #38
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

DukeS are you fixed now? If you don't give we all will try to keep helping. Yes sometimes it does take a clean and install. Happy computing.
My System SpecsSystem Spec
11 Jul 2012   #39

Windows 7 Pro x64

Noel -

Here's the result. I'm guessing there is a dependency on WERSVC - Windows Error Reporting Service

Going into either msconfig or services.cpl it is marked "Disabled" and changes in msconfig do not stick, changes in Services respond with "Access denied."

I went to the dependencies tab and it says none and none.

I went to the wersvc.dll and is shows Administrators and TrustedInstaller have Full Control, and that the Owner is Administrators.

MSCONFIG says it was disabled on July 8th, the same time I disabled a number of non-Microsoft services to get to a "clean" environment for SP1. If I made the change, it was unintended, and apparently I cannot undo that change. So, any tricks to get control of this guy or identify what is preventing changes?

This is listed as a symptom of the Conflicker worm, but a check of the "Conflicker EyeChart" shows no infection. (Anti-Virus has been off while trying to solve the SP1 issue.) Nevertheless, I am restoring AV and running a scan.

Attached Thumbnails
Win7 SP1 Update not installing - mismatched Mail file. 0x80004005-eventcmdcap.png  
My System SpecsSystem Spec
11 Jul 2012   #40

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Now we know which service is failing we can start to work out why.........
run the following commands in an Elevated Command Prompt....


Copy and paste the results to your reply.
Here are some instructions to make life easier :)
1) To open an Elevated Command Prompt Window (the CP window), click on Start, All Programs, Accessories – then right-click on Command Prompt, and select Run as Administrator. Accept the UAC prompt.
2) To run the commands easier, highlight the block of commands, and right-click on the highlight – select Copy. In the CP Windows, click on the black/white icon at top left – select Paste. The commands will run but may not complete the last command, so hit the Enter Key once.
3) To copy the results... click on the Black/White icon in the top left, and select Edit... 'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to paste it into your response.
My System SpecsSystem Spec

 Win7 SP1 Update not installing - mismatched Mail file. 0x80004005

Thread Tools

Similar help and support threads
Thread Forum
IE 11 locks up on AOL mail after installing critical update
IE 11 would lock up when attempting to read AOL mail, on my HP laptop. Firefox worked fine to read AOL mail. Uninstalled IE11, which rolled browser back to IE10. AOL mail worked fine. Fresh install of IE11 and AOL mail worked fine. Installed several critical updates(I seldom do recommended...
Windows Updates & Activation
Error 0x80004005 while extracting zip file
I'm trying to extract a zip folder that contains only one .exe file.Actually,I downloaded this zip file from Esri Downloads. When the file is completely downloaded and i tries to extract it using standard windows extractor I receive an error saying "Error 0x80004005: Unspecified error". I've...
Win Live Mail error(0X80004005)
I have a Dell Inspiron mini with Win7 starter with 1 gig of Ram. I use Microsoft Security Essentials. I did not use it for 2 months and when I turned it on 2 days ago, 22 win updates we downloaded. Now when I try to use Win Live Mail to download E-Mail from ATT.NET, I get a 0X80004005 error...
Browsers & Mail
please help me e_fail(0x80004005) windows update sp1
i tired try solve problem for e_fail(0x80004005),this i upload CBS folder and windlos update log this my windows update log 2012-01-16 11:49:46:504 596 15a8 AU AU setting next sqm report timeout to 2012-01-17 04:49:46 2012-01-16 11:50:39:858 596 15a8 AU Successfully wrote event for...
Windows Updates & Activation
Can't change any file properties, error 0x80004005
Hi there, I was trying to change a mp3 file properties > details, but it won't let me. There is nothing listed. When looking in explorer, it shows no album information or title. It does it with video files as well, so I am assuming all properties. When I do change something from the...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:06.
Twitter Facebook Google+