Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows update is not working

25 Aug 2012   #1

MS Windows 7 Professional 32-bit SP1
Windows update is not working

At first(some weeks ago), windows update couldn't search automatically for updates and when I was trying to update manually I was getting error 80080005.
I didn't manage to fix the problem, and now when manually checking for updates, it never finishes(its stuck at 'checking for updates').

Tried running System Update Readiness Tool as well. Tried to apply a hotfix and failed. Since then when I run the tool again it gets stuck at 'searching for updates on this computer' (kinda like windows update).

Additional info
After a quick look at update history: It started 2 months ago*. Since then windows update has been installing the same 3 updates each time. Though their status is marked as 'successful', they have been installed over 40 times till now('successfully' each time).

*Seems the starting point for all this is a failed update:
Update for Microsoft XML Core Services 4.0 Service Pack 2 (KB973688)
Installation date: ‎21/‎6/‎2012 12:28 μμ
Error details: Code 643

The 3 updates that keep getting installed/in case you need them
Security Update for Windows 7 (KB2633171)
Security Update for Windows 7 (KB2676562)
Update for Windows 7 (KB2679255)

My System SpecsSystem Spec
26 Aug 2012   #2

Windows 7 x64

Are you running any type of anti-virus or firewall that might be bocking access for Windows Update?

I show 2 entries in Programs and Features panel about MSXML. KB954430 and KB973688 were both installed on 7/12/2011. Do you show those, and if so, can you try a repair, change or uninstall operation?

The 80080005 means CO_E_Server_Exec_Failure, if that is any help.

Could you copy your WindowsUpdate.log in the Windows folder, to your desktop and then copy around the last 5 days of entries. Paste those in a text file and zip it and attach? Maybe someone will see something that might help.
My System SpecsSystem Spec
27 Aug 2012   #3

MS Windows 7 Professional 32-bit SP1

I have avast!, no firewall though. Recently, I uninstalled TuneUp Utilities in case it was interfering. I'll try changing the anti-virus too.

By 'show' you mean 'see' right?
In Programs and Features/Installed Updates I see none of these. In fact it says: No updates are installed on this computer.

I attached the .txt.
Thanks for your reply.
My System SpecsSystem Spec

27 Aug 2012   #4

Window 7 Ultimate x64

Have you tried uninstalling those updates then reinstalling them?
My System SpecsSystem Spec
27 Aug 2012   #5

Windows 7 x64

I see in the log the multiple reports of having successfully installed KB2676562

I also see things like this:
80190194 The requested URL does not exist on the server.

WARNING: DownloadFileInternal failed for error 0x80190194
So, since it appears your system has gotten out of sync, I will suggest you rename or delete the SoftwareDistribution folder in the Windows directory. It will take a little time for your system to catch up, so be patient.
My System SpecsSystem Spec
27 Aug 2012   #6

MS Windows 7 Professional 32-bit SP1

@Saltgrass:I deleted the SoftwareDistribution folder.
I get error 80080005 once again, when checking for updates. (at least now it finishes and throws the error instead of never finishing)

@TokiHacker: I can't see the supposedly installed updates in Programs and Features. As I said, I get a message 'No updates are installed on this computer'.
My System SpecsSystem Spec
28 Aug 2012   #7

Windows 7 x64

I have seen anti-virus utilities cause problems with Windows Update. And one of the problems was during a reboot to install the updates, the utility was active scanning and would not allow the Updates to be installed. So if you have an anti-virus, just turning off "Real Time Protection" may not be enough.

I use MSE and it has never caused that problem, but during testing another one did. It is hard to say which ones may or may not since they are updated and problems repaired.

You do shut your system all the way down occasionally?

If nothing else helps, you might use the site linked below. But one of the commands in the "do it myself" section does not run on my system. May be a typo, but before you do the fixit, or yourself, open an administrative command prompt and type:

netsh winsock reset

Give it some time to see if it helps, then continue with the process if you want.

How do I reset Windows Update components?
My System SpecsSystem Spec
28 Aug 2012   #8

MS Windows 7 Professional 32-bit SP1

Yes, I shut down my PC everyday. Most of the times though, using an Auto Shutdown program(I've been using it long before the problem appeared, but you never know what can cause trouble).

I used the command in cmd but it didn't seem to help.
What do you mean by 'give it some time' by the way? Should I leave it without doing anything and trying again after hours/days?

And I tried the fixit as well. It recognized the problem with windows update, said it fixed it but I still get the same error :/
My System SpecsSystem Spec
28 Aug 2012   #9

Windows 7 x64

Time means it may take several runs to catch up after removing the SoftwareDistribution folder. Not really sure how long, but if it is running on Automatic Updates, it may take several days. If you are checking for updates yourself, it will be much faster.

The error you show, still being consistent, would leave me to believe you are not connecting to the Update Server. But I don't know exactly what the error message means, if it in fact, it is accurate.

Are you running any type of proxy server?

Maybe check the Event Viewer for messages about Errors or Warnings that happen around the time you try doing updates.
My System SpecsSystem Spec
28 Aug 2012   #10

MS Windows 7 Professional 32-bit SP1

I don't use any proxy.

The event I see in Event Viewer after checking for updates:
The Windows Modules Installer service terminated with the following error:
Insufficient system resources exist to complete the requested service.

I also tried running a sfc/scannow in cmd and it seems there is a problem there too. I get this message: Windows Resource Protection could not start the repair service.

You think I should do a repair install of windows7?
My System SpecsSystem Spec

 Windows update is not working

Thread Tools

Similar help and support threads
Thread Forum
USB not working after Windows Update
Computer was fine on Friday but this morning after an update has been applied I have no USB hence no keyboard or mouse. I'm able to access the computer from anoth PC via Teamviewer so can make changes etc no problem. So far I've spent the entire day trying different things to sort this out but to...
Hardware & Devices
Rdp not working after windows update
I recently performed all the windows updates and now rdp will not open. The error says Could not load the Remote Desktop Service ActiveX control. Make sure mstscax.dll is in the path. I confirmed the extension is in there. I uninstalled an update that was possibly to blame. I replaced the...
Network & Sharing
Internet not working, windows update, ping, DNS, etc. working fine
Hello, I've got a Dell laptop here that isn't functioning properly. I can't get this to work for the life of me! I am currently using this laptop with a different hard drive, it's the install on the SSD that doesn't work. I know that the quick fix would be to simply reload windows, but I don't...
Network & Sharing
Windows Update is not working/Update Readiness Tool won't install
Win 7 64 Windows Update not working (post migration), nor is Windows Update Readiness tool installing. I have renamed catroot and stopped services, nothing working. I just migrated HD to a hybrid solid state (Seagate Momentus). I had this problem both with Acronis 2009 and Acronis 2013, and...
Windows Updates & Activation
Windows Update not working
Fresh install of Windows 7 and i have tried the readiness update which comes back with no errors in the log. I have removed firewall and antivirus and still cannot get the Microsoft Updates (it is just the security related ones) to install. I have also run the sfc /scannow from the elevated cmd...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:42.
Twitter Facebook Google+