Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 sp1 update error 8024200D and 8007000d

28 Sep 2012   #1

Windows 7 Ultimate x32
Windows 7 sp1 update error 8024200D and 8007000d

since the past 2 weeks i have been trying to install windows 7 sp1. When i use automatic updates sp 1 gets downloaded properly but while insalling i get the error 8024200D. I have used the system update readiness tool and microsoft fix it. Still the same error.

Here are the problems that i could find in CBS log
SPI: (SPIRegQueryDWORDValue:400)Failed to open the registry root: n/a, key: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ServicePack\SP1. er=0x2.

After i could not resolve this problem i decided to download and run the standalone installer of sp1. Then i got the error 8007000d while downloading

I also tried installing in both ways in clean boot with all services except microsoft disabled. Still the same error. PLz someone help me.

And i want to know if sp1 will be required to run upcoming and latest games??

My System SpecsSystem Spec
29 Sep 2012   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Please post the CheckSUR.log file from your run.
Note that a new version of the tool was released yesterday - please download a new copy and run that, and post the new Checksur.log file created.
My System SpecsSystem Spec

 Windows 7 sp1 update error 8024200D and 8007000d

Thread Tools

Similar help and support threads
Thread Forum
Windows Update Failed, error code - 8024200D
Hello, My windows update keeps failing on the same 5 updates with the error code 8024200D , This is really annoying me, I have tried everything on the internet i could find and nothing has worked, Can anybody help?, Thank you, Sean. Windows 7 Professional 64bit: Windows 7 Service Pack 1...
Windows Updates & Activation
Ms14-052 IE 11 update kb2977629 cannot install error 8007000D
My system is Windows 7 Professional Service Pack 1. I cannot install this update kb2977629. Error 8007000D.
Windows Updates & Activation
Windows Update [kb2843630], error 8024200d
Hello smart people. I require your assistance. Yesterday I installed Windows 7 Home Premium 64bit over my old Windows 7 Home Premium 32bit, and wow, there were a ton of updates. I got all of them installed except for one - kb2843630. I keep getting the same error code - 8024200d. I have...
Windows Updates & Activation
Windows Update error 800B0100 abd 8024200D
So after a clean install of Windows 7 on a new machine I have been having some bizzare problems (printers refusing to print with no errors and bluetooth devices failing to connect with no errors) and I'm hoping that the failure of these windows updates is at the root of it and hoping that I can...
Windows Updates & Activation
8007000D error Cannot update service pack 1
8007000D error Cannot update service pack 1, just did a restore to factory. Used a brand new service/recovery disks bought directly from acer for an aspire 5336-2524. Everything else is fine but continually fail to update and install service pack 1. I tried the suggested help center and the...
Windows Updates & Activation
Windows Update error 800B0100,8024200D and 800737712
Hi All, I rebuild my PC and did a clean install of Windows 7 64 Pro. I have been battling to get Windows update to work about half of the 54 important updates fail. I have tried: 1. Windows Update Readiness Tool - Didn't do anything as far as I could tell. 2. Microsoft Fix it in default and...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:37.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App