Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 Update failed error 8000ffff

10 Oct 2012   #1

Windows 7 Professional x86
Windows 7 Update failed error 8000ffff

I have been trying to install the latest windows 7 updates for several days and all of them (14) keep failing. The same error is received for all of them, Error 8000ffff. I researched what the updates were for and it looks like they are for Windows 7 x64, I have Windows 7 x86. Also, just before this happened I started getting an error message that my windows was not genuine. But I ran the activation and it says it is genuine (I have had Windows 7 Professional for a couple of years). I did some googling and ran into several post that suggested uninstalling KB971033 (for the windows not genuine error), so I did that and the error message no longer shows.

The windows Malicious Tool update worked just fine.

Any ideas?

My System SpecsSystem Spec
10 Oct 2012   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Uninstalling KB971033 just hides the problem, it does NOT solve it.
Please reinstall KB971033 from and then post an MGADiag report.

Please follow this tutorial and post an MGADiag report - then we can see what the problem is.

Please also state the Version and Edition of Windows quoted on your COA sticker (if you have one) on the case of your machine (or inside the battery compartment), but do NOT quote the Key on the sticker!
My System SpecsSystem Spec
11 Oct 2012   #3

Windows 7 Professional x86
MGADiag report

Thank you for your help with this. I re-installed the Windows Update KB971033. I also re-installed Windows 7 Professional. The only issue that was reported during the re-install was an issue with .NET Framework 4.0 which was resolved. After the reinstall, there were 66 updates that installed successfully. I still have 32 optional updates to go through.

Here is the MGADiag report results:
Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-3JKFQ-FC3VW-VMVV9
Windows Product Key Hash: TcIo3ZxHlBIaQMDoN+feCgUxwxg=
Windows Product ID: 00371-840-0276265-85945
Windows Product ID Type: 5
Windows License Type: Retail
Windows OS version: 6.1.7601.2.00010100.1.0.048
ID: {D5922FEC-03DB-4B9E-9CFC-3384A46E3F1A}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Professional
Architecture: 0x00000000
Build lab: 7601.win7sp1_gdr.120830-0333
TTS Error: 
Validation Diagnostic: 
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
OGAExec.exe Signed By: Microsoft
OGAAddin.dll Signed By: Microsoft

OGA Data-->
Office Status: 100 Genuine
Microsoft Office Access 2007 - 100 Genuine
Microsoft Office Project Professional 2007 - 100 Genuine
Microsoft Office Visio Professional 2007 - 100 Genuine
OGA Version: Registered,
Signed By: Microsoft
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files\Internet Explorer\IEXPLORE.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{D5922FEC-03DB-4B9E-9CFC-3384A46E3F1A}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010100.1.0.048</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-VMVV9</PKey><PID>00371-840-0276265-85945</PID><PIDType>5</PIDType><SID>S-1-5-21-2111140343-2501155965-1958600134</SID><SYSTEM><Manufacturer>Dell Inc.</Manufacturer><Model>Inspiron 1501 </Model></SYSTEM><BIOS><Manufacturer>Dell Inc.</Manufacturer><Version>2.6.2 </Version><SMBIOSVersion major="2" minor="4"/><Date>20060928000000.000000+000</Date></BIOS><HWID>5B383A07018400FE</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Mountain Standard Time(GMT-07:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>DELL </OEMID><OEMTableID>M08 </OEMTableID></OEM><GANotification><File Name="OGAAddin.dll" Version=""/></GANotification></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{90120000-0015-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Access 2007</Name><Ver>12</Ver><Val>2D5D4E0F0CC8F12</Val><Hash>M0lsW0zrjptJMZiO3VkJ2NzDD6Q=</Hash><Pid>89384-905-4771853-63454</Pid><PidType>1</PidType></Product><Product GUID="{90120000-003B-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Project Professional 2007</Name><Ver>12</Ver><Val>6CDEAA3D9CCD712</Val><Hash>MiAfSgR2XbIdtweMt8/Nph2gaZs=</Hash><Pid>89403-905-4771871-63162</Pid><PidType>1</PidType></Product><Product GUID="{90120000-0051-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Visio Professional 2007</Name><Ver>12</Ver><Val>17BE54CA876B712</Val><Hash>w0xp7n3Yog1gwJN4opKJIJIgq/o=</Hash><Pid>89405-905-4771781-63176</Pid><PidType>1</PidType></Product></Products><Applications><App Id="15" Version="12" Result="100"/><App Id="3A" Version="12" Result="100"/><App Id="53" Version="12" Result="100"/></Applications></Office></Software></GenuineResults> 

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, Professional edition
Description: Windows Operating System - Windows(R) 7, RETAIL channel
Activation ID: e838d943-63ed-4a0b-9fb1-47152908acc9
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00371-00170-840-027626-00-1033-7601.0000-2842012
Installation ID: 018900383162729882211090408545439181321803441765152995
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: VMVV9
License Status: Licensed
Remaining Windows rearm count: 4
Trusted time: 10/11/2012 5:25:50 AM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 10:6:2012 06:51
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x0
OEMID and OEMTableID Consistent: yes
BIOS Information: 
ACPI Table Name OEMID Value OEMTableID Value
FACP ATI Bowfin 
My System SpecsSystem Spec

11 Oct 2012   #4

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

There's no problem in the report at the moment - you appear to have validated on 6 Oct??
What happens if you validate at now?
(hint- it should pass, and you'll be offered MSE and IE9 or Windows Live)

The machine appears to have been originally shipped with Vista installed (probably for the launch date!)?

The KB numbers for 32-bit and 64-bit updates are the same - it's only the download locations and filenames that are different.

What AV are you using? (<aside> - Any odds on Norton {second choice McAfee}?</aside>)
My System SpecsSystem Spec
11 Oct 2012   #5

Windows 7 Professional x86

The validate was successful. I bought the laptop with Vista and upgraded to Windows 7 Professional a couple of years ago. I am using Norton Security Suite.
Everytime I went to Genuine Microsoft Software to validate it would be successful, activating windows was always successful. I just kept getting the popup window saying it wasn't genuine.

I attached the popup window I used to get.

Attached Images
Windows 7 Update failed error 8000ffff-not-genuine-windows.jpg 
My System SpecsSystem Spec
12 Oct 2012   #6

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

I suspect I know what the problem was on the old install
The SATA/RAID drivers - older Intel Rapid Storage (in your case more likely Intel Matrix) Technology drivers have been causing problems after updates - or at least, that's what seems to be the case, as reinstalling them or updating them clears the error, and the system speeds up :)
My System SpecsSystem Spec

 Windows 7 Update failed error 8000ffff

Thread Tools

Similar help and support threads
Thread Forum
Error Code 8000FFFF and Windows 7 Update
Days and Days of trying to repair this. This: Windows will not update. Periodic messages that my Windows is not genuine. One entire day of failed installation of clean install with Windows 7 USB stick provided by Dell. A few hours with a very sweet techie, who did the most basic stuff. I have run I...
Windows Updates & Activation
Windows Update Error 8000FFFF
Hopefully I am submitting this new post correctly? I seemed to have a similar issue as others in updating Windows Update successfully. Below is my diagnostic report. Thank you. Diagnostic Report (1.9.0027.0): ----------------------------------------- Windows Validation Data--> Validation...
Windows Updates & Activation
Windows Update Error 8000FFFF
Hello Sevenforum Experts, I tried to solve the problem with the Update on my own. But nothing works... I always get the Update Error Code 8000FFFFF. I ran already the System Update Readiness Tool and SFC Scan It would be great if somebody could please help me with that.
Windows Updates & Activation
windows update error code 8000FFFF
hi there, spent days trying to download latest windows updates . every time i keep getting the failed to download message and with it error code 8000FFFF. tried using the microsoft fixit , but doesnt fix it ! tried pausing kaspersky but no success... tried installing each of the updates one at a...
Windows Updates & Activation
Windows Update failed - code error 8000ffff
hello about a month I have a problem with the updates of windows 7 professional 32 bit. When I turn on the PC, Windows tries to install an update, it hangs at 35% and the pc restarts 3 times before using it. after, if I click on search updates, I have error code 8000ffff. I tried microsoft fixit...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:44.
Twitter Facebook Google+