Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Update for service pack 1 not installing, tried loads of things...

24 Oct 2012   #1

64bit windows 7
Update for service pack 1 not installing, tried loads of things...


I have windows 7 64 bit genuine. I have never been able to install windows update service pack 1. Every other update works fine.

I have tried using the windows ready update thing that checks your system and it says its fine.

I have also used Check disc, defragged, done system restore, disabled antivirus and tried again but still it resets but when windows loads up onto desktop again, it comes up with install error.

Would this have anything to do with the fact that even after doing a system restore, it seems sometimes when I click control panel or windows update or itunes etc nothing at all happens. Sometimes nothing I click on works and it just says not responding, everything except firefox....

Any help would be great as It is driving me mad, hard drive is only 6 months old so did not think it could be that?
My System SpecsSystem Spec
24 Oct 2012   #2
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

My System SpecsSystem Spec
24 Oct 2012   #3
Microsoft MVP

Windows 7 Ultimate 32bit SP1

Have you run an Anti-virus scan?
My System SpecsSystem Spec

25 Oct 2012   #4

64bit windows 7

I have done full antivirus check with Norton, run CCleaner and also malwarebytes.

I have tried the above about system check and manual install, still the same error.. any other ideas?

I have noticed a fault in event logs every time I switch computer on:

This driver took longer to initialize, resulting in a performance degradation in the system start up process:
File Name : eeCtrl
Friendly Name : Symantec Eraser Control Driver
Version :
Total Time : 633ms
Degradation Time : 526ms
Incident Time (UTC) : ‎2012‎-‎10‎-‎25T18:41:24.562400100Z


Windows has started up:
Boot Duration : 72859ms
IsDegradation : false
Incident Time (UTC) : ‎2012‎-‎10‎-‎25T18:41:24.562400100Z


Windows has shutdown:
Shutdown Duration : 11508ms
IsDegradation : false
Incident Time (UTC) : ‎2012‎-‎10‎-‎24T19:23:45.964982700Z

are these related?
My System SpecsSystem Spec
25 Oct 2012   #5

64bit windows 7

i have just run the trouble shooter, system readiness tool and turned off all security programs and still get the exact error message when system resets to finish the install

it says:

Installation was not successful

Element not found

Details: ERROR_NOT_FOUND(0x80070490)
My System SpecsSystem Spec
25 Oct 2012   #6
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Two things come to mind. Remove Nortons completely. Using their/there on line removal tool for your particular program. Just because it is deactivated is not good enough. It can still have it's fingers in things. Install MSE and see if things work.
Microsoft Security Essentials - Microsoft Windows
If things still don't work I suggest a repair install. Please read completely before using.
Repair Install
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
BSOD installing Service pack 1
Hello, My friend is getting BSOD 0x7b when starting up his computer after he tried updating his windows 7 to service pack 1. All goes back to normal after using system restore. Sorry I didn't include the log file don't have access to that pc at the moment. As I understand this happens because of a...
BSOD Help and Support
Installing Service Pack 1 ruined everything
So as you may all know, Windows 7 officially started to have Service Pack 1 start to automatically install on March 19. So it just installed for me last night (without my permission)... and It screwed me good and hard. I have lost pretty much every single preference on my computer. Browser ...
Windows Updates & Activation
Windows 7 Service Pack 1 not installing
Hi I tried to install Windows 7 service pack 1 but had and error saying it could not install. I followed the instructions and downloaded the Update Readiness Tool With the following report. ================================= Checking System Update Readiness. Binary Version 6.1.7601.21645...
Windows Updates & Activation
Problem installing Service Pack 1 (SP1)
I have a PC running windows 7 64-bit and I am finding it impossible to get windows 7 Service Pack 1 (SP1) to install. I start the installation and it seems to run for more than an hour and appears to be installing OK; but when I restart the PC I get an error saying that the installation was not...
Windows Updates & Activation
Is installing service pack 1 really that important?
I currently have all my updates current except for service pack 1 and I feel my systes is pretty doggone smooth these days. Questions: 1.) Will upgrading to service pack 1 potentially make my system any slower because of extra stuff added I don't really need? 2.) Is it important to install...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:04.
Twitter Facebook