Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Update doesn't work

06 May 2013   #1

Windows 7 x64
Windows Update doesn't work

I am running Windows 7 x64 on my Asus G73JH laptop.

I already performed a clean reinstall in the hopes of fixing this problem but to no avail.

So my issue is when I open Windows Update and click on the check for updates button it does one of two things. It either just flashes to the checking for updates loading screen and then returns to normal, or gives me an error stating that the Windows Update service is not running despite it really being up.

I have tried the Windows Fixits and many other solutions such as deleting certain folders and restarting the service but none have worked so far.

My System SpecsSystem Spec
06 May 2013   #2

Windows 7 x64

This is also the log file I receive when I attempt an installation of .NET Framework 4 Standalone Installer

OS Version = 6.1.7600, Platform 2
OS Description = Windows 7 - x64 Home Premium Edition
CommandLine = C:\f5870403d8371dd6be3d8c307aab\\Setup.exe /x86 /x64
TimeZone = Central Daylight Time
Initial LCID = 1033
Using Simultaneous Download and Install mechanism
Operation: Installing
Package Name = Microsoft .NET Framework 4 Setup
Package Version = 4.0.30319
User Experience Data Collection Policy: AlwaysUploaded
Number of applicable items: 11
Exe (C:\f5870403d8371dd6be3d8c307aab\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
ServiceControl operation succeeded!
ServiceControl operation succeeded!
Exe (C:\f5870403d8371dd6be3d8c307aab\Windows6.1-KB958488-v6001-x64.msu) failed with 0xc8000247 - (null).
Final Result: Installation failed with error code: (0xC8000247) (Elapsed time: 0 00:00:06).
My System SpecsSystem Spec
07 May 2013   #3

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

From the looks of it you need an updated copy of the IRST drivers
To confirm this, please post an MGADiag report,

Please follow this tutorial and post an MGADiag report - then we can see what the problem is.

Ignore errors produced when clicking on the Copy button - they simply mean that the tool could not create the backup files for some reason. The data is still copied to the clipboard for pasting to your response.

Please also state the Version and Edition of Windows quoted on your COA sticker (if you have one) on the case of your machine (or inside the battery compartment), but do NOT quote the Key on the sticker!
My System SpecsSystem Spec


 Windows Update doesn't work

Thread Tools

Similar help and support threads
Thread Forum
windows update doesn't work
I googled it for an hour and 1/2 trying a ton of things but no joy. First, i enabled WU in services because i had it disabled. Then i restarted and it was running. Tried to update and it said on important update so i trued to download it. It stayed at 0% forever so i tried a few things i read and...
Windows Updates & Activation
Altgr doesn't work after windows update, help!
Hi, I just joined the forum and this is my first post, so i apologize if it's not the right section. I just did a major update to the system, even though about every time I update Windows, something stops working. I couldn't resist the urge... After the update i noticed my alt gr key it's not...
General Discussion
Windows Update doesn't work.
forget about my post ... there´s an other place it fit´s better ... sorry for mistake ############################# i have also just set up a old samsung-notebook with Win7-ultimate-x32 and Windows Update doesn´t work. Please, Please someone can help. I still have tried several things. But...
Windows Updates & Activation
Windows Update Doesn't Work in Domain Environment
I'm trying to set up a new PC around the office, but as soon as I establish a connection to the domain, Windows Update keeps giving me ERROR: 8024402F. This may sound wacky, but I've narrowed the problem down to the clock (as in time). After checking the Event Viewer logs I found this... Log...
Windows Updates & Activation
Windows Update doesn't work
I purchased a Gateway desktop with Win7 installed, but no installation disc. When I try to run Windows Update, it takes me to the site, but the shield is X'd out, and it tells me the service is not running, although in fact it is. I have seen others reporting this same problem, at sites all over...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:13.
Twitter Facebook