Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Update not working

26 May 2013   #1

windows 7 64bit
Windows Update not working

I am having trouble with the Windows Update.

I have been on holiday and missed the May 2013 update on starting my PC today I tried going to the Windows Update since strangely, although I had been using my PC for a while the update hadn't started uploading as usual.

I had great difficulty actually opening the Windows update window and when it finally did it said the 'windows update cannot currently check for updates because the service is not running window 7'. I have tried several solutions as detailed in: windows update cannot currently check for updates because the service is not running window 7 HELP

But to no avail. The window doesn't open when I click in Control Panel and I cannot close control panel have, to shutdown Explorer.exe process then restart it.

Tried the Windows fixit program []Microsoft Fix it Solution Center: troubleshooting software issues downloaded as instructed and let it run said all problems fixed try it. Tried and windowsUpdate window now opens satisfactorily but says: Service is not running restart. I have done so and still same message appears. Checked SERVICES.MSC and BITS and update set to Automatic (Delayed Start).

Have also downloaded the System Update Readiness Tool for Windows 7 for x64-based Systems (KB947821) [February 2013] but when I tried to run message: installer encountered an error 0xc8000247.

Attached the CBS zip file as instructed

Please advise.



My System SpecsSystem Spec
26 May 2013   #2
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

The first thing that comes to my mind is check the time and date in bios and Windows.
Sometimes when a system set a long time with a weak bios battery the time will be wrong.
I would also try a manual Windows Update.

You could also check and see if Microsoft still love you.
Attachment 269865

If none of this helps I recommend going here.
My System SpecsSystem Spec
27 May 2013   #3

windows 7 64bit
Microsoft update not working

Thanks for your reply Layback Bear, you are right it seems Microsoft doesn't like me!

On restarting my PC from sleep this morning I got a window which stated need to verify that I am using a genuine Window OS [which I know I am since I have the original installation disk].

Downloaded the verification software as instructed and clicked run, it tried to install but then same - installation error 0xC8000247.

So I'm back to square one

The emoticon says it all....

My System SpecsSystem Spec

27 May 2013   #4

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64 +Linux_VMs +Chromium_VM

I don't see the attached CBS zip file

Screenshots and Files - Upload and Post in Seven Forums
My System SpecsSystem Spec
27 May 2013   #5

windows 7 64bit

I'm sorry David seems I did not click the upload button. I'm so new at this my apologies to all you guys trying to help.

My System SpecsSystem Spec
27 May 2013   #6

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64 +Linux_VMs +Chromium_VM

No problem and welcome to Seven Forums!
That file should help the experts here get this sorted out.
My System SpecsSystem Spec
15 Sep 2013   #7

Windows 7 32bit

I am experiencing the same issue. I have the results of the Diagnostic report and added the CBS file. Can someone help?

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-KV3GM-MF2TV-9XDG2
Windows Product Key Hash: NVG8/+w9DzwS3MnLbK/h1lg68xw=
Windows Product ID: 00426-437-6790992-85796
Windows Product ID Type: 5
Windows License Type: Retail
Windows OS version: 6.1.7601.2.00010100.1.0.001
ID: {9A06E7C2-E9AE-468C-9BB8-E35271A83C0B}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: 
Build lab: 
TTS Error: 
Validation Diagnostic: 
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 100 Genuine
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3_70AFE6BE-116-80040154_63BB5E84-298-80040154_E2AD56EA-85-80040154_16E0B333-89-80040154_B4D0AA8B-1029-80040154

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->

Spsys.log Content: 

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, Ultimate edition
Description: Windows Operating System - Windows(R) 7, RETAIL channel
Activation ID: ac96e1a8-6cc4-4310-a4ff-332ce77fb5b8
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00426-00170-437-679099-01-1033-7600.0000-1772012
Installation ID: 016253416822999986118453068513990550298514805123786771
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: 9XDG2
License Status: Licensed
Remaining Windows rearm count: 3
Trusted time: 9/15/2013 6:33:37 PM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 6:20:2013 23:33
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes, but no SLIC table
Windows marker version: N/A
OEMID and OEMTableID Consistent: N/A
BIOS Information: 
  ACPI Table Name    OEMID Value    OEMTableID Value
  APIC            DELL          4700   
  FACP            DELL          4700   
  HPET            DELL          4700   
  BOOT            DELL          4700   
  MCFG            DELL          4700   
  SSDT            DELL        st_ex
  ASF!            DELL          4700
My System SpecsSystem Spec

 Windows Update not working

Thread Tools

Similar help and support threads
Thread Forum
USB not working after Windows Update
Computer was fine on Friday but this morning after an update has been applied I have no USB hence no keyboard or mouse. I'm able to access the computer from anoth PC via Teamviewer so can make changes etc no problem. So far I've spent the entire day trying different things to sort this out but to...
Hardware & Devices
Rdp not working after windows update
I recently performed all the windows updates and now rdp will not open. The error says Could not load the Remote Desktop Service ActiveX control. Make sure mstscax.dll is in the path. I confirmed the extension is in there. I uninstalled an update that was possibly to blame. I replaced the...
Network & Sharing
Internet not working, windows update, ping, DNS, etc. working fine
Hello, I've got a Dell laptop here that isn't functioning properly. I can't get this to work for the life of me! I am currently using this laptop with a different hard drive, it's the install on the SSD that doesn't work. I know that the quick fix would be to simply reload windows, but I don't...
Network & Sharing
Windows Update is not working/Update Readiness Tool won't install
Win 7 64 Windows Update not working (post migration), nor is Windows Update Readiness tool installing. I have renamed catroot and stopped services, nothing working. I just migrated HD to a hybrid solid state (Seagate Momentus). I had this problem both with Acronis 2009 and Acronis 2013, and...
Windows Updates & Activation
Windows Update not working
Fresh install of Windows 7 and i have tried the readiness update which comes back with no errors in the log. I have removed firewall and antivirus and still cannot get the Microsoft Updates (it is just the security related ones) to install. I have also run the sfc /scannow from the elevated cmd...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:23.
Twitter Facebook Google+