Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win7 SP1 failes to update

02 Jul 2013   #1

Windows 7 Ultimate x64
Win7 SP1 failes to update

Hello community

A problem keeps appearing, when trying to install Windwos 7 Service Pack 1 (KB976932) on a computer of a user. Since I'm not a great troubleshooter and Google hasn't provided me with any useful information (yet), I thought I might ask for some help here.

- Virtual Windows 7 Enterprise x86 machine (VM)
- 2 GB RAM
- Intel(R) Xeon(R) CPU X5650 @ 2.67 GHz (2 processors)

Windows Update History
- Error details: Code 800706BE

-Event ID 7
Error Code: 0x80070002

-Event ID 8
Error Code 0x80070002

-Event ID 20
Error Code 0x80070643

Done so far:
- tried installing update after diagnostic startup (basic devices and services only)
- installed and executed System Update Readiness Tool (SURT)
- performed sfc /scannow (3 times)
C:\Windows\system32>sfc /scannow
Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.
Windows Resource Protection found corrupt files but was unable to fix some of th
Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example
- performed microsoft "fix it" regarding error code 0x80070002

The user has tried several times to install this update without informing the IT about this problem. So in the log files there might be quite a few errors. The failed installation was noticed through our WSUS-Console (Update Services).

C:\Windows\Logs\CBS should be attached as
If any further information is needed (e.g screenshots), I'd be happy to upload them also. In the mean time, I'll keep on trying to find a solution, but would be very grateful if some one more experienced than I could have a look at this!

Thanks in advance,

My System SpecsSystem Spec
02 Jul 2013   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

You have some major corruption there!
In addition to 15 problem files in the SFC, you also have over 460 'Missing Payload Files' in the CheckSUR report.

The vast majority of all these is media files - mp3, jpg, wmv etc....
-- but there are 66 .dll and 29 .exe files missing in there.
It's as if someone tried to strip out Windows Media Player, and the Games, and remove all media files from the system.

A repair install is really your only hope, other than a clean install - if it works.
My System SpecsSystem Spec
02 Jul 2013   #3

Windows 7 Ultimate x64

Hi NoelDP

Thanks allot for having a look at this problem for me. You have surely saved me lots of time. As you recommended, I'll give the repair installation a try, bevor a clean re-installation.
As for the .dll-hell and other missing stuff, I can't explain what the user did here...

I'll mark this thread as solved, since from here on I can handle it. Thanks again! In case something interesting should happen, I'd keep you posted.
My System SpecsSystem Spec

02 Jul 2013   #4

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

You're welcome - good luck with it!
My System SpecsSystem Spec
02 Jul 2013   #5

W7x64 Ult.

Did you disconnect your data drives before the update attempt? That can cause a problem.....
My System SpecsSystem Spec
03 Jul 2013   #6

Windows 7 Ultimate x64

Quote   Quote: Originally Posted by Outlander View Post
Did you disconnect your data drives before the update attempt? That can cause a problem.....
Hi Outlander

Unfortunately it is a VM with only one (C:\) drive. But thank you very much for the advice!
My System SpecsSystem Spec

 Win7 SP1 failes to update

Thread Tools

Similar help and support threads
Thread Forum
Win7 home update fails, error 8007370B - cannot update, install SP1.
Running Windows 7 Home Premium x64 Cannot update, attempting to upgrade to Win 7 professional. Discovered automatic updates were fried for some time and the system did not have SP1, which is apparently required for the upgrade. I see similar threads, each seems to require advanced...
Windows Updates & Activation
Win7 Ultimate Update Failed to Win7 Sp1 Error Code 80073701
Hello I'm Having Problem Updating My Windows 7 Ultimate into Windows 7 Ultimate SP1 I Tried Using System Update Readiness Tool for Windows 7 (KB947821) But an Error Pops Up Please HELPP!!:cry:
Windows Updates & Activation
WiFi internet randomly failes
Toshiba laptop, Windows 7 Ultimate x86, RTL8187b WiFi NIC. Clean install. Opening a new site is working ok and fast, when clicking on a link on the website, I get a very slow response or a time-out...When I do the same thing at the same time on a wired computer or/and on a Ipad (wireless), the...
Network & Sharing
Error Code 80070643 Powerpoint (KB2464594) update failes
Hello, I received updates today and one was for a Power Point 2007 (KB2464594) security issue. I've rolled my system back (RollBackRx) and still can't get this update to install. I've read what I've found and none of it has been helpful. I understand this is a general error but have no idea...
Windows Updates & Activation
Backup failes with error 0x80070570
hi, i try to backup my data to an external usb-disk. as soon as the backup software wants to write to the disk an error 0x80070570 is displayed. i can access this disk without problem and i also use it for storing the system images. the strange thing is that i managed to do a single backup to...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:54.
Twitter Facebook