Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 9C57 error updating on IE 10, now IE 11-- this one's a toughie

19 Dec 2013   #1

Windows 7 Home Premium x64
9C57 error updating on IE 10, now IE 11-- this one's a toughie

Hi, I believe I'm at the end of my rope. Since some MS update around June, I've been really hosed on my Windows 7 Home Premium x64 machine. I was not able to install IE 10, so I hid the update, and now I cannot install IE 11, just the same. It errors out with the 9C57 error, which indicates uninstalled prerequisites. When I attempt to manually install the stated prereqs, the error is "the update is not applicable to your computer."

Here's where I'm at, and what I've tried:

1. sfc /scannow is clean, no integrity violations.
2. MS FixIt shows no errors.
3. CheckSUR is clean, No errors detected.
4. A Windows 7 Home Premium x64 repair install fails; it goes through the entire process with multiple reboots, then restores the old system and claims that "This version of windows cannot be installed." The installation bits & version (Home Premium SP1 U x64) match my installed version.

Any assistance would be very greatly appreciated. I've been deep in this for too long, and could use another set of eyes. I have attached my, also with the %systemroot%\IE11_main.log showing the prereq patch failures, and the %systemroot%\Logs\WU_IE11_Packages.log.

Thank you so much and happy holidays,

My System SpecsSystem Spec
20 Dec 2013   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

These could be the errors that are breaking things...
2013-12-19 18:26:06, Info                  CBS    Identity missing version. [HRESULT = 0x80070057 - E_INVALIDARG]
2013-12-19 18:26:06, Error                 CBS    Failed to shred identity: Microsoft-Windows-InternetExplorer-LanguagePack [HRESULT = 0x80070057 - E_INVALIDARG]
Unfortunately I'm not sure where in the registry the failure is occurring.
I think it's in the Components Hive, in an entry referring to this package...

Let's have a look...

I need to have a look at your COMPONENTS registry hive

Please copy the C:\Windows\System32\config\COMPONENTS file (no extension) to your desktop and then compress it - upload the compressed file to your favoured fileshare site (preferably Dropbox or SkyDrive) and post a link.
My System SpecsSystem Spec
20 Dec 2013   #3

Windows 7 Home Premium x64

OK, the hive is at

Thank you Noel!

I should note also that Belarc Advisor claims that a large number of applicable fixes aren't present on my system (but these do not show up in Windows Update, at any rate):

--- begin Belarc output --
Missing Security Updates new – for Adobe, Apple, Java, Microsoft and more [Back to Top]

Hotfixes from Microsoft Update (agent version 7.5.7601.17514) install automatically.
Last install: 12/20/2013 12:21:39 PM, download: 12/20/2013 12:21:54 PM, check: 12/20/2013 12:26:12 PM.

These security updates apply to this computer but are not currently installed (using Advisor definitions version 2013.12.18.1), according to the 12/10/2013 Microsoft Security Bulletin Summary and bulletins from other vendors. Note: Security benchmarks require that Critical and Important severity security updates must be installed.

Hotfix Id Severity Description (click to see security bulletin)
CpuOct2013-1899837 Critical Oracle Java SE Critical Patch Update for Java 64-bit
Q2479943 Critical Microsoft security update (KB2479943)
Q2509553 Critical Microsoft security update (KB2509553)
Q2532531 Critical Microsoft security update (KB2532531)
Q2536275 Important Microsoft security update (KB2536275)
Q2536276 Critical Microsoft security update (KB2536276)
Q2544893 Important Microsoft security update (KB2544893)
Q2579686 Important Microsoft security update (KB2579686)
Q2585542 Important Microsoft security update (KB2585542)
Q2619339 Critical Microsoft security update (KB2619339)
Q2631813 Important Microsoft security update (KB2631813)
Q2653956 Critical Microsoft security update (KB2653956)
Q2685939 Critical Microsoft security update (KB2685939)
Q2690533 Important Microsoft security update (KB2690533)
Q2691442 Important Microsoft security update (KB2691442)
Q2705219 Moderate Microsoft security update (KB2705219)
Q2712808 Moderate Microsoft security update (KB2712808)
Q2743555 Important Microsoft security update (KB2743555)
Q2757638 Critical Microsoft security update (KB2757638)
Q2770660 Important Microsoft security update (KB2770660)
Q2840149 Moderate Microsoft security update (KB2840149)
--- end Belarc output ---
My System SpecsSystem Spec

22 Dec 2013   #4

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

The Belarc output is interesting - many of those updates are pretty old.
I'm assuming that none show in the Windows Update listing?
Whenever I've had problems installing IE11, I've always been able to solve them by installing IE10 first - so I propose to try that route first.

Please download the IE10 x64 installer from here...

(It's classed as an Update Rollup!)

Try installing it - then post the following files..

My System SpecsSystem Spec
23 Dec 2013   #5

Windows 7 Home Premium x64

Thank you for looking at this. As mentioned above these Belarc-reported updates do not show up in Windows Update. My problems with IE10 for several months were the same as they are now with IE11-- missing prerequisites that, when I try to run them manually state "the update is not applicable to your computer." In fact, they are the same KB updates required by IE11.

From CBS.log, the prereq updates fail with:
2013-12-23 12:24:05, Info CBS Failed to internally open package. [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE]

I have also tried moving/resetting the \Windows\SoftwareDistribution\DataStore and \Windows\SoftwareDistribution\Download dirs to no avail.

The IE10 installation fails with "Internet Explorer needs an update before installing" "Go online and install the required update..." which of course fails just as it does with IE11-- it throws me to a very similar page at MS where each of the required updates fail out with the above "the update is not applicable to your computer."

The requested logs are at, although there was no IE10_NR_Setup.log generated by the IE10 install attempt.

Thanks again!
My System SpecsSystem Spec
23 Dec 2013   #6

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

The IE10 install fails due to the lack of a prerequisite update
01:28.842: ERROR: Error installing prerequisite file (C:\Windows\TEMP\IE1C764.tmp\KB2834140_amd64.MSU): 0x800f081e (2148468766)

See if installing the update alone works - Download Update for Windows 7 for x64-based Systems (KB2834140) from Official Microsoft Download Centre

If it fails, please post an MGADiag report, as there may be something there that will give us a clue..

we need to see a full copy of the report produced by the MGADiag tool
(download and save to desktop - )
Once saved, run the tool.
Click on the Continue button, which will produce the report.
To copy the report to your response, click on the Copy button in the tool (ignore any error messages at this point), and then paste (using either r-click/Paste, or Ctrl+V ) into your response.
My System SpecsSystem Spec
23 Dec 2013   #7

Windows 7 Home Premium x64

KB2834140 was one of the stated prerequisites; I have a slew of them saved off into a folder: "The update is not applicable to your computer."

MGADiag report:
Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-F9KGX-RC7JK-8GBP4
Windows Product Key Hash: +2u56N5Cd3oaGpcr/SGPhry/p80=
Windows Product ID: 00359-OEM-8702191-24477
Windows Product ID Type: 3
Windows License Type: OEM System Builder
Windows OS version: 6.1.7601.2.00010300.1.0.003
ID: {1B24DE21-42BE-47F5-BD1E-5F4C21BD7623}(3)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: Registered,
Signed By: Microsoft
Product Name: Windows 7 Home Premium
Architecture: 0x00000009
Build lab: 7601.win7sp1_rtm.101119-1850
TTS Error:
Validation Diagnostic:
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{1B24DE21-42BE-47F5-BD1E-5F4C21BD7623}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-8GBP4</PKey><PID>00359-OEM-8702191-24477</PID><PIDType>3</PIDType><SID>S-1-5-21-4002960993-1707218947-265954237</SID><SYSTEM><Manufacturer>MSI</Manufacturer><Model>MS-7818</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>V1.6</Version><SMBIOSVersion major="2" minor="8"/><Date>20131014000000.000000+000</Date></BIOS><HWID>DAB93607018400F4</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Pacific Standard Time(GMT-08:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, HomePremium edition
Description: Windows Operating System - Windows(R) 7, OEM_COA_NSLP channel
Activation ID: 586bc076-c93d-429a-afe5-a69fbc644e88
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00359-00174-021-924477-02-1033-7600.0000-1752008
Installation ID: 007380576464705870422966602286157555264325357535290594
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: 8GBP4
License Status: Licensed
Remaining Windows rearm count: 4
Trusted time: 12/23/2013 1:47:26 PM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 10:8:2013 08:19
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes, but no SLIC table
Windows marker version: N/A
OEMID and OEMTableID Consistent: N/A
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
SSDT PmRef Cpu0Ist
SSDT PmRef Cpu0Ist
SSDT PmRef Cpu0Ist
SSDT PmRef Cpu0Ist
SSDT PmRef Cpu0Ist
My System SpecsSystem Spec
23 Dec 2013   #8

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Hmm - the 'not applicable' error is one that we would expect to be produced if you'd downloaded the x86 version of the installer, rather than the x64 version.... or I would have expected some kind of indication of it in the CheckSUR, or the CBS logs.

The MGADiag report is fine - I was hoping for some errors in there which may have given a clue, in terms of DLL files being unregistered, but everything looks perfectly normal and proper.

I'm falling asleep at the wheel here - more tomorrow
My System SpecsSystem Spec
23 Dec 2013   #9

Windows 7 Home Premium x64

Yes, I figured this wasn't an easy one. FWIW I ran the CheckSUR again:

Checking System Update Readiness.
Binary Version 6.1.7601.22471
Package Version 22.0
2013-12-23 16:20

Checking Windows Servicing Packages

Checking Package Manifests and Catalogs

Checking Package Watchlist

Checking Component Watchlist

Checking Packages

Checking Component Store

Seconds executed: 214
No errors detected

My System SpecsSystem Spec
27 Dec 2013   #10

Windows 7 Home Premium x64

I guess what I'm most worried about, is if this system is shot for Windows 7 and the repair install is failing, do I have any hope of a Windows 8.1 upgrade? Is there any way to test an 8.1 upgrade without first purchasing it?
My System SpecsSystem Spec

 9C57 error updating on IE 10, now IE 11-- this one's a toughie

Thread Tools

Similar help and support threads
Thread Forum
error code 9c57 when installing IE11
Hi seven forum members, i'm having a problem while installing ie11, the error code is 9c57 when installing ie11 only. but when i update via windows update i get the error: 9c59 My cbs log's are included, if someone can help me out it would be much appreciated.
Windows Updates & Activation
Error code 9C57 when updating with IE11
Hello All, I having an issue with updating my Window SP1 with IE11 and some other updates. I have tried all possible combinations mentioned on the forum threads, but with no success. As requested,I have installed the SURT tool and the log files are attached for your reference. Would...
Windows Updates & Activation
Windows Update Error Code 9C57
Hello all my computer recently got messed up last week and i was just able to get it fixed the other night, however though i was able to install all my updates, except for IE10 and i started getting error code 9C57 Windows Encounters an Unknown error, it won't let me attach the CBS log i keep...
Windows Updates & Activation
IE10 not updating error code: 9C57
Hi all, I want to update IE10 because i need it for Games for live, I get that error when updating it and when I download it via IE10 website it gives me an error saying that it need to update via windows update.
Windows Updates & Activation
IE 10 install failure - Error code 9C57
First post, thanks in advance for any help. Problem: IE 10 update fails to install. What I've done so far: Updated all drivers for everything under device manager Windows fixit program to no avail
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:01.
Twitter Facebook Google+