Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 Service Pack 1, error 0x80070643

15 Feb 2014   #1

Windows 7 Professional x64
Windows 7 Service Pack 1, error 0x80070643

Hi, I have been trying to install the Windows 7 SP1, unsuccessfully, for most of a week now. The update does not appear in my Windows Update program, so I used the online version on The update installs correctly, but after restarting and beginning the "configuring windows" process, it only reaches about 50% before it states that there has been a fatal error and reverts the changes. It goes into a mini-loop where it configures and then reverts several times, before finally restarting with all changes reverted. I always get error code 80070643. I followed all the directions for this error on, including running the System Update Readiness tool (no errors) and the sfc scan (also no errors), disabling the firewall and all anti-virus programs, and uninstalling/reinstalling the .NET framework. I also tried downloading SP1 to my desktop and running it that way to bypass any problems related to my internet. I posted on Microsoft answers and received no replies, so any help I get here will be greatly appreciated. I've attached my log collection. Thanks again!

My System SpecsSystem Spec
16 Feb 2014   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

There appears to be a problem with one particular update..
2014-02-15 13:25:40, Info                  CBS    Exec: Processing started.  Client: WindowsUpdateAgent, Session: 30354051_3058463317, Package: Package_for_KB2719033~31bf3856ad364e35~amd64~~
2014-02-15 13:25:51, Info                  CBS    Exec: Staging Package: Package_3_for_KB2719033~31bf3856ad364e35~amd64~~, Update: 2719033-6_neutral_GDR, PinDeployment: amd64_079a43fa6c6e58cb026f8974f9a685c5_31bf3856ad364e35_6.1.7600.17034_none_ebb25be7180fab86
2014-02-15 13:25:51, Info                  CBS    Exec: This is a PSF Package.  Job has been saved and we are returning to client.
2014-02-15 13:25:51, Info                  CSI    0000014d@2014/2/15:19:25:51.315 CSI Transaction @0x4486b80 destroyed
2014-02-15 13:25:51, Info                  CBS    Exec: DPX job state saved for one or more packages, aborting the staging and install of execution.
2014-02-15 13:25:51, Info                  CBS    Perf: Stage chain complete.
2014-02-15 13:25:51, Info                  CBS    Failed to stage execution chain. [HRESULT = 0x800f0816 - CBS_E_DPX_JOB_STATE_SAVED]
2014-02-15 13:25:51, Error                 CBS    Failed to process single phase execution. [HRESULT = 0x800f0816 - CBS_E_DPX_JOB_STATE_SAVED]
There ar also a large number of errors of this type...
 Line 6017: 2014-02-15 13:18:35, Info                  CBS    Failed to get session package state for package: Package_7_for_KB2563227~31bf3856ad364e35~amd64~~ [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
 Line 7313: 2014-02-15 13:18:36, Info                  CBS    Failed to get session package state for package: Package_1_for_KB2604114~31bf3856ad364e35~amd64~~ [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
0490 errors are often very difficult to resolve - and it may be easier and quicker to do a repair install, since there are so many.

See the insructions here - Repair Install - I would advise downloading the SP1 version of an install disk and using that, as it will bypass the need for the later install of SP1.
My System SpecsSystem Spec
16 Feb 2014   #3

Windows 7 Professional x64

Thanks, Noel. I've started the download for the repair install Windows SP1 version and will let you know how it goes in the next couple of days when I have the chance to finish the process.
My System SpecsSystem Spec

17 Feb 2014   #4

Windows 7 Professional x64

Okay, I tried to do the repair install, but I got a message that said that I can't use an SP1 iso without having SP1 currently, which is the whole problem. I tried a download link without SP1 from the same site, but all i get is an error message saying that it isn't a valid iso, and when i used an extractor, i'm left with an .img file, not an .exe file, so manually formatting my usb drive didn't work either. Do you know of any links for non-Sp1 files that contain the proper materials? or am i just missing an obvious step somewhere?

EDIT: Managed to find instructions on what went wrong (I needed to format the .iso to include UDF). Trying again!
EDIT 2: now I'm getting an error that it cannot copy the file; rufus says it cannot extract it from the image and I am getting ever more frustrated.
EDIT 3: On advice found in another section of this forum, I mounted the .iso and it worked like a charm. I now have Windows 7 SP1 and didn't lose any of my data. Thank you guys so much!
My System SpecsSystem Spec

 Windows 7 Service Pack 1, error 0x80070643

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 service pack 1 error 800736b3
Sorry for my english, I tried to find the solution in the forums of my country and did not solve the problem * I am trying to install "windows 7 service pack 1 (kb976932)" but I am not succeeding, all the ports of the error (800736b3) in Windows Update. I tried downloading from Microsoft's website...
Windows Updates & Activation
Factory Windows 7 Service pack 1 but service pack shows in updates?
Just bought new never used factory fresh PC Acer AXC-605-UR29 Windows 7 Service Pack 1 manufacrtured this year, I checked for latest updates and sure enough Service Pack 1 shows up in updates Windows 7 Service Pack 1 for x64-based Systems (KB976932) Download size: 9.1 MB
Windows Updates & Activation
Windows 7 Service Pack 1 - Error 80004005
I have been trying to install Service Pack 1 on Windows 7 (64-bit), but I keep getting an error code of 80004005. I've run scan disk, which repaired some files, but the error message still comes up. I need this update to install IE11. Any ideas?
General Discussion
Error 0x80070643 Service pack 1 install failure
About a week ago, I installed a new SSD and configured it as my boot drive running Win 7 Ultimate. Everything was working fine until yesterday. I ran windows update and attempted to install 2 updates and was prompted to restart. I clicked start-->install updates and shut down. When it was shutting...
Windows Updates & Activation
Windows 7 32-Bit Service Pack 1 Installation Error...
Wonder if you guys can help with an installation of SP1 for Windows 7 32-Bit. I have attached the cbs.log containing the error information however all the fixes suggested around the net (disable AV, selected startup, install in safe mode etc) don't work and the service pack still fails to install....
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:32.
Twitter Facebook Google+