Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows saying not genuine, MGADIAG report attached

15 Mar 2014   #1

Windows 7 Home Premium 64bit SP1
Windows saying not genuine, MGADIAG report attached

Hi and a very good day to all,

The computer I am using constantly prompts that i am using a non-genuine windows and that is all, no "non-genuine logo" on the bottom right corner, no black screen. Just the prompt saying non genuine.

So, I thought I was clever (obviously I am not) and tried to change the product key using the OPTION TWO specified in Product Key Number - Change

An Error appeared... The error says

"On a computer running Microsoft Windows non-core edition, run 'slui.exe 0x2a 0x8002801D' to display the error text. Error: 0x8002801D"

Tried running the following commands on elevated command prompt, "slui.exe" and "slui.exe 3" and "slui.exe 0x2a 0x8002801D", but nothing happened.

So I ran the command

REG QUERY HKU\S-1-5-20\Environment
REG QUERY "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-5-20"
REG QUERY "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList"

and the following is the result...

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>REG QUERY HKU


C:\Windows\system32>REG QUERY HKU\S-1-5-20

HKEY_USERS\S-1-5-20\Control Panel
HKEY_USERS\S-1-5-20\Keyboard Layout

C:\Windows\system32>REG QUERY HKU\S-1-5-20\Environment

    TEMP    REG_EXPAND_SZ    %USERPROFILE%\AppData\Local\Temp
    TMP    REG_EXPAND_SZ    %USERPROFILE%\AppData\Local\Temp

C:\Windows\system32>REG QUERY "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-
    ProfileImagePath    REG_EXPAND_SZ    C:\Windows\ServiceProfiles\NetworkServi
    Flags    REG_DWORD    0x0
    State    REG_DWORD    0x0

C:\Windows\system32>REG QUERY "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
    ProfilesDirectory    REG_EXPAND_SZ    %SystemDrive%\Users
    Default    REG_EXPAND_SZ    %SystemDrive%\Users\Default
    Public    REG_EXPAND_SZ    %SystemDrive%\Users\Public
    ProgramData    REG_EXPAND_SZ    %SystemDrive%\ProgramData

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-

However, I don't actually know what it means... hahaha...

So, registered and account, and it says that i should attach a MGADIAG report and ask for help... so, attached below is the report... hope some guru/sifu may be kind to help the not-so-IT-savvy me in solving the problem.

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0x8004FE22
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-2QWT6-HCQXJ-9YQTR
Windows Product Key Hash: PVjSC5x6njvqunmbCY3lOD7rYDo=
Windows Product ID: 00359-OEM-8992687-00007
Windows Product ID Type: 2
Windows License Type: OEM SLP
Windows OS version: 6.1.7601.2.00010300.1.0.003
ID: {3A6770EB-4703-4E7B-A41C-6AF2C3142D53}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Home Premium
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.130828-1532
TTS Error: 
Validation Diagnostic: 
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 100 Genuine
Microsoft Office Enterprise 2007 - 100 Genuine
Microsoft Office Project Professional 2007 - 100 Genuine
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3_E2AD56EA-765-d003_E2AD56EA-766-0_E2AD56EA-134-80004005_E2AD56EA-765-b01a_E2AD56EA-766-0_E2AD56EA-148-80004005_16E0B333-89-80004005_B4D0AA8B-1029-80004005

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{3A6770EB-4703-4E7B-A41C-6AF2C3142D53}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-9YQTR</PKey><PID>00359-OEM-8992687-00007</PID><PIDType>2</PIDType><SID>S-1-5-21-300682061-1495161419-1774891691</SID><SYSTEM><Manufacturer>ASUSTeK Computer Inc.</Manufacturer><Model>K43SA</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>K43SA.210</Version><SMBIOSVersion major="2" minor="6"/><Date>20110926000000.000000+000</Date></BIOS><HWID>ABD03307018400FE</HWID><UserLCID>4409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Malay Peninsula Standard Time(GMT+08:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>_ASUS_</OEMID><OEMTableID>Notebook</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{90120000-0030-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Enterprise 2007</Name><Ver>12</Ver><Val>64BC76978749586</Val><Hash>GW6PzcEVEDTVKeO5Ym5UUm41dBk=</Hash><Pid>89388-707-0441865-65959</Pid><PidType>14</PidType></Product><Product GUID="{90120000-003B-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Project Professional 2007</Name><Ver>12</Ver><Val>3AB862DE70D8D86</Val><Hash>UfpXsJvSSVcPufbDdjd0NK73+ug=</Hash><Pid>89403-707-4159871-63830</Pid><PidType>14</PidType></Product></Products><Applications><App Id="15" Version="12" Result="100"/><App Id="16" Version="12" Result="100"/><App Id="18" Version="12" Result="100"/><App Id="19" Version="12" Result="100"/><App Id="1A" Version="12" Result="100"/><App Id="1B" Version="12" Result="100"/><App Id="3A" Version="12" Result="100"/><App Id="44" Version="12" Result="100"/><App Id="A1" Version="12" Result="100"/><App Id="BA" Version="12" Result="100"/></Applications></Office></Software></GenuineResults>  

Spsys.log Content: 0x80070002

Licensing Data-->
C:\Windows\system32\slmgr.vbs(22, 1) Microsoft VBScript runtime error: File name or class name not found during Automation operation: 'CreateObject'

Windows Activation Technologies-->
HrOffline: 0x8004FE22
HrOnline: N/A
HealthStatus: 0x0000000000000800
Event Time Stamp: 3:14:2014 08:02
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:
Tampered File: %systemroot%\system32\slui.exe|slui.exe.mui|COM Registration

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information: 
  ACPI Table Name	OEMID Value	OEMTableID Value
  APIC			_ASUS_		Notebook
  FACP			_ASUS_		Notebook
  DBGP			_ASUS_		Notebook
  HPET			_ASUS_		Notebook
  MCFG			_ASUS_		Notebook
  ECDT			_ASUS_		Notebook
  SLIC			_ASUS_		Notebook
  SSDT			PmRef		Cpu0Ist
  SSDT			PmRef		Cpu0Ist
Early thanks for the help and hope to hear from you guys in the forum soon... :)

My System SpecsSystem Spec
16 Mar 2014   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

The 0x8002801D error is a pain to solve - but we'll have a go :)

If you don't understand anything please ask!
First create a System Restore point, then....
Open Regedit
Navigate to

Right-click on the Key in the left pane, and select Permissions
Click on the Advanced button
Click on the Owner tab
Highlight Administrators, and put a tick in the 'Replace owner on...' box
Click Apply
(Current Owner should change to Administrators)
Click OK - ONCE
Click on the Permissions tab
In the Permission entries box, highlight Administrators
click Edit
put a tick in the Allow /Full Control box (all the other Allow boxes should automatically be ticked)
put a tick in the 'Apply these permissions....' box
Click OK out to Regedit
Close Regedit
Open an Elevated Command Prompt
run the following command

C:\Windows\Microsoft.NET\Framework\v4.0.30319\regtlibv12.exe C:\Windows\system32\wbem\wbemdisp.tlb 

Close the Command prompt if successful - otherwise post the results.
Open Notepad
copy and paste the following into the Notepad window, and save to the desktop as TEST.VBS

Set objWMIService = GetObject("winmgmts:\\.\root\cimv2")
Set colComputers = objWMIService.ExecQuery("Select * from Win32_ComputerSystem")
wscript.echo "Test Passed"
now double-click on the new file - you should get a small popup window saying 'Test Passed'
If you get anything else, copy and paste the message to your reply.
Now reboot and run a new MGADiag report and post the results.
My System SpecsSystem Spec

 Windows saying not genuine, MGADIAG report attached

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 not genuine with coa sticket, mgadiag result
Im using an ASUS G55vw preinstalled with windows 7 home premium oa but upgraded into windows 7 pro from the store. so i have two coa stickers, one for home premium and pro. now after some years i decided to format everything for a new start, i downloaded a clean copy of windows via torrent...
Windows Updates & Activation
MGADiag Tool report attached - genuine or not? And then what?
I have run a precautionary MGADiag report, before I go ahead and attempt a clean reinstall of Win 7 Ultimate x64 on my Acer E1-571 laptop, since I found the product id and key for the current installation advertised on a number of websites. The laptop, bought in Asia, came with no disk, and the...
Windows Updates & Activation
Windows not genuine message, MGADiag report included
Hello, I've been getting the "Windows not genuine" message popping up for several months on a 2 -year old home built system (I bought & activated a genuine copy of Windows 7). I've included the MGADiag report below. I've recently reactivated Windows using the Microsoft phone number but that...
Windows Updates & Activation
MGADiag report - "This Computer is not running genuine Windows"
Always getting "This Computer is not running genuine Windows" error message. Posted MGADiag report below. Any help would be greatly appreciated. Diagnostic Report (1.9.0027.0): ----------------------------------------- Windows Validation Data--> Validation Code: 0x8004FE22 Cached...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:56.
Twitter Facebook