Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: An update has messed up my boot config

12 Jun 2014   #1

Windows 7 Ultimate x64
An update has messed up my boot config


This isn't a case of an update failing, but appearing to succeed and messing up my boot config.

I switched my computer off earlier and noticed there were updates to install. I returned a few hours later to find my computer unusable. It would restart when windows tried to load, no errors, just a restart. Start-up repair was no help.

I have 2 entries in my boot config, a windows 7 install and a windows 8 consumer preview installed to a .vhd. I had deleted this .vhd some months ago, due to hating windows 8, but had never got around to removing the entry from the boot configuration.

I selected the windows 8 install from the boot menu, and low and behold it loads my windows 7 install. I tried it as I forgot I had removed the .vhd and just wanted to get into windows and get at google so the good folk of the interweb may assist me.

The following updates have been installed today, so one of them must be the culprit:

The procedure for new posts appeared to be aimed at failed updates, so I wasn't sure it was relevant, please advise on any information needed.

Many thanks

My System SpecsSystem Spec
14 Jun 2014   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Very strange!
SOunds like the boot configurations got swapped around somehow.

Please open an Elevated Command Prompt and run the following command - post the results.


Here are some instructions to make life easier :)
1) To open an Elevated Command Prompt Window (the ECP window), click on Start, All Programs, Accessories – then right-click on Command Prompt, and select Run as Administrator. Accept the UAC prompt.
2) To run the commands easier, highlight the block of commands, and right-click on the highlight – select Copy. In the CP Window, click on the black/white icon at top left – select Paste. The commands will run but may not complete the last command, so hit the Enter Key once.
3) To copy the results... click on the Black/White icon in the top left, and select Edit... 'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to paste it into your response.
My System SpecsSystem Spec

 An update has messed up my boot config

Thread Tools

Similar help and support threads
Thread Forum
Boot Drive not listed in BIOS / Empty Boot Tab in Sys Config
Hello, For some reason my boot drive is not listed in UEFI BIOS where you choose the boot drive sequence, still the computer boots OK from that drive. I checked the System Config and the Boot tab is completely empty and I'm unable to make any changes there. When I try to run BCDEdit it says "the...
General Discussion
Boot problems - boot sector messed up using TestDisk?
Hi All, I have a Dell Laptop with Win 7. I recently used TestDisk to try to recover a lost data partition (not my system partition) but when I rebooted the Dell system utilities partition booted (not Windows). Some digging has revealed that Windows was on C:\ but is now on F:\. I have...
Installation & Setup
Windows 7 x64 returns to old computer config. after BIOS update
Dear all, After I successfully updated my ASUS Rampage III Extreme BIOS (from the BIOS), I got booted into an older configuration of Windows 7. I lost all my new files, and everything went back to what looks like an old restore point. I have attached some photo's from the BIOS. I am not...
Hardware & Devices
Load mouse config earlier in boot??
I like to use my mouse on the left side even though I'm a rightie, so I have the primary buttons switched. Unfortunately, Win7 loads that config almost at the end of the boot up process, which of course is annoying if you're trying to click on a few things while the boot finishes (and not knowing...
Performance & Maintenance
Update Error in startup config!
Hi.. I have a problem, every time i start my Acer Aspire M7721, it automatically want to update. Thats fine for me, but the past several days, it stopped the configuration at 0% at stood there for about 5-10 minutes. I have searched the internet, but i couldnt find any solution! Please help...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:52.
Twitter Facebook Google+