Windows 7 32bit cannot install IE10 or IE11: Windows Update error 9C59

Page 1 of 3 123 LastLast

  1. Posts : 18
    Windows 7 Enterprise 32bit
       #1

    Windows 7 32bit cannot install IE10 or IE11: Windows Update error 9C59


    I am having an issue that it looks like many other have run into trying to upgrade from IE8/9 to 10 or 11. Other Windows Updates go through fine but anytime I try to install IE 10 or 11 via Windows Update or from the offline installer it fails with the error 9C59.

    A little backstory on this in case it helps.... We have a VDI environment so this is on our gold image. Months back we updated IE8 to IE9 but found that we were having compatibility issues with an internal web app and had to downgrade back to IE8 (via uninstalling the IE9 installed update). It appears that I can still re-install IE9 but anything beyond that fails with the info above.

    I've tried many of the suggestions out there such as reinstalling the readiness tool, resetting windows update agent, etc but no luck so far. The interesting thing that I found is if i start fresh with this update again (so i start with IE8) , the "turn windows features on / off" shows IE 8 as an option to toggle on/off. However after I try the IE11 install and it fails, i still have IE 8 installed but the "windows features on/ off" window shows IE11...so its almost like it ALMOST gets there and fails.

    Either way, if theres any help someone could have for this I'd greatly appreciate it! i'm happy to try and scans / logs that might help

    thank you

    andrew
      My Computer


  2. Posts : 21,482
    Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
       #2

    Please follow the Windows Update Posting Instructions and post the requested data
    If the file is too large (8MB compressed), remove the older CBSPersist cab files until the final file is below the limit - you can always post them separately after zipping them. (the forum doesn't allow the upload of bare CAB files, for a number of reasons)
      My Computer


  3. Posts : 18
    Windows 7 Enterprise 32bit
    Thread Starter
       #3

    sorry about that! I have attached the cbs zipped folder here and just so its in the post as well the windows update error code i am getting is : 9C59

    I am able to update every other Windows Update except IE10 and IE11. Let me know if theres any other info that I am forgetting and I'm happy to get them here. thank you for the help!
      My Computer


  4. Posts : 21,482
    Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
       #4

    Interesting error from CheckSUR...
    Code:
    Summary:
    Seconds executed: 1136
     No errors detected
    (w) Unable to get system disk properties 0x0000045D IOCTL_STORAGE_QUERY_PROPERTY Disk Cache
    It's one I've never seen before.

    There are also some nasty errors in the CBS.log...
    Code:
    2014-06-17 10:32:51, Info                  CSI    0000016c [SR] Beginning Verify and Repair transaction
    2014-06-17 10:32:54, Error                 CSI    0000016d@2014/6/17:15:32:54.583 (F) d:\win7sp1_gdr\base\wcp\sil\fs_buffered.cpp(1005): Error STATUS_FILE_IS_A_DIRECTORY originated in function Windows::Rtl::SystemImplementation::CBufferedFileSystemProvider::SysReadFile expression: (null)
    [gle=0x80004005]
    2014-06-17 10:32:54, Error                 CSI    0000016e (F) STATUS_FILE_IS_A_DIRECTORY #3111595# from Windows::Rtl::SystemImplementation::CFile_IRtlFileTearoff::ReadFile(Flags = 3, Buffer = {l:0 ml:65536 b:}, Offset = 0, Disposition = 0)[gle=0xd00000ba]
    2014-06-17 10:32:54, Error                 CSI    0000016f (F) STATUS_FILE_IS_A_DIRECTORY #3111584# from CFileInstaller::ValidateFileHashAgainstCDF(...)[gle=0xd00000ba]
    2014-06-17 10:32:54, Error                 CSI    00000170 (F) STATUS_FILE_IS_A_DIRECTORY #3111566# from CFileInstaller::DoComponentOperation(...)[gle=0xd00000ba]
    2014-06-17 10:32:54, Error                 CSI    00000171 (F) STATUS_FILE_IS_A_DIRECTORY #3111565# from PrimitiveInstaller::CCoordinator::RepairComponent(Component = Microsoft-Windows-SecureStartup-BootServicing-Utility, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral)[gle=0xd00000ba]
    These are what is crashing the SFC scan.

    It's only the second time I've seen this error in the past couple of weeks (and never previously!) - I managed to fix it last time, so I'll have a go again now.

    Please open an Elevated Command Prompt, and run the following command


    DIR C:\ /AL /S

    Post the results.


    Here are some instructions to make life easier :)
    1) To open an Elevated Command Prompt Window (the ECP window), click on Start, All Programs, Accessories – then right-click on Command Prompt, and select Run as Administrator. Accept the UAC prompt.
    2) To run the commands easier, highlight the block of commands, and right-click on the highlight – select Copy. In the CP Window, click on the black/white icon at top left – select Paste. The commands will run but may not complete the last command, so hit the Enter Key once.
    3) To copy the results... click on the Black/White icon in the top left, and select Edit... 'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to paste it into your response.
      My Computer


  5. Posts : 18
    Windows 7 Enterprise 32bit
    Thread Starter
       #5

    awesome thank you for your help with this! i really appreciate it!

    i've attached a document w/ the results for you. if you'd prefer them just copied directly into the body of this message let me know
      My Computer


  6. Posts : 2,663
    Windows 8.1 Pro x64
       #6

    I've only got about a minute to write this post so I'll keep this quick.

    CheckSUR error is one you get for running the SURT in a VM (I think!)
    SFC error is scarily similar to what ZeroAccess used to do: SFC Warning

    The fact it's on a security component makes alarm bells go off in my head, it may well be a new strain of ZA.
      My Computer


  7. Posts : 18
    Windows 7 Enterprise 32bit
    Thread Starter
       #7

    i'm not sure if it matters but the previous cbs upload was trying to install this as an application layer with our VDI system (unidesk/ citrix) and a citrix rep let me know that scannow doesnt quite work right in that setup.

    I've now tried the same thing on my gold image, ran the readiness tool, and successfully ran a scannow (results said it found no integrity issues. However IE11 still fails with the same error. I'm attaching the updated cbs zip file here if you dont mind taking a look? I was able to install this fine on my 64 bit gold image so not sure what i'm missing here. any help would be awesome ! thank you!
      My Computer


  8. Posts : 21,482
    Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
       #8

    CheckSUR and CBS logs are both clear - although the CheckSUR still has that error.

    (Tom - I just ran CheckSUR in a VBox VM, with no similar error?)

    There isn't any background data in the CBS log to see further back, as the log appears to have been archived out just before the SFC ran.

    The 9c59 error seems often only to be curable by a repair install, and I suspect that it's the result of either egistry damage or interfering programs.
      My Computer


  9. Posts : 18
    Windows 7 Enterprise 32bit
    Thread Starter
       #9

    unfortunately a repair install is not possible in my situation as this is the gold image that all of our users desktops are created from as well as all of our application layers (meaning if I started over it would orphan all of my desktops and app layers as far as i know).

    thank you for trying to help! any other possibilities to get past this ??
      My Computer


  10. Posts : 21,482
    Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
       #10

    Tom's knowledge of the intricacies of WU is a lot deeper than mine - hopefully he'll come back to us soon! (if not, I'll email him off-forum)
      My Computer


 
Page 1 of 3 123 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:26.
Find Us