Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Updates Stuck in Windows 7

02 Jul 2014   #1

Windows 7 32 bit
Windows Updates Stuck in Windows 7

Hello Techxperts,

A colleague's old Windows 7 32-bit Machine is having trouble updating and I have agreed to repair it. Whenever I check for updates under Windows Updates I receive the following error message: "Restart your computer to install important updates. Windows can’t update important files and services while the system is using them. Save any open files and restart the computer, and then try to check for new updates." This process repeats ad infinitum. I found I cannot uninstall any Windows Updates, either. I also tried loading SP1 but could not do so (“Installation was not successful. The Windows 7 Service Pack Installation cannot proceed until your computer is restarted. Please restart your computer and try again.”) I tried this in Safe Mode and in the normal mode as well. Restarting the machine does not help the situation. I should note also that I ran the installation from a disk.

I ran a full scan on the machine with Sophos and Malwarebytes anti-malware. The machine is clean. I have also removed Microsoft dot net framework which was suggested to me as a possible cause of this symptom.

I am hoping I can recover the machine without reloading from scratch or performing a Windows Repair (which in my experience does not always work).

As per the Windows Update Posting Instructions, here are the steps I have taken so

System Update Readiness Tool (SURT):
Downloaded the 32-bit version and ran this. It appeared to freeze once I ran it. About 5 minutes later it claimed to have completed.

SFC Scan: I ran this scan as indicated. I tried Option 2 - "Run the SFC / SCANNOW Command in Windows 7" and attempted to scan and repair system files. I received the message: "Windows Resource Protection did not find any integrity violations."

Errors and Error Codes: See Above

Thank you for your thoughts on this and for your help.

PS - see my next post for the CBS logs.

My System SpecsSystem Spec
02 Jul 2014   #2

Windows 7 32 bit

Here is the CBS logs from this machine. Thank you.
My System SpecsSystem Spec
03 Jul 2014   #3

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

It looks to me as if your registry is corrupted -

I need to have a look at your COMPONENTS registry hive

Please copy the C:\Windows\System32\config\COMPONENTS file (no extension) to your desktop and then compress it - upload the compressed file to your favoured fileshare site (preferably Dropbox or OneDrive) and post a link.
My System SpecsSystem Spec

03 Jul 2014   #4

Windows 7 32 bit

NoelDP, Thank you for having a look.
My System SpecsSystem Spec
04 Jul 2014   #5

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

From the looks of it, You installed the Release Candidate for Service Pack 1, and never uninstalled it. You need to do so before SP1 will install properly
My System SpecsSystem Spec
07 Jul 2014   #6

Windows 7 32 bit

Hello - thank you again for having a look. I think that the Release Candidate you have mentioned is KB976932. I did not notice this amongst the list of available uninstallations in Add/Remove Programs. My Windows Edition is likewise not shown to be SP1 at this time when I check the version. If you are correct, though, I am not sure how to perform the uninstallation. Is there another way to do so besides going though the Control Panel?

I tried uninstalling some Windows Updates stating with those most recently installed but come up with this message: "An error has occurred. Not all of the updates were successfully uninstalled." I seem to be unable to uninstall or install Windows Updates at this time. It might be worth noting that I was, however, able to install the latest update for Java today.
My System SpecsSystem Spec
07 Jul 2014   #7

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Here's an instruction-set for the uninstall...
Uninstalling Windows 2008 R2/Windows 7 SP1 RC to install the RTM version | Virtualisation & Management Blog
Note that the alternative 'wusa' method must be run from an Elevated Command Prompt.

If neither method produces anything, then let's see what's actually installed...
This should give us some idea
we need to see a full copy of the report produced by the MGADiag tool
(download and save to desktop - )
Once saved, run the tool.
Click on the Continue button, which will produce the report.
To copy the report to your response, click on the Copy button in the tool (ignore any error messages at this point), and then paste (using either r-click/Paste, or Ctrl+V ) into your response.
My System SpecsSystem Spec
07 Jul 2014   #8

Windows 7 32 bit

Okay, tried the wusa method from the elevated command prompt and am given this message: "The update KB976932 is not installed on this computer."

Stand by for the MGADiag output.
My System SpecsSystem Spec
07 Jul 2014   #9

Windows 7 32 bit

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->
Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-M3DJT-4J3WC-733WD
Windows Product Key Hash: xo+ajVSpae7/4VoZjS7m6JL0f3A=
Windows Product ID: 00371-OEM-8992671-00524
Windows Product ID Type: 2
Windows License Type: OEM SLP
Windows OS version: 6.1.7600.2.00010100.0.0.048
ID: {18A28728-C5A2-40E4-958D-B19C3D489A1A}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: Registered,
Signed By: Microsoft
Product Name: Windows 7 Professional
Architecture: 0x00000000
Build lab: 7600.win7_gdr.100618-1621
TTS Error:
Validation Diagnostic:
Resolution Status: N/A
Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002
OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
OGAExec.exe Signed By: Microsoft
OGAAddin.dll Signed By: Microsoft
OGA Data-->
Office Status: 100 Genuine
Microsoft Office Professional Edition 2003 - 100 Genuine
OGA Version: Registered,
Signed By: Microsoft
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3_E2AD56EA-765-d003_E2AD56EA-766-0_E2AD56EA-134-80004005_E2AD56EA-765-b01a_E2AD56EA-766-0_E2AD56EA-148-80004005_16E0B333-89-80004005_B4D0AA8B-1029-80004005
Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files\Google\Chrome\Application\chrome.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed
File Scan Data-->
Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{18A28728-C5A2-40E4-958D-B19C3D489A1A}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7600.2.00010100.0.0.048</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-733WD</PKey><PID>00371-OEM-8992671-00524</PID><PIDType>2</PIDType><SID>S-1-5-21-3867143114-1227475228-180427910</SID><SYSTEM><Manufacturer>Dell Inc.</Manufacturer><Model>OptiPlex 780 </Model></SYSTEM><BIOS><Manufacturer>Dell Inc.</Manufacturer><Version>A04</Version><SMBIOSVersion major="2" minor="5"/><Date>20100430000000.000000+000</Date></BIOS><HWID>BEBB3607018400F8</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>DELL </OEMID><OEMTableID>B10K </OEMTableID></OEM><GANotification><File Name="OGAAddin.dll" Version=""/></GANotification></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{90110409-6000-11D3-8CFE-0150048383C9}"><LegitResult>100</LegitResult><Name>Microsoft Office Professional Edition 2003</Name><Ver>11</Ver><Val>2CD219300513500</Val><Hash>Lv0VM4aoBJjjgZaMnS3fsOYlV8o=</Hash><Pid>73931-640-2817064-57516</Pid><PidType>14</PidType></Product></Products><Applications><App Id="15" Version="11" Result="100"/><App Id="16" Version="11" Result="100"/><App Id="18" Version="11" Result="100"/><App Id="19" Version="11" Result="100"/><App Id="1A" Version="11" Result="100"/><App Id="1B" Version="11" Result="100"/><App Id="44" Version="11" Result="100"/></Applications></Office></Software></GenuineResults>
Spsys.log Content: 0x80070002
Licensing Data-->
Software licensing service version: 6.1.7600.16385
Name: Windows(R) 7, Professional edition
Description: Windows Operating System - Windows(R) 7, OEM_SLP channel
Activation ID: 50e329f7-a5fa-46b2-85fd-f224e5da7764
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00371-00178-926-700524-02-1033-7600.0000-2422010
Installation ID: 000690809955980490885275582804154964050656804326091235
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: 733WD
License Status: Licensed
Remaining Windows rearm count: 3
Trusted time: 7/7/2014 11:07:33 AM
Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 6:26:2014 14:00
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->
OEM Activation 1.0 Data-->
OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
____ DELL B10K
My System SpecsSystem Spec
07 Jul 2014   #10

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

This does appear to be a vanilla Windows 7 RTM install - it's interesting that the registry refers to the RC build, rather than anything else.

I suspect that your best option is going to be a repair install using SP1 media - see what you think about the idea... - it's not as difficult as it looks, and does solve an awful lot of potential problems!
My System SpecsSystem Spec

 Windows Updates Stuck in Windows 7

Thread Tools

Similar help and support threads
Thread Forum
Computer stuck 13 of 17 Windows updates
Have a friend's computer that started Windows Updates and got to 13 of 17 and won't go any farther. Tried re-starting (I know they say not to) and it gets to 13 and won't go any further. Also can't start it in Safe Mode. What next?
Windows Updates & Activation
Windows 7 updates stuck on 0%
I reformatted my HP laptop so it restored it to how it comes when first out of the box, because I was having issues with a few programs and it started to run slowly. I now have 130 windows 7 updates. I can occasionally download some of them by doing them 1 at a time, other times they don't work....
Windows Updates & Activation
Windows 7 Updates stuck at 0%, Error 80200001
So I have searched this forum diligently (and Microsoft's website), downloaded multiple scripts and FixIt-ers, and have had absolutely no luck. This is killing me! I am stuck needing 93 files updated, and for some reason I cannot use the run/cmd program to install Automatic Updates (It is missing...
Windows Updates & Activation
Important Windows Updates Stuck On 0% ?
Hello Every one who read this Topic My name is wez i've been having this problem and havent been able to install important updates for around 5 months now and my pc aint functioning properly as the updates are needed . Here is a screen shot of how it looks for me when i try to install...
Windows Updates & Activation
Stuck configuring updates. Windows 7 on F: versus C:
cannot use the restore function and the windows repair does not work. I had some success with unmounting the drive but when I reboot again, everything went back to my problem state. Somewhere along my work, I also created a recovered Operating system which is invalid so when I boot up it...
Windows Updates & Activation
Stuck on Configuring Windows Updates
Hello Everyone. I did a clean install of Windows 7 Ultimate x64 after installed 33 updates, pressed restart after the updates installed now im stuck on configuring windows updates at 15% it wont progress any further, what can I do to fix this? please help!
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:57.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App