Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Update errors

14 Sep 2014   #11

Windows 7 SP1 Ultimate x64

Here is the working copy:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Windows\system32>DIR C:\Windows\Winsxs\amd64_prnge001.inf.resources_31bf3856a
 Datenträger in Laufwerk C: ist Win7x64 SSD-128m4
 Volumeseriennummer: EEB8-B8CF

 Verzeichnis von C:\Windows\Winsxs

14.09.2014  18:57    <DIR>          amd64_prnge001.inf.resources_31bf3856ad364e3
               0 Datei(en),              0 Bytes
               1 Verzeichnis(se), 65.047.818.240 Bytes frei

C:\Windows\system32>TAKEOWN /F C:\Windows\Winsxs\amd64_prnge001.inf.resources_31

ERFOLGREICH: Die Datei (oder der Ordner) "C:\Windows\Winsxs\amd64_prnge001.inf.r
esources_31bf3856ad364e35_6.1.7600.16385_de-DE_ab8f860c83548d98" gehört jetzt
             dem Benutzer "wob-PC\wob".

C:\Windows\system32>ICACLS C:\Windows\Winsxs\amd64_prnge001.inf.resources_31bf38
56ad364e35_6.1.7600.16385_de-DE_ab8f860c83548d98 /grant Administrators:(F) /T
Administrators: Zuordnungen von Kontennamen und Sicherheitskennungen wurden nich
t durchgeführt.
0 Dateien erfolgreich verarbeitet, bei 1 Dateien ist ein Verarbeitungsfehler auf

C:\Windows\system32>COPY "%userprofile%\desktop\TTYRES.DLL.mui" C:\Windows\Winsx
48d98 /Y
Zugriff verweigert
        0 Datei(en) kopiert.

My C Drive is a 128GB SSD, never run chkdsk /r on it.
Not sure how long it will takes so I let it run over night.

My System SpecsSystem Spec
14 Sep 2014   #12

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

With an SSD, it should only take a few minutes - an hour at most.
My System SpecsSystem Spec
14 Sep 2014   #13

Windows 7 SP1 Ultimate x64

I've finished chkdsk c: /r without errors.

Then I boot my computer from a boot cd and copied the TTYRES.DLL.mui manually to the specified folder.

Now I can run SFC scan without errors (will find some errors but all repaired)

Unfortunately still no luck to install the Windows Update Agent.

Comes up same Error Code again: 80073701

I've atached the latest CBS folder again

Will go sleep now (2am here), thank you NoelDP for your time and help so far
My System SpecsSystem Spec

14 Sep 2014   #14

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

You appear to have McAfee installed - which can cause problems.
I'm not convinced that it's the cause this time.
Here's what SFC found and fixed in this run...
 Line 33450: 2014-09-15 01:46:27, Info                  CSI    0000080e [SR] Repairing 2 components
 Line 33451: 2014-09-15 01:46:27, Info                  CSI    0000080f [SR] Beginning Verify and Repair transaction
 Line 33454: 2014-09-15 01:46:27, Info                  CSI    00000811 [SR] Repairing corrupted file [ml:520{260},l:56{28}]"\??\C:\Windows\Help\mui\0407"\[l:22{11}]"diskmgt.CHM" from store
 Line 33460: 2014-09-15 01:46:27, Info                  CSI    00000814 [SR] Repairing corrupted file [ml:520{260},l:56{28}]"\??\C:\Windows\Help\mui\0407"\[l:22{11}]"diskmgt.CHM" from store
 Line 33473: 2014-09-15 01:46:27, Info                  CSI    00000817 [SR] Repair complete
What does surprise me is that it claims to have found two distinct errors, but the listing only shows one.
It did see an error in ownership of the same file, and it may be that which it's describing as the second error.

Now that we have the area clear, I can see that this is the basic error with Windows update...
2014-09-15 01:42:02, Info                  CBS    Exec: Resolving Package: WUClient-SelfUpdate-Core-CoreComp~31bf3856ad364e35~amd64~en-US~7.6.7600.256, Update: Core, PinDeployment: amd64_microsoft-windows-w..oyment-languagepack_31bf3856ad364e35_7.6.7600.256_en-us_f47183af9fa51491
2014-09-15 01:42:02, Error                 CSI    0000041c@2014/9/14:18:42:02.324 (F) d:\win7sp1_gdr\base\wcp\componentstore\csd_locking.cpp(324): Error STATUS_SXS_ASSEMBLY_MISSING originated in function CCSDirectTransaction::LockComponent expression: (null)
2014-09-15 01:42:02, Error                 CSI    0000041d (F) STATUS_SXS_ASSEMBLY_MISSING #9081312# from CCSDirectTransaction::OperateEnding at index 0 of 1 operations, disposition 2[gle=0xd015000c]
2014-09-15 01:42:02, Error                 CSI    0000041e (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) #9081197# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_PinDeployment(Flags = 0, a = Microsoft-Windows-WindowsUpdateClient-Core.Deployment-LanguagePack, Version = 7.6.7600.256, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral, cb = (null), s = (null), rid = [80]"WUClient-SelfUpdate-Core-CoreComp~31bf3856ad364e35~amd64~en-US~7.6.7600.256.Core", rah = [2]"32", manpath = (null), catpath = (null), ed = 0, disp = 0)[gle=0x80073701]
2014-09-15 01:42:02, Info                  CBS    Failed to pin deployment while resolving Update: Core from file: (null) [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2014-09-15 01:42:02, Info                  CBS    Failed to resolve item[0] in Package: WUClient-SelfUpdate-Core-CoreComp~31bf3856ad364e35~amd64~en-US~7.6.7600.256, Update: Core [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
2014-09-15 01:42:02, Info                  CBS    Failed to resolve execution update. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
... which is strange, given that you have a German edition of Windows installed (and this indicates that it's trying to installan English version of the Windows Update Agent).
There have been a number of similar problems here in the past week or so, but we haven't got to the bottom of any of them yet - I've been recommending a Repair install as the cure.
That may still be your quickest solution.
My System SpecsSystem Spec
14 Sep 2014   #15

Windows 7 SP1 Ultimate x64

Yes I have McAfee AntiVirus Plus installed but also in cleanboot the WUA update fail

I've tried one more thing - running the WindowsUpdateDiagnostic Tool
It shows some Error fixed except this:

Windows Update Error 0x80070490 not solved
RootCause RC_DataStore
Collected File:

the log files giving from the diagnostic tool are atached

I'll see if I have time next weekend to figure out the repair install procedure in this forum.

Thanks very much for your support.
My System SpecsSystem Spec
12 Oct 2014   #16

Windows 7 SP1 Ultimate x64

today I've done an Repair install of my Windows 7 and finally I get installed the new Update Agent - thank you very much NoelDP

I was suprised that all my settings came back, I was a little bit scared before.

Now I only left with 2 problems:

KB2858725 Netframework Update 4.5.1 failed with Code 643


when I restart the PC now takes much longer then before

I have an SSD system drive and when I restart now my PC, during the Windows logo, the SSD (HDD -LED) stop working for about 30 second and then continuous... before I have not seen this
My System SpecsSystem Spec
12 Oct 2014   #17

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

That's Windows re-optimising the system - it will take a few days to settle down.

As far as your .NET problem is concerned it's probably best to remove and reinstall .NET 4.5 - see the instructions here... .NET Framework Cleanup Tool User's Guide - Aaron Stebner&#39;s WebLog - Site Home - MSDN Blogs
My System SpecsSystem Spec
12 Oct 2014   #18

Windows 7 SP1 Ultimate x64

I have followed the instructions and removed with NET Framwork Cleanup tool all NetFx versions.
Then I downloaded and reinstall NetFramework v1.1, 2.0 and 3.5 no problems.

I can also find the Files and registry entries in the right place for all versions until 3.5 sp1. Only version 4 or 4.5 or 4.5.1 or 4.5.2 I am not able to install.
when I start the standalone package for Netfx 4.0 Client or 4.5 or 4.51 or 4.52 failed with "schwerwiegenden Fehler"

and in the log file I see:
Aktion gestartet um 23:38:55: CA_BlockOlderVersionInstall.
MSI (s) (24:CC) [23:38:55:423]: Produkt: Microsoft .NET Framework 4.5.2 -- A later version of Microsoft .NET Framework 4.5.2 is already installed.
how can that be or how can I remove the "newer version"?

Even there are no entries in the registry or files under C:\Windows\Microsoft.NET\Framewok\ for NetFx version 4xx only 2.0, 3.0 and 3.5.

Run Windows update now is also no problem, all updates are installed except NETFx 4.5.1 comes again up with error code 643
but there is no more Netframeworks 4 installed on my system. Run sfc /scannow not find any probs.

sorry for my bad english right now but I am very tired after whole day sitting here...

My System SpecsSystem Spec
12 Oct 2014   #19

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

All I can suggest it that you run the Cleanup tool again.

.NET is a huge 'application' - I had to expand the files on a .NET update yesterday, and it amounted to almost 500MB - and took over 30 minutes. Copying the resulting files to where I actually needed them took another 45 minutes!
My System SpecsSystem Spec
13 Oct 2014   #20

Windows 7 SP1 Ultimate x64

sorry to bother you again NoelDP but you are the only one who really has helped me a lot with my Windows problems.

Most of the ppl saying just make a fresh install, but most at the time there is no need to do that.

Espacially now in my case where is everything working very smooth.
And as you say before, after restarting many time (because of the Netframework problem) the computer now start up very fast, within 15 sec for reboot...

Only the Framework problem I get not fixed. I have run the cleantool again and again.
Also checked registry and Folder for entries and files, nothing left for v. 4xx
Now also from the cleantool logfile I can see there is no mor Netframework 4xx installed. only 2.0, 3.0 and 3.5

Still get error code 643 when I run Win Update and try to update Framework 4.5.1. or framework client 4.0

And the standalone package 4.5.2 still gives me message that it cannot be installed

I will attach the 2 logfiles from cleaner and installer just in case - you can have a look.

My question now is there any other way to get the Frameworks 4.x.x installed?

Regards wasisdn
My System SpecsSystem Spec

 Update errors

Thread Tools

Similar help and support threads
Thread Forum
Errors while using windows update.
Hey after looking around for a while it seems this site genrally manges to resolve peoples problems with windows update. Below will be a list of the errors and the steps I have taken so far. Downloaded the System Update Readiness Tool and installed it Completed a SFC scan (no problems...
Windows Updates & Activation
errors on update ox80073712
Have had issues for months with updates - which reading online seems quite common. tried to install adobe pdf which has failed due to this error ox80073712 although they also add their error 1935. adobe suggest running scannow from elevated command prompt which on my machine is also failing so i...
Windows Updates & Activation
Win 7 Update errors, Readiness Test returning 5000+ errors Help
Need some guidance. I'm trying to help a friend who got hit by something, virus, malware etc. Cleaned that up but.... In looking over his Win 7 64bit Home Premium system, I noticed his Windows Update had not run in over a year. So I tried to run it manually and have been going down a rabbit...
Windows Updates & Activation
Windows Update errors
I have run a FixIt and Windows Update readiness tool and I still can't get these 3 updates to install. I retried both tools 3 times, sfc found no violations. Retrying updates yields the same errors. I have tried each one individually too. I've also rebooted and restarted the PC.:mad:
Windows Updates & Activation
Windows Update errors
Hi Windows Update downloaded but failed to install updates, stating errors- KB978601; KB979683; KB980232 (error code 80070643) KB979309; KB981332 (error code 80071A91) System Restore in Safe Mode also failed (error code 80071A91). Any suggestions on how to resolve this?
Windows Updates & Activation
windows update errors
Hello my friends, i'm no longer able to download & install windows updates, i've last downloaded a successful update on 14 january, then, i didn't check for any updates since that time 2 days ago, i made a check for updates & i've found couple of updates to install, i selected them, but i always...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:50.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App