Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No updates for Windows 7, 32-bit

20 Sep 2014   #1

Win7 Home Premium X32
No updates for Windows 7, 32-bit

Starting about a week ago, Windows Updater (WU) on my Win7 Home Premium 32-bit system began to act abnormally, has been degenerating in capability, and is now unable (or unwilling) to install any updates at all. The condition seemed to coincide with V320 of wuaueng.dll being installed automatically by WU.

First indication was that WU would take a much longer than usual time to search for updates (though the Systray icon advised that updates were available), then advise that a new, up-to-date update routine needed to be installed. (This has been reported here on SevenForums and elsewhere.) The installation was never successful—update history would show that Windows Update Agent 7.6.7600.320 installation had failed, time after time.

System Restore to a few days earlier got WU going again, but attempt to let WU manage installation of any selected update(s) would soon again yield essentially what I've described in the para. above. Another System Restore would get V256 of wuaueng.dll installed in place of V320, and I was able to download and install a handful of updates manually. Any attempt to use WU would fail the same way, however.

A day or so later, attempt to launch WU would result in failure, with error code 80070005 reported. Following instructions for this error code given by did not cure the problem. Searching for other help from turned up instructions to stop the Windows Update Service, re-register certain DLLs, re-start the Service. Following these resulted in the Windows Updater now launching...but with an anomalous dialog (attached).

Clicking the OK button yields a window containing this advisory: "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access this item." (The title bar of the window begins ":{26EE0668-A00A-44D7-9371-BEB064C98683}\{36EEF7B...") This is definitely an Administrator account, with UAC cranked all the way down.

I checked the wuapp.exe and wuaueng.dll files residing in an alternative HD that runs the same version of Win7 as does my primary drive (I keep the alternative drive up-to-date) against the ones in my primary drive's C:\Windows\System32 folder—they are byte-for-byte identical. Starting Win7 from the alternative drive yields completely normal Windows Update operation...and V320 of wuaueng.dll is the version in the System32 folder.

Strangely, if I copy wuapp.exe from the System32 folder on my primary drive to any other folder on the drive and launch it, wuapp.exe starts up normally! However, no updates can be installed. This may tally with the fact that now I can't get any updates to install from downloaded installers.

I'm now having no success with System Restore.

Addressing the required "posting info":

1. System Update Readiness Tool (SURT) — will not install and run. No error number is reported.

2. SFC Scan — no corrupted or missing files are reported

3. Windows Update Error Codes — the only error code reported in this whole mess is 80070005...and it's no longer reported, because WU doesn't get that far.

4. Log Collection — Zip-ed version of CBS.log is attached

5. Start a New Thread — done herewith

Thx in advance for advice and instructions. If I need post more data, please advise.

I'm open to any/all guidance for "surgical" fixes...but if there is a "tac nuke" approach (e.g., restoring folders and files from Shadow Copies, copying folders and files from the alternative drive) short of a Repair Install of Win7 that I could try, I'm willing to give it a go. I keep extensive archives of the primary drive and have access to a fully-functional drive running the same version of Win7. In past years, I've been adept in replacing corrupted Default, Sam, Security Software, System config files to rescue a wacked Registry. A plethora of these (and other Windows-related folders and files) from the previous week and earlier are available in the large Shadow Copy folders on the primary drive.

Will do a repair install if absolutely necessary...but would really like to avoid that.


My System SpecsSystem Spec
21 Sep 2014   #2

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Shen I don't know if this will be of any help but worth a try Error 0x80070005 in Windows Update when you try to install updates

You mentioned SFC and I think you could run this too < use the /f and maybe the /r switches in Option 2 ifnecessary
My System SpecsSystem Spec
21 Sep 2014   #3

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Please post the ENTIRE CBS folder - it may be too large for the forum to handle, so split it into chanks smaller than 8MB each.
Also please post the C:\Windows\windowsupdate.log file.
My System SpecsSystem Spec

21 Sep 2014   #4

Win7 Home Premium X32
No updates for Windows 7, 32-bit

Thanks to both ICit2lol and NoelDP for replies. In deference to Noel's long track record sorting out Windows Update problems here, and knowing from personal experience how tough it is to hit a moving target, I'll elect not to make any attempt to install anything else yet.

A Zip file of the current contents of the CBS folder is attached, as well as the current Windows Update Log file. The 52+ MB "old" CBS log file arose from following one of Microsoft's instructions to rename the old log file.

FWIW, another anomaly occurring re this over the last week was one of Microsoft's FixIt tools not running because it was unable to respond to a Run As Administrator command. However, I am the Admin, with full privileges, and I was launching the EXE file directly, not via right-click.

Also, there are some updates-to-be-made queued up that arise on system shutdown.

I failed to mention in first post that I run Eset NOD32. I've seldom had trouble installing Windows updates with NOD32 running, but in this go-around I've had to suspend NOD32 while doing the few successful manual updates from installer EXE files.

My System SpecsSystem Spec
21 Sep 2014   #5

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

I think these are the operative errors in the windowsupdate log...
2014-09-20 23:41:14:598 4516 12dc Misc ===========  Logging initialized (build: 7.6.7600.320, tz: -0700)  ===========
2014-09-20 23:41:14:598 4516 12dc Misc   = Process: C:\Windows\system32\wuauclt.exe
2014-09-20 23:41:14:598 4516 12dc AUClnt FATAL: Error: 0x80070005. wuauclt handler: failed to spawn COM server
2014-09-20 23:41:14:598 1376 814 Handler FATAL: 0x80070005: ERROR: Remote update handler container process created (PID: 4516), but exited before signaling event
2014-09-20 23:41:14:598 1376 814 Agent   * WARNING: Exit code = 0x80070005
2014-09-21 09:42:52:429 5960 ee8 Misc   = Process: C:\Windows\system32\wuauclt.exe
2014-09-21 09:42:52:428 5960 ee8 Setup Closing WU explorer windows
2014-09-21 09:42:52:439 5960 ee8 Setup WARNING: Failed to cocreate IShellWindows, error = 0x800700052014-09-21 09:42:53:442 1420 16ec Setup Launching WuSetupV.exe to complete SelfUpdate
2014-09-21 09:42:53:444 1420 16ec Setup WuSetupV.exe launched successfully
2014-09-21 09:42:53:444 1420 16ec Agent   * WARNING: Skipping scan, self-update check returned 0x8024001B
2014-09-21 09:42:53:444 1420 16ec Agent   * WARNING: Exit code = 0x8024001B
Here's a possible fix I found while googling...
1. launch regedit.exe
2. Locate the following key: HKEY_LOCAL_MACHINE\Software\Microsoft\Ole
3. Look for the value "DefaultAccessPermission" (NOT DefaultLaunchPermission)

If this value exists, it is possible that the value has been corrupted or are incorrect. If you don't have the need for specific default permissions, you can restore the original permissions on the machine by deleting this value (do not delete the entire reg key, just that one value.)
My System SpecsSystem Spec
21 Sep 2014   #6

Win7 Home Premium X32

Thx for the very quick reply, Noel—

No joy. (BTW, here in southern California, "failure to spawn" is an affliction that is seldom admitted to. ::smirk:: )

The specific Registry key did, in fact, exist. I exported it for safekeeping, then deleted it. Same anomalous action when attempting to launch WU, even after system restart.

I booted from the alternative Win7 drive—it has the same key defined. I exported that key, then compared it to the one I exported from the primary drive—they are byte-for-byte identical.

For completeness: The "alternative drive" to which I have referred is a 640GB unit that was my primary drive for several years. I cloned it to a new 750GB and partitioned it (the 750) to 300GB and 450GB to make ready to install an SSD when prices were "attractive." This operation was done roughly a year ago, and until a week+ ago, the 300GB partition has worked flawlessly in regards to Windows updates. The partition has about 100GB free space.

The 640 is up-to-date as far as Win7 is concerned, but it doesn't have some of the apps installed, and some apps are still installed on the "C:\Drive" and not a separate partition.

My reluctance to do a Repair Install is concern that changes I have made (installed applications and updates and patches thereto, et al.) may be affected adversely by the Repair Install. My experience goes back to the Days of DOS, and I've seen more than ample evidence that "tools" from Microsoft are quite self-centered and dismissive of the user's system's overall configuration.

No matter how this all goes, I would be very interested in your opinion of how/why Windows would get its knickers knotted in launching wuapp.exe from the System 32 folder (publisher valid certificate), yet has no complaint at all about the exact same exe located in a different folder.

Standing by to try anything you think appropriate...

My System SpecsSystem Spec
21 Sep 2014   #7

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Please post the new windowsupdate.log file -
which exact folders did you relocate off the C: drive?
My System SpecsSystem Spec
21 Sep 2014   #8

Win7 Home Premium X32

Thank you for your reply, Noel. Current WU log file is atch.

No folders containing any executables/dlls/etc. were "relocated" in a brute force manner. The only folders that I moved via cut/paste contained data files created by me, residing in folders created by me: graphic, sound, word processor files, and the like. There were no cut/paste liberties taken with the Windows (and subordinate) folder, Program Files, Program Data, Docs & Sets, Sys Vol Info, etc.

To reach the goal of having the Win7 "boot entity" (at this stage, a partition) no larger than 200GB, I uninstalled various non-Microsoft applications and reinstalled them on the other partition. The uninstallations were all done in the formal manner, under the aegis of Windows. I employed no redirection options that might confuse Windows. I left some applications that I use regularly and desire to load and run as quickly as possible (when I move to an SSD) where they have always been on the C:\ (logical) drive.

As best I can ascertain, everything I do on this machine goes as it has gone for the last many months...with the exception that at about the time that Microsoft "rolled out" its V360 update to WU, my ability to make updates has atrophied through several stages (varying anomalies) over a week's time to the current state of non-operation. Until V360 of wuaueng.dll was installed (automatically) vice V256, WU was quite well-behaved.

My System SpecsSystem Spec
21 Sep 2014   #9

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

here's one complete error sequence...
2014-09-20 19:06:21:658 3236 1774 Misc ===========  Logging initialized (build: 7.6.7600.320, tz: -0700)  ===========
2014-09-20 19:06:21:658 3236 1774 Misc   = Process: C:\Windows\system32\wuauclt.exe
2014-09-20 19:06:21:658 3236 1774 Misc   = Module: C:\Windows\system32\wucltux.dll
2014-09-20 19:06:21:658 3236 1774 CltUI FATAL: Failed to connect to AU engine to get notification handle, hr=80070005
2014-09-20 19:06:21:663 1376 1158 AU AU received handle event
2014-09-20 19:06:21:663 1376 1158 AU AU setting pending client directive to 'Install Approval'
2014-09-20 19:06:36:675 1376 1158 AU Launched new AU client for directive 'Install Approval', session id = 0x1
let's try this...
Download the all-in-one Windows Repair tool from here - Windows Repair (All In One)
run it - but ONLY the Windows Update repair section. UNCHECK everything else.

then reboot, and try another Check for Updates, and attempt to install only the oldest available update.
My System SpecsSystem Spec
21 Sep 2014   #10

Win7 Home Premium X32

Did as you directed, Noel. There was a change (will detail), then a relapse.

The three screen shots atch show the reaction to launching WU after using the All-In-One Windows Repair Tool (only the Repair Windows Update option). I'd seen this alert several days ago, and the result of clicking "Check for updates" is shown in the next screen shot. (Had also seen that before.) Clicking "OK" brought up the advisary about the WU service, but as you can see from the last screen shot, the service was, in fact running.
Attachment 334158

Attachment 334159

Attachment 334160

I elected to restart the service and try WU again. This time I was advised that the system should be restarted, which I did...and was rewarded after restart with the same symptoms as I posted at the beginning of this thread: "publisher valid certificate" and when clicking to proceed anyway, Windows advising that device, folder, file, et al. cannot be accessed.

I've attached the two log files that the Repair util created.

Over to you...and sincere appreciation for investing your time in my problem.

My System SpecsSystem Spec

 No updates for Windows 7, 32-bit

Thread Tools

Similar help and support threads
Thread Forum
Windows Check for updates keeps running-all installation/updates fail
I have never posted on a forum before so apologies if I am doing this wrong. The problem started when I tried to plug in my (new) iphone to my Dell pc. The device was not detected so I tried to update my itunes software - update failed and I received a Windows 7 error. After searching through...
Windows Updates & Activation
Windows 7 restore to updates, no boot, loop back to updates
Dell Latitude 2120. Windows 7 trying to restore at boot up, loads 18000+ updates then restores again in loop. Safe mode attemp restore lists OS C: as only selectable drive, operating drive is D: <DIR> lookup shows an apple update and delete april of 2013 appears to be when problem started.
Backup and Restore
Windows Updates Fails configuring updates and reverts back
EDIT: Please see my updated information a few posts down. Hello, I'm having issues on a Windows 7 64 bit system. If the updates install, then upon restart it fails configuration and reverts back. Otherwise the the updates will fail and I get the following when using the windows fix it for...
Windows Updates & Activation
Windows wont complete updates, Security Updates KB2604121
Its been doing most of these updates forever, when I go to shut it down it updates but when I wake up in the morning these updates are still not done... It's like they never finish. This happens every night for the past 6 months or so i'm getting tired of it now so i need some help. I've tried...
Windows Updates & Activation
Windows 7 updates same for updates every time it checks for updates
For the past day windows wants to install the same 4 updates over and over, I have windows update set to download and let me choose when to install. I can't understand why I even need them, as I uninstalled net framework. Notice how the update at 8:17 AM., KB2656368, is the same as one of...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App