Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win 7 Service Pack 1 installation fails - AND messes up drive letters!

27 Jan 2015   #41

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint

Have you booted from the disk and tried startup repair. Try disconnecting all the other drives except the hard drive Windows is on. try running startup repair. Startup Repair. You may have to run it 3 times with attempted boots in between each run. If it says it cannot find a Windows install, try marking the system partition active, using the command prompt. Partition - Mark as Active

My System SpecsSystem Spec
28 Jan 2015   #42

windows 7 home premium

Yes thanks, I've tried multiple boots on startup repair. Up to 5 at least on some attempts! On each occasion it says it has been unable to do the repair and offers me the opportunity to do a recovery. This also fails. The only way to get things working again is to go to safe mode which then immediately starts the 'reverting changes' procedure as previously outlined.

PS I probably should reiterate at this point that after installing SP1 it does reboot as far as the 'starting windows' splash screen (ie with the four bits of flying colour) before giving up the ghost. However, which disk partition does this come from? If this is where/when the drives change over, you could be on to something though regarding the 'active' partition and so on?
My System SpecsSystem Spec
28 Jan 2015   #43
Layback Bear

Windows 7 Pro. 64/SP-1

Because of the failure of Repair install and Startup Repair I know of nothing else to do except a Clean Install.
Here is a tutorial by Brink.

Clean Install Windows 7
My System SpecsSystem Spec

28 Jan 2015   #44

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Just stopping in to offer a few suggestions, you might have already done some of this

There are three things that perked up my ears:
1) Chkdsk stopped at 65% (post# 13) - this might be a misread on my part, maybe that's the last time you looked.
2) Two disk 'failures' (post# 14)
3) Access denied (post# 33)

1 (unexpected end) & 2 (two drives) seem to indicate a controller issue.
Look at the Disk Check events (I'm loading the now and ).
Check Disk (chkdsk) - Read Event Viewer Log

If you ran chkdsk offline (Repair or Install disc), then there isn't an event to view
I didn't see anything in the App events that indicate anything (chkdsk runs and fixed anything found, but most were nothing found).

There was an older event in the System log event 11
Custom dynamic link libraries are being loaded for every application. The system administrator should review the list of libraries to ensure they are related to trusted applications. Please visit Working with the AppInit_DLLs registry value for more information.
-> I have no clue if this has any bearing on the current issue, but it is a warning and you might want to put on your thinking cap to see if the dates of the events and things you installed or uninstalled around the time mean anything to you.

Might as well look though
Open an elevated Command Prompt and enter the following command:
reg query "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows"
If I read the support page right, AppInit_DLLS should be null
Viewing chkdsk events:
Filter the Application Log (right click, Filter current log).
Select all but verbose Event Levels,
then in the Event Sources box, select Chkdsk and Wininit, press [OK]
Attachment 347920

All of these steps are routine maintenance, but for your machine, the disk activity might force an error that was only a slight problem. Windows disk management usually recovers and takes care of moving good files to good spots on the disk. Usually....

Before you begin: Do you have a good backup of your data? Please make a backup if you can, before proceeding

Clean up temporary files
Restart your machine in case there are any system operations pending

Click here to download Old Timer-TFC.
>> save the application to your Desktop.
Old Timer-TFC is a standalone application, there is no install.

Save your work and close all open windows.
TFC will close ALL open programs including your browser!

Right click, run as administrator TFC

Click the Start button to begin the cleaning up temporary files and folders.
Do not work on other things while TFC is running - most applications use some sort of temporary files. Just let TFC run by itself on the machine until it completes.

If TFC prompts you to reboot, do so immediately.
If TFC does NOT prompt you, then reboot your machine immediately after TFC has completed.

Clean up Windows and the disk
Run Disk Cleanup as administrator
type cleanmgr in the Start menu search box
right click Disk Cleanup in the results and pick Run as administrator
Select all boxes
Optional - can be done later
Press the [Cleanup System files] button
Press the [Cleanup ...] button under System Restore and Shadow copies
Press [OK]
Answer yes to any prompt - after reviewing the message. If your not certain, ask.

There is a kb that allows Windows Updates to be cleaned in Disk Cleanup - but I think it requires SP1 .... just a notation.

Disable hibernation:
Launchh an elevated Command Prompt (Right click, select Rin as administrator...)
type the following commands
powercfg /h off
there is no output

Run Defrag on C:, if there are many passes, more than 5, run a few manual defrags. I try to get down to 3 or 4 passes, but that might take a while on your machine. Run one and let me know how many passes it took. This is an art, not a science.

That's all I can think at the moment. The access denied will make me think about the issue from a different perspective. If I come up with anything on that, I'll post it.

My System SpecsSystem Spec
29 Jan 2015   #45

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Thanks for jumping in, guys.
My System SpecsSystem Spec
01 Feb 2015   #46

windows 7 home premium

Thanks for the responses. It will be a few days before I get chance to go through it all but will report back then. Cheers
My System SpecsSystem Spec

 Win 7 Service Pack 1 installation fails - AND messes up drive letters!

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 service pack 1 install fails
been trying to install sp1 for some time now and keep getting a HRESULT = 0x80070005 - E_ACCESSDENIED I am currently trying to run the update readiness tool
Windows Updates & Activation
Windows 7 Service Pack 1 fails repeatedly
I had some trojan issues on this computer which have been completely resolved. All updates have installed except service pack one. I have run the update readiness tool and the log from the csi says payload file missing. I have run sfc /scannow that comes back with errors that cannot be fixed even...
Windows Updates & Activation
Service Pack 1 Fails, error 8004100E
I've spent a day and a half trying to get service pack 1 installed on a machine. I've tried shutting down my security programs, installing it manually, and the fixits from this post: I'm...
Installation & Setup
Windows 7 Service Pack 1 (SP1) consistently fails to install -80246007
SP1 consistently fails to install. I have tried all the usual suggestions including the System Readiness Tool. The CHECKSUR logs are included below. Can anyone help me correct the corrupted System Store? Thanks in advance. CHECKSUR.LOG ================================= Checking System...
Windows Updates & Activation
Service Pack 1 fails to install (error_file_not_found_0x80070002)
I've never been offered SP1 through windows update for some reason so i decided to download the standalone installer and i went through the following steps: 1. Ran the system update readiness tool - no errors found. 2. Went through following steps before installing - Steps to follow before you...
Windows Updates & Activation
Service pack 1 fails - error 80073712
Hello guys! I am having trouble installing sp1 despite other windows updates having been flawless so far. I tried following instructions found at the Windows site but the System Update Readiness Tool didn't find any errors and repair installation aborts. Sorry to bother you with another "sp1 fail"...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App