Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 80070422 error

07 Oct 2014   #1

windows 7 home premium 64bit os
80070422 error


I have had this problem for a couple months now and have not been able to solve the issue despite many attempts. At one point i had even managed to contact the windows technical support staff. For any of you who have actually attempted finding that on the microsoft site, you know what a pain in the butt that can be to do. I spent a couple hours with them, and they too were unable to resolve the issue even with full access to my computer. The technician then recommended I buy the windows defender premium for 159/year... This is a 400 dollar laptop. I also asked if he knew it would fix my issue, he said it should. So for 159 a year on a 400 laptop I MIGHT be able to fix the problem. I said no. I bought malwarebytes premium edition and that seemed to remove the error (80070422) and let me check for windows updates again... A couple months later, the problem returned. I have not been able to fix it since, and my computer continues to get slower all the time. I read through the posts in this thread and have tried checking a couple things myself. I ran your suggested commands for cmd and only 1 code gave me an issue. When I ran CMD for SC QC SPPUINOTIFY, i got the response "System Error 5 has occurred." All else appeared normal. Any thoughts, suggestions, workarounds? What would you like me to do? Because at this point I am about to reinstall Windows >.< I have only had this laptop since about March 2013.

Thanks, Balto

My System SpecsSystem Spec
07 Oct 2014   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Please post the same logs I requested earlier - I'm going to ask for this thread to be split out to create your own thread
My System SpecsSystem Spec
07 Oct 2014   #3

windows 7 home premium 64bit os

Farbar Service Scanner Version: 21-07-2014
Ran by John (ATTENTION: The logged in user is not administrator) on 07-10-2014 at 17:59:02
Running from "C:\Users\John\Downloads"
Microsoft Windows 7 Home Premium Service Pack 1 (X64)
Boot Mode: Normal

Internet Services:

Connection Status:
Localhost is accessible.
LAN connected.
Google IP is accessible. is accessible. is accessible.

Windows Firewall:

Firewall Disabled Policy:

Action Center:

Windows Update:

Windows Autoupdate Disabled Policy:

Windows Defender:
WinDefend Service is not running. Checking service configuration:
The start type of WinDefend service is set to Demand. The default start type is Auto.
The ImagePath of WinDefend service is OK.
The ServiceDll of WinDefend service is OK.

Windows Defender Disabled Policy:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender]

Other Services:

File Check:
C:\Windows\System32\nsisvc.dll => File is digitally signed
C:\Windows\System32\drivers\nsiproxy.sys => File is digitally signed
C:\Windows\System32\dhcpcore.dll => File is digitally signed
C:\Windows\System32\drivers\afd.sys => File is digitally signed
C:\Windows\System32\drivers\tdx.sys => File is digitally signed
C:\Windows\System32\Drivers\tcpip.sys => File is digitally signed
C:\Windows\System32\dnsrslvr.dll => File is digitally signed
C:\Windows\System32\mpssvc.dll => File is digitally signed
C:\Windows\System32\bfe.dll => File is digitally signed
C:\Windows\System32\drivers\mpsdrv.sys => File is digitally signed
C:\Windows\System32\wscsvc.dll => File is digitally signed
C:\Windows\System32\wbem\WMIsvc.dll => File is digitally signed
C:\Windows\System32\wuaueng.dll => File is digitally signed
C:\Windows\System32\qmgr.dll => File is digitally signed
C:\Windows\System32\es.dll => File is digitally signed
C:\Windows\System32\cryptsvc.dll => File is digitally signed
C:\Program Files\Windows Defender\MpSvc.dll => File is digitally signed
C:\Windows\System32\ipnathlp.dll => File is digitally signed
C:\Windows\System32\iphlpsvc.dll => File is digitally signed
C:\Windows\System32\svchost.exe => File is digitally signed
C:\Windows\System32\rpcss.dll => File is digitally signed

**** End of log ****
My System SpecsSystem Spec

07 Oct 2014   #4

windows 7 home premium 64bit os

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\John>net start sppsvc
The Software Protection service is starting.
The Software Protection service was started successfully.

C:\Users\John>sc qc sppsvc
[SC] QueryServiceConfig SUCCESS

BINARY_PATH_NAME : C:\Windows\system32\sppsvc.exe
TAG : 0
DISPLAY_NAME : Software Protection

C:\Users\John>sc queryex sppsvc

WIN32_EXIT_CODE : 0 (0x0)
PID : 11088

C:\Users\John>net start sppuinotify
System error 5 has occurred.

Access is denied.

C:\Users\John>sc qc sppuinotify
[SC] QueryServiceConfig SUCCESS

SERVICE_NAME: sppuinotify
BINARY_PATH_NAME : C:\Windows\system32\svchost.exe -k LocalService
TAG : 0
DISPLAY_NAME : SPP Notification Service

C:\Users\John>sc queryex sppuinotify

SERVICE_NAME: sppuinotify
WIN32_EXIT_CODE : 1077 (0x435)
PID : 0

My System SpecsSystem Spec
08 Oct 2014   #5

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

You appear not to be in an Administrator Account - and did not apparently run the commands I posted in an Elevated Command Prompt. Without elevation, the sppuinotify service will always result in an error code 5.

The Startup on the sppsvc service is wrong. It should be set to Auto(Delayed start).

Please follow this tutorial and post an MGADiag report - then we can see what the problem is.

Ignore errors produced when clicking on the Copy button - they simply mean that the tool could not create the backup files for some reason. The data is still copied to the clipboard for pasting to your response.

Please also state the Version and Edition of Windows quoted on your COA sticker (if you have one) on the case of your machine (or inside the battery compartment), but do NOT quote the Key on the sticker!
My System SpecsSystem Spec

 80070422 error

Thread Tools

Similar help and support threads
Thread Forum
Windows Error Code 80070422 - Windows Updates
This is a fairly new system I recently set up. It's a Dell Precision T1700 workstation with the following specs: OS: Windows 7 Professional 64-bit Processor: Intel Xeon E3-1271 v3 @ 3.60GHz Memory: 16GB Video Card: NVIDIA NVS 510 Hard Drive: 2 x Crucial M550 1TB SSD drives @ Raid 1...
Windows Updates & Activation
Burnt out from error error error! Time to go back to Paper.
Hello there. I have been redirected here by jamanji, whom has been most helpful by the way. My PC crashed a little over a week ago. Rather than retype everything, I would like to give you the link to my post. I am not 'Tech' per se, but I would like to try and resolve my problem myself, To...
System Security
Windows could not check for updates automatically error 80070422
Hello, I have bee trying to solve this problem for a few hours now. When I select "check for updates" in Windows Update it gives me the error mentioned in this thread's title (I've attached the screen shot). I tried to do the sfc scan but my command prompt box (after entering "sfc /scannow")...
Windows Updates & Activation
BSOD by ntoskrnl.exe, error d1, error 3b, error 1a
I've just install windows 7 home premium 64bit and got 4 times of BSOD. for the first time error code is 0x0000001a for the 2nd time error code is 0x0000003b for the 3rd time error code is 0x0000003b for the 4th time error code is 0x000000d1 I also attach minidump files and text files that...
BSOD Help and Support
Scan Error Error while Scan::0::LEAD Error: Twain source manager no
hi.... i have promblme , i do not know how to fix it.. i have kodak scnners i1220 plus i have RD Web Access the promblme is.. I have a system based on Oracle has been connted with one scanners( i connected with scanners) When i do a scan shows me this a message (Scan Error Error while...
Hardware & Devices
Windows Update Fails Error Code 80070422
The service is started and automatic, was automatic (Delayed) but changed that - no difference. I did receive 3 updates yesterday but Belarc Advisor states I'm short of 11 critical updates. I believe it as I just installed Office and no updates are being offered. Maybe the servers are down. I...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:31.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App