Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: newly restored system, WU says service not running

30 Oct 2014   #1

seven home premium x64
newly restored system, WU says service not running

I did a Factory Restore on my sister's Toshiba Satellite C655-S5049 laptop due to presumed malware, or damage from malware, that I was unable to repair after many tries. She had not made recovery media, so I recovered from the recovery partition on the internal HD.

Of possible importance, though I'm not sure where, is that the internal HD was replaced about a year ago. There were regular "not genuine Windows" for a long time, but it was never clear to me whether these started with the HD replacement or were due to malware. (The running Windows is certainly what came with the computer, which she bought new at Best Buy.)

(Does any malware infect the recovery partition? I hope not, but it's protected only by software.)

The first bad sign was that Windows claimed the driver for the WiFi adapter was improperly signed. It still made that claim after uninstalling and reinstalling -- but then Windows accepted it.

Or maybe that was the second bad sign. I'm frequently getting messages "do you want to allow such-and-such program signed by Unknown to run". That's random programs like the Windows Installer.

Well, this reinstall came from a recovery partition created in 2010 (when she bought the computer). Obviously it's critical to load the Windows updates. I got the infamous "Windows Update cannot currently check for updates, because the service is not running. You may need to restart your computer".

Search. Do the "rename c:\windows\softwaredistribution" thing (including disabling and enabling the Win Update service), reboot a few times, no help.

I downloaded SURT and tried to run it but could not even install it: "Installer encountered an error:0xc8000247".

I was reluctant to let sfc do updates on a freshly installed system without further input, so I did sfc /verifyonly. The forum extraction instructions obviously missed critical data (the run said it found integrity violations, the extracted data did not), so I manually extracted all records during the time period of the sfc run. That's the file I've attached.

I did the oft-requested net start commands; results below.

What next?


C:\windows\system32>net start bfe
The requested service has already been started.

More help is available by typing NET HELPMSG 2182.

C:\windows\system32>net start bits
The requested service has already been started.

More help is available by typing NET HELPMSG 2182.

C:\windows\system32>net start wuauserv
The requested service has already been started.

More help is available by typing NET HELPMSG 2182.

C:\windows\system32>net start trustedinstaller
The Windows Modules Installer service is starting.
The Windows Modules Installer service was started successfully.


My System SpecsSystem Spec
01 Nov 2014   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Let's have a closer look or two...
You mention non-genuine notifications...

Please follow this tutorial and post an MGADiag report - then we can see what the problem is.

Ignore errors produced when clicking on the Copy button - they simply mean that the tool could not create the backup files for some reason. The data is still copied to the clipboard for pasting to your response.

Please also state the Version and Edition of Windows quoted on your COA sticker (if you have one) on the case of your machine (or inside the battery compartment), but do NOT quote the Key on the sticker!

As far as windows Update is concerned...

Please download the Farbar Service Scanner from

Right-click on the saved file and select 'Run as Administrator', and tick all the options, then click on the Scan button - copy and paste the report to your response.


Please follow the Windows Update Posting Instructions and post the requested data
If the file is too large (8MB compressed), remove the older CBSPersist cab files until the final file is below the limit - you can always post them separately after zipping them. (the forum doesn't allow the upload of bare CAB files, for a number of reasons)
My System SpecsSystem Spec

 newly restored system, WU says service not running

Thread Tools

Similar help and support threads
Thread Forum
Random BSOD while running, IRQL GT zero at system service
I just encountered my first BSOD on my computer randomly and I have no idea what caused it. I attached my .zip from DM Log Collector. Thanks guys, I've used this site when searching for errors/problems in the past in google and I always get the sevenforums :)
BSOD Help and Support
c0000005 errors when running newly installed games
Hi, I've been having problems with games crashing with c0000005 as soon as I run them. This isn't happening with games I've had installed for a while, it has only started when i've tried to install new games in the last month or so. I've attached my files from the SF tool. I was wondering if...
General Discussion
Batch file to start a service if the service is not running
Here what I want : if servicename is running, do nothing. if servicename is not running, then start servicename, then record the date and time. based on my search online, here is what I have so far: net start | find "servicename" > nul 2>&1
General Discussion
Newly installed Win 7 running slow on strong PC
Hi, hope I will find some help here... I've just installed fresh Win 7 ultimate x64 via USB. Right from the start it was working really slow but it just got worse. My hardware is decent: Intel i7 CPU, 12GB RAM, WD Caviar 500GB system HDD. Task Manager shows that only 13% of RAM is being used...
Performance & Maintenance
Unexpected shutdown if system service "power" is running
so my computer started unexpectedly shutting down about 60 seconds after loading windows today. No BSOD, no error message, no warning, just a hard shutdown. It happened consistently every time I started the computer, unless I was in safe mode, then I had no issues. So I went into msconfig, and...
BSOD Help and Support
Why did 'System Restore' restored my Internet service?
I use cable internet. My modem was online all the time and was able to reset the miodem succesfully. I tried the release/renew in command prompt and it said media disconnected. I also power cycled the modem but still not internet. Finally, I did a System Restore and was able to restore my Internet....
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App