Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 Update error 800706BA

12 Nov 2014   #21

Win7 Ultimate x64 SP1

I just did some quick Bing work on error code 80070426. I found this link:

Windows Update Error 80070426 - Microsoft Community

It's an older post, but it states that "This problem occurs if the Software Licensing service (Slsvc.exe) is not running while updating windows" and then provides instructions for confirming if Slsvc.exe is running. When I look at my services, I don't see that one listed anywhere. Does that have anything to do with it?

My System SpecsSystem Spec
12 Nov 2014   #22

Win7 Ultimate x64 SP1

Saw on another thread here on these forums that error code 80070426 could also be related to the cryptographic service not starting. I went to services, found that one, saw it was stopped (set to automatic), and tried to manually start it. I got the attached error message.

Not sure if any of that helps narrow it down.

Thanks again, Noel.
My System SpecsSystem Spec
13 Nov 2014   #23

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

The 426 error is a generic one and applies to any service, not just the SPPSVC (in Win7) or SlSvc (in Vista) - although it is a common one, especially if the system is showing as being non-genuine.
In this case the problem service is the Cryptsvc, which is one of Windows' root services, and affects almost everything.

Let's have a closer look at it
Open an Elevated Command prompt, and run the following commands..

net start cryptsvc
sc qc cryptsvc
sc queryex cryptsvc
sc qprivs cryptsvc
sc qsidtype cryptsvc
sc sdshow cryptsvc

Post the results...

Here are some instructions to make lifeeasier :)

1) To open anElevated Command Prompt Window (the ECP window), click on Start, All Programs,Accessories – then right-click on Command Prompt, and select Run asAdministrator. Accept the UAC prompt.

2) To run thecommands easier, highlight the block of commands, and right-click on thehighlight – select Copy. In the CP Window, click on the black/white icon at topleft – select Paste. The commands will run but may not complete the lastcommand, so hit the Enter Key once.

3) To copy theresults... click on the Black/White icon in the top left, and select Edit...'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to pasteit into your response.
My System SpecsSystem Spec

13 Nov 2014   #24

Win7 Ultimate x64 SP1

Here's the output from those commands as requested.

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>net start cryptsvc
The Cryptographic Services service is starting.
The Cryptographic Services service could not be started.

A system error has occurred.

System error 1067 has occurred.

The process terminated unexpectedly.

C:\Windows\system32>sc qc cryptsvc
[SC] QueryServiceConfig SUCCESS

SERVICE_NAME: cryptsvc
BINARY_PATH_NAME : C:\Windows\system32\svchost.exe -k NetworkService
TAG : 0
DISPLAY_NAME : Cryptographic Services
SERVICE_START_NAME : NT Authority\NetworkService

C:\Windows\system32>sc queryex cryptsvc

SERVICE_NAME: cryptsvc
WIN32_EXIT_CODE : 1067 (0x42b)
PID : 0

C:\Windows\system32>sc qprivs cryptsvc
[SC] QueryServiceConfig2 SUCCESS

SERVICE_NAME: cryptsvc
PRIVILEGES : SeChangeNotifyPrivilege
: SeCreateGlobalPrivilege
: SeImpersonatePrivilege

C:\Windows\system32>sc qsidtype cryptsvc
[SC] QueryServiceConfig2 SUCCESS

SERVICE_NAME: cryptsvc

C:\Windows\system32>sc sdshow cryptsvc


My System SpecsSystem Spec
13 Nov 2014   #25

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

The 1067 error tells me almost nothing
Let's have a look at the event logs...

Open Event Viewer

click on theWindows logs entry in the left pane to expand it.

Now click on theApplication entry - wait while it loads.

Click on 'File'in the menu bar and select Save...

Save the file asAppevt.evtx

Repeat for theSystem log

then zip both,and upload them.

My System SpecsSystem Spec
13 Nov 2014   #26

Win7 Ultimate x64 SP1

There were 14650 events in the App section and 43771 events in the system section, but I was only able to save 256 events from each at a time. Is there a more convenient way to save all of those, rather than doing 256 events at a time?

I've uploaded the 256 most recent events from each.

~ Greg ~
My System SpecsSystem Spec
14 Nov 2014   #27

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Here's one of the critical errors...

Windows cannot access the file C:\Windows\System32\catroot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\ for one of the following reasons: there is a problem with the network connection, the disk that the file is stored on, or the storage drivers installed on this computer; or the disk is missing. Windows closed the program Host Process for Windows Services because of this error.
... and another...
Faulting application name: svchost.exe_CryptSvc, version: 6.1.7600.16385, time stamp: 0x4a5bc3c
Faulting module name: bcryptprimitives.dll, version: 6.1.7601.17514, time stamp: 0x4ce7c4f0
Exception code: 0xc0000006
Fault offset: 0x00000000000080bf
Faulting process id: 0x2efc
Faulting application start time: 0x01cfff6b91015234
Faulting application path: C:\Windows\system32\svchost.exe
Faulting module path: C:\Windows\system32\bcryptprimitives.dll
Report Id: ced74748-6b5e-11e4-9526-0030914000f
From the SYstem log it looks as if your hard drive is failing.

Back up your data NOW - to external media.
Once you've done that, run a CHKDSK , then post the new Application event log, and we'll see how bad it is.

Click on Start > All Programs > Accessories

Right-click onthe Command Prompt entry

Select Run as Administrator and accept the UAC prompt- the Elevated Command Prompt window should pop up.

At the Commandprompt, type


and hit the Enter key.

You will be toldthat the drive is locked, and the CHKDSK will run at the next boot - hit the Ykey, and then reboot.

The CHKDSK willtake a few hours depending on the size of the drive, so be patient!

After the CHKDSK has run, Windows should bootnormally (possibly after a secondauto-reboot) - then run the SFC.

My System SpecsSystem Spec
14 Nov 2014   #28

Win7 Ultimate x64 SP1

It took about 20 mins or so for chkdsk to run. Not sure if that's good or bad. New app log is attached.

~ Greg ~
My System SpecsSystem Spec
14 Nov 2014   #29

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

You have massive problems with the hard drive
CHKDSK is verifying files (stage 1 of 5)...

Cleaning up instance tags for file 0x19aac.

  265472 file records processed.                                          File verification completed.

  691 large file records processed.                                      0 bad file records processed.                                        4 EA records processed.                                              85 reparse records processed.                                       CHKDSK is verifying indexes (stage 2 of 5)...

  326302 index entries processed.                                         Index verification completed.

  0 unindexed files scanned.                                           0 unindexed files recovered.                                       CHKDSK is verifying security descriptors (stage 3 of 5)...

  265472 file SDs/SIDs processed.                                         Cleaning up 2135 unused index entries from index $SII of file 0x9.

Cleaning up 2135 unused index entries from index $SDH of file 0x9.

Cleaning up 2135 unused security descriptors.

Security descriptor verification completed.

  30416 data files processed.                                            CHKDSK is verifying Usn Journal...

  36525264 USN bytes processed.                                             Usn Journal verification completed.

CHKDSK is verifying file data (stage 4 of 5)...
The Event entry ran out of buffer space part-way through Stage 4

The first error after the reboot was with the Cryptsvc....
so let's try fixing it. ;:
Repair the catalog database by using Esentutl

To repair the catalog database by using Esentutl:
  1. Click Start, point to All Programs, and then click Accessories.
  2. Right-click Command Prompt, and then click Run as administrator.
  3. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
  4. In the command prompt window, type net stop cryptsvc to stop Cryptographic Services, and then press ENTER.
  5. Type esentutl /p %systemroot%\System32\catroot2\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\catdb, and then press ENTER. By default, %systemroot% is located at C:\Windows.
  6. Click OK to confirm that you should run this tool only on databases that are corrupt. If the tool reports that the database is corrupt, then you will need to empty the catroot2 folder, so that its contents can be rebuilt (as described below).
  7. Type net start cryptsvc to start Cryptographic Services, and then press ENTER.
post the results, don't reboot if you can avoid it.

If it says the database is corrupt...

Please run thefollowing commands in an Elevated Command Prompt


once complete,leave the system alone for at least an hour to rebuild the database, thenreboot,

Note that thismay delete your Update History - but all updates will remain installed, and canbe viewed in the Installed Updates listing.

Then post a new AppEvent log
My System SpecsSystem Spec
14 Nov 2014   #30

Win7 Ultimate x64 SP1

I ran the esentutl and no mention of anything being corrupted. Cryptsvc was restarted, confirmed in Services.

~ Greg ~
My System SpecsSystem Spec

 Windows 7 Update error 800706BA

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 - Update KB976932 and KB982526 update failure- error 800b100
Hey, I'm trying to install update KB976932 (Windows Service pack 1 for 64bit) and KB982526 (Microsoft .NET Framework 3.5 SP1) but I keep getting error 800b100 which stops me from doing so. I've tried deactivating my firewall; manually installing from the microsoft website; and using the...
Windows Updates & Activation
Windows update error code 2 on installing security update .NETF 4.52
Hi everybody I get windows update error code 2 on installing Security Update for Microsoft .NET Framework 4.5, 4.5.1 and 4.5.2 on Windows 7, Vista, Server 2008, Server 2008 R2 x64 (KB2978128) I have also some other errors installing Internet Explorer 11. I have used "sfc /scannow" command...
Windows Updates & Activation
Windows update error 800706BA Failing to install any updates
I just did a fresh install on a new SSD for my laptop. I am getting above error. I reinstalled again and got the same. I ran check disk already. And I started SURT 7 hours ago but it is stuck on Initializing installatipn... help...please...let me know if you need anymore info? Diagnostic...
Windows Updates & Activation
Windows Update Error 80070002 & Windows Update Diag Error 0x8007370B
ASUS Desktop PC CM6850 Series Windows 7 Home Premium SP1 64-bit Core i7 4GB RAM 500GB HDD Windows updates not working for a while. Initial was 8007370B appearing in the Windows Update window when searching for updates. Found bad memory using Memtest86+ and pulled the stick. Other stick...
Windows Updates & Activation
Windows could not search for new updates Error 800706BA
Windows 7 Home Premium SP1 Dell Inspiron 1545 Pentium Dual Core T4400 @ 2.2GHz 3GB RAM 64 bit OS I tried to use Windows Update by clicking but then I receive this message:
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App