Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot install Windows 7 Service Pack 1, CSI files missing (packager.d

24 Nov 2014   #1

Windows 7 Ultimate
Cannot install Windows 7 Service Pack 1, CSI files missing (packager.d

Hi everyone,

I've spent about 2 hours so far trying to figure this one out, so I'm hoping someone in the forums might be able to lend a hand.

I'm unable to install Service Pack 1 on a Windows 7 Ultimate x64 system. Based on initial investigation, it appears to be related to a missing/corrupt packager.dll file.

I've tried sfc /scannow and the System Readiness Tool, but neither fix the problem. Included below is the output from system readiness tool and I've attached the more detailed output from the sfc /scannow.

I'd appreciate any help you could offer, I really would like to avoid rebuilding this system if possible.

Thanks in advance!

Checking System Update Readiness.
Binary Version 6.1.7601.22471
Package Version 26.0
2014-11-24 10:51

Checking Windows Servicing Packages

Checking Package Manifests and Catalogs

Checking Package Watchlist

Checking Component Watchlist

Checking Packages

Checking Component Store
(f) CSI Payload File Missing 0x00000000 packager.dll amd64_microsoft-windows-packager_31bf3856ad364e35_6.1.7601.17727_none_4c2e48b0e7630a9d
(f) CSI Payload File Missing 0x00000000 packager.dll x86_microsoft-windows-packager_31bf3856ad364e35_6.1.7601.21863_none_f06a092048474399
(f) CSI Payload File Missing 0x00000000 packager.dll x86_microsoft-windows-packager_31bf3856ad364e35_6.1.7601.17727_none_f00fad2d2f059967
(f) CSI Payload File Missing 0x00000000 packager.dll amd64_microsoft-windows-packager_31bf3856ad364e35_6.1.7600.16917_none_4a52bb96ea3482c0
(f) CSI Payload File Missing 0x00000000 packager.dll amd64_microsoft-windows-packager_31bf3856ad364e35_6.1.7600.21094_none_4a82ae600395ec28
(f) CSI Payload File Missing 0x00000000 packager.dll x86_microsoft-windows-packager_31bf3856ad364e35_6.1.7600.16917_none_ee34201331d7118a
(f) CSI Payload File Missing 0x00000000 packager.dll x86_microsoft-windows-packager_31bf3856ad364e35_6.1.7600.21094_none_ee6412dc4b387af2
(f) CSI Payload File Missing 0x00000000 packager.dll amd64_microsoft-windows-packager_31bf3856ad364e35_6.1.7601.21863_none_4c88a4a400a4b4cf

Seconds executed: 517
Found 8 errors
CSI Payload File Missing Total count: 8
Customer Experience report successfully uploaded. Thank you for participating. For more information, see the Microsoft Customer Experience Improvement Program on the Microsoft web site.

My System SpecsSystem Spec
25 Nov 2014   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

I've uploaded a file - - to my OneDrive at Noel's OneDrive
Please download and save it.

Right-click on the saved file and select Extract all...
Change the target to C:\ and click on Extract
Close all windows (it would be a good idea to print these instructions!)

Now reboot to the Repair Environment - as soon as the machine restarts, start tapping F8 - this should bring up the Advanced Boot Menu, at the top of which should be the option 'Repair my Computer'
Pick that
You'll have to log in with your username and password.

Pick the option to use a Command Prompt
At the prompt type
DIR C:\dgmaa
hit the enter key - if you get a 'Not Found' error try
DIR D:\dgmaa
DIR E:\dgmaa

The drive letter in use when you find the folder will need to be substituted (for<drive>) into the following command...

XCOPY <drive>:\dgmaa <drive>:\windows\winsxs /y /i /s /v /h

(e.g. XCOPY P:\wfire P:\windows\winsxs /y /i /s /v /h )

run the command (it should take almost no time) and when the prompt returns, type
and hit the Enter key to exit Command Prompt - reboot to Normal Mode Windows.

Now run SFC /SCANNOW in an Elevated Command Prompt
then reboot and upload the FULL new CBS.log file to your reply - copy it to your desktop and compress it for upload.
Also, run CheckSUR again, and post the FULL CheckSUR.log file
My System SpecsSystem Spec
25 Nov 2014   #3

Windows 7 Ultimate

Hi NoelDP,

Thanks for the quick response. If you don't mind me asking, how did you get your hands on those files. I created a separate Windows 7 Ultimate x64 install, updated everything, and those files were not in the C:\Windows\winsxs directory.
My System SpecsSystem Spec

26 Nov 2014   #4

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

It comes from having kept the system up-to-date for the past 4 years Any I don't actually have installed I can extract from the relevant download (if I can find it!)
My System SpecsSystem Spec

 Cannot install Windows 7 Service Pack 1, CSI files missing (packager.d

Thread Tools

Similar help and support threads
Thread Forum
Factory Windows 7 Service pack 1 but service pack shows in updates?
Just bought new never used factory fresh PC Acer AXC-605-UR29 Windows 7 Service Pack 1 manufacrtured this year, I checked for latest updates and sure enough Service Pack 1 shows up in updates Windows 7 Service Pack 1 for x64-based Systems (KB976932) Download size: 9.1 MB
Windows Updates & Activation
Windows 7 Service Pack 1-Just will not install..tried
I have read and followed for the past year all advice given about this error. Basically the system store is corrupt and I have no idea where to go to get the files to fix it. I have attached screen prints of error code and also the log files as requested in posting updates. Have run System...
Windows Updates & Activation
I Need help to Install Windows 7 with Service Pack 1 on my PC
Hi, I'm Glad I Joined this Forum, I am Still Finding Out how to Show my IDE Hard Disk (Samsung SP0842N) But when I start the Setup, It Redirect to the Load Driver. What Should I Do to Install Windows 7 from my IDE DVD-ROM to IDE HDD? Thanks for the Hands, Nico
Installation & Setup
Can't install Windows 7 Service Pack 1
I have Win 7 Ultimate 32-bit. I have never had SP1 before. I recently rolled back my PC a few day with system restore, then updated Windows to the newest updates. I downloaded SP1 32-bit and when I try to install it, it installs right to almost the end and gives me:Error 0x80070002 I've looked...
Windows Updates & Activation
When can we install Windows 7's first service pack?
ya so umm, when do the rest of us get the good stuff? :geek:
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App