Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 Home Premium SP1 Update error 0x800B0100

05 Jan 2015   #1

64 bit Windows 7
Windows 7 Home Premium SP1 Update error 0x800B0100

Noel ...

I received "again" the “Windows Not Genuine” message screen! System Properties show me “Windows 7 Home Premium”, Windows activation: “Windows is activated, Product ID: 00359-OEM-8882432-58635, The MGADiagnostics tool responds my version is “Genuine” (see below!)

Today I received the 64-bit Windows 7 Home Premium SP1 Reinstallation DVD from Dell. The DVD states: The Microsoft operating system Certificate of Authenticity (COA) is a label located on the bottom of your computer. The COA contains the product key code, which might be required to complete the operating system setup. The problem: The label on my system shows a COA for the Vista Home Premium OS. Dell updated the Vista Version to Win 7 offered for free in July of 2009. Would the same COA work for the Windows 7 Home Premium Reinstallation DVD? Another problem would be a fresh install not only of the OS but the time required to re-install over 50 Programs properly configured and ready to run.

I was able to reverse the restore point from before November 30 and so able to install all Windows updates including those of December 10. I "again" was not able to install (since August) the 64-bit Windows 7 SP1 update KB976932 see below and received the error code 0x800B0100. I downloaded and ran the 64-bit System Update Readiness Tool three times followed by the “Fix it” KB 956702 to no avail. Is the amount of single updates (292) I received since December of 2009 a problem to install Service Pack 1?

The earlier tampered Registry entries did not show up. Checking the System Registry entries related to SLUI.EXE:
C:\Windows\system32>REG QUERY HKLM\SOFTWARE\Wow6432Node\Classes\TypeLib\{EE57495
7-4077-4AD6-8658-327C2C86C5AA} /S
(Default) REG_SZ SPPUI 1.0 Type Library
(Default) REG_EXPAND_SZ %SystemRoot%\System32\slui.exe
(Default) REG_SZ 0

Results Running the Microsoft Genuine Advantage Diagnostics Tool:
Diagnostic Report (1.9.0019.0):
WGA Data-->
Validation Status: Genuine
Validation Code: 0
Cached Validation Code: 0x0
Windows Product Key: *****-*****-PHMJD-H6WFF-3JFG9
Windows Product Key Hash: MDozAz6ccP1R2XxzRxgu6Gn4RRo=
Windows Product ID: 00359-OEM-8882432-58635
Windows Product ID Type: 3
Windows License Type: OEM System Builder
Windows OS version: 6.1.7600.2.00010300.0.0.003
ID: {E6C3E0E3-05D6-436B-814C-BCF31272682A}(3)
Is Admin: Yes
TestCab: 0x0
WGA Version: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Home Premium
Architecture: 0x00000009
Build lab: 7600.win7_gdr.130318-1532
TTS Error:
Validation Diagnostic:
Resolution Status: N/A
WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
WGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002
OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002
OGA Data-->
Office Status: 100 Genuine
Microsoft Office XP Professional - 100 Genuine
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3_E2AD56EA-765-d003_E2AD56EA-766-0_E2AD56EA-134-80004005_E2AD56EA-765-b01a_E2AD56EA-766-0_E2AD56EA-148-80004005_16E0B333-89-80004005_B4D0AA8B-1029-80004005
Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed
File Scan Data-->
Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{E6C3E0E3-05D6-436B-814C-BCF31272682A}</UGUID><Version>1.9.0019.0</Version><OS>6.1.7600.2.00010300.0.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-3JFG9</PKey><PID>00359-OEM-8882432-58635</PID><PIDType>3</PIDType><SID>S-1-5-21-2567437654-698764886-1245489548</SID><SYSTEM><Manufacturer>Dell Inc.</Manufacturer><Model>Studio XPS 1340</Model></SYSTEM><BIOS><Manufacturer>Dell Inc.</Manufacturer><Version>A11</Version><SMBIOSVersion major="2" minor="5"/><Date>20090908000000.000000+000</Date></BIOS><HWID>27B93607018400F8</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>DELL </OEMID><OEMTableID>QA09 </OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{91110409-6000-11D3-8CFE-0050048383C9}"><LegitResult>100</LegitResult><Name>Microsoft Office XP Professional</Name><Ver>10</Ver><Val>B7329F7DAA184DC</Val><Hash>DphMBe9f82H/SWDx3K7ZMBasObk=</Hash><Pid>54186-760-2673746-17125</Pid><PidType>1</PidType></Product></Products><Applications><App Id="15" Version="10" Result="100"/><App Id="16" Version="10" Result="100"/><App Id="18" Version="10" Result="100"/><App Id="1A" Version="10" Result="100"/><App Id="1B" Version="10" Result="100"/></Applications></Office></Software></GenuineResults>
Spsys.log Content: 0x80070002
Licensing Data-->
Software licensing service version: 6.1.7600.16385
Name: Windows(R) 7, HomePremium edition
Description: Windows Operating System - Windows(R) 7, OEM_COA_NSLP channel
Activation ID: 9f83d90f-a151-4665-ae69-30b3f63ec659
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00359-00176-824-358635-02-1033-7600.0000-3362009
Installation ID: 004004227696264982874662462052412895823712044913687366
Processor Certificate URL: SpcService Web Service
Machine Certificate URL: RacService Web Service
Use License URL: UseLicenseService Web Service
Product Key Certificate URL: PkcService Web Service
Partial Product Key: 3JFG9
License Status: Licensed
Remaining Windows rearm count: 3
Trusted time: 1/5/2015 6:44:33 PM
Windows Activation Technologies-->
HrOffline: 0x8004FE22
HrOnline: 0x00000000
HealthStatus: 0x0000000000000800
Event Time Stamp: 1:4:2015 17:28
WAT Activex: Registered
WAT Admin Service: Registered
HWID Data-->
OEM Activation 1.0 Data-->
OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
SSDT PmRef Cpu0Tst
SSDT PmRef Cpu0Tst
SSDT PmRef Cpu0Tst
SSDT PmRef Cpu0Tst
SSDT PmRef Cpu0Tst
SSDT PmRef Cpu0Tst
SSDT PmRef Cpu0Tst
SSDT PmRef Cpu0Tst
SSDT PmRef Cpu0Tst

I installed and ran the Hotfix 64-bit System Update Readiness Tool KB947821 successfully (three times) saying Installation complete, followed by trying to update the recommended Windows 7 Service Pack 1 for x64-based systems and receive again error code 800b0100
Tried to get help at Error 0x800B0100 when you try to install Windows Updates or Microsoft Updates and ran "Fix it" with the following result:

Trobleshooting was unable to Automatically fix all of the issues found. You can find more details below.

Windows Update error.0x800B0100 Not fixed
Cryptographic service components are not registered NOT fixed
Service registration is missing or corrupt Fixed
Problems installing recent updates Fixed
Problems installing recent updates Fixed

Thanks for all your help

My System SpecsSystem Spec
06 Jan 2015   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

(For the benefit of our other readers, fdohmann joins us from the MS forums, as the subject was getting off-topic for the WGA forums there)

Please follow the Windows Update Posting Instructions and post the requested data

If the file is too large (8MB compressed), remove the older CBSPersist cab files until the final file is below the limit - you can always post them separately after zipping them. (the forum doesn't allow the upload of bare CAB files, for a number of reasons)
My System SpecsSystem Spec
06 Jan 2015   #3

64 bit Windows 7

Noel ...

Thanks! After the Windows "Not genuine" message appeared again this Morning after boot, I clicked "Resolve online now" and finally got the "Welcome to Windows" message. I believe dealing with the SP1 update issue running the MGADiagnostics, the "System Update Readiness Tool" and "Fix it" (including sfc /scannow) several times it "healed" itself. Before I send you the CBSPersist cab files I will try the SP1 update again.
My System SpecsSystem Spec

06 Jan 2015   #4

64 bit Windows 7

No, I got the same "800B0100" error. Please see the attached CBSLog file.
My System SpecsSystem Spec
06 Jan 2015   #5

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Just the one error in CheckSUR...
Unavailable repair files:

I've uploaded a file - - to my OneDrive at Noel's OneDrive
Please download and save it.
Right-click on the downloaded file, and select Extract all…
Extract to the default location - which will create a new folder fdoaa in the same place.
Open this folder - there should be one folder inside it (Packages)

Copy the content of the Packages folder to the folder

Now run the CheckSUR tool again (it may take a while)

Post the new CheckSUR.log file, and the CheckSUR.persist.log file.
My System SpecsSystem Spec
06 Jan 2015   #6

64 bit Windows 7

Please see the new log files attached!
My System SpecsSystem Spec
06 Jan 2015   #7

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

CheckSUR seems to be happy now...
What happens in you do a Check for updates, and attempt to install SP1 now?
My System SpecsSystem Spec
06 Jan 2015   #8

64 bit Windows 7

Yep, that worked SP1 is installed! Thanks Noel, reviewing the update history, something I tried first on 06/24/2013 is finally done.
My System SpecsSystem Spec
07 Jan 2015   #9

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

...and the newer updates are also going in now?
My System SpecsSystem Spec
07 Jan 2015   #10

64 bit Windows 7

Added two more updates yesterday!

The First Noel the angel did say
Was to certain poor shepherds
in fields as they lay;
In fields as they lay, keeping their sheep,
On a cold winter's night that was so deep.

It is getting cold here in South Carolina. But why should Germans worry about that? Heard about the upcoming storm over there.
Where in Wales is home? Drop me a message @, I have some free software for you EccoPro - New Developments - YouTube
My System SpecsSystem Spec

 Windows 7 Home Premium SP1 Update error 0x800B0100

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 Home Premium Fails to Update error 80073701
Since July 16 failed the Windows update. Every day Windows attempts to install updates every day it fails. Error code is 80073701. is too large, therefore, via this link: I have added a copy of the update history. It's in Dutch: Mislukt...
Windows Updates & Activation
Windows 7 Home Premium 64-bit Update - Error Code 800736B3
Hello :) I'm having a problem installing Windows Updates on my Windows 7 Home Premium 64-bit PC - the update process ends with the error code: 800736B3 (see attached screenshot) I have tried following several suggested courses of action I obtained from several sources, none of which has...
Windows Updates & Activation
Windows 7 home premium x64 update error 800b0100 for sp1
Keep geting error the error code 800b0100 when I try to update window 7 home premium x64 for service pack 1 when i try to update with the file KB976932 have used surt still no sucess. Hope you can help thanks a bunch. Vicky
Windows Updates & Activation
Windows 7 Home Premium 64bit Update Error
I am running Win 7 Home Premium, 64 bit on a Dell laptop studio xps 16. I am having trouble with Windows Updates. "Windows Update cannot currently check for updates, because the service is not running. You may need to restart your computer." No Antivirus installed on the computer. Windows Update...
Windows Updates & Activation
0x800b0100 error (SP1 update) Win 7 Home Basic OEM
Hi. I'm new here. Help me Tom! please. Thanks a lot for this forum. I get the following famous error: 0x800b0100 when trying to install SP1 update. (I tried both Windows Update and Manually) My system: Intel E5700 Win7 Home Basic x64
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:50.
Twitter Facebook Google+