Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Error Code 80070422 - Windows Updates

08 Jan 2015   #1

Windows 7 - 64 bit
Windows Error Code 80070422 - Windows Updates

This is a fairly new system I recently set up. It's a Dell Precision T1700 workstation with the following specs:

OS: Windows 7 Professional 64-bit
Processor: Intel Xeon E3-1271 v3 @ 3.60GHz
Memory: 16GB
Video Card: NVIDIA NVS 510
Hard Drive: 2 x Crucial M550 1TB SSD drives @ Raid 1
Anti-Virus Software Installed: Norton 360 & Malwarebytes Anti-Malware Premium

I got the dreaded Windows Error Code 80070422 and searched online for a solution but was unable to get Windows to update. I'm not certain when this error message began, but I ran into initial problems setting this workstation up when the ASUS PCI-e Wireless Card kept causing the system to go BSOD on me so I did System Restore on this workstation several times before finally giving up and changing the Wireless PCI-e card to Amped Wireless instead and everything seems fine now. But ever since I updated to a different wireless adapter, Windows Update will not function. Please help. Thanks!


My System SpecsSystem Spec
08 Jan 2015   #2

Windows 7 - 64 bit

I tried running the SFC Scan tool from the Command Prompt, but go this message when I hit ENTER:

Windows Resource Protection could not start the repair service.

Attached Thumbnails
Windows Error Code 80070422 - Windows Updates-error-code.png  
My System SpecsSystem Spec
08 Jan 2015   #3

Windows 7 - 64 bit

I ran the System Update Readiness Tool (SURT) tool.

I tried uploading the CBS zip file but I'm having trouble uploading that file. This is what happens after I select the file and click on Upload:
Uploading File(s) - Please Wait

404 - File or directory not found.

The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

Is there an alternative method instead?
My System SpecsSystem Spec

09 Jan 2015   #4

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Please download the Farbar Service Scanner from

Right-click on the saved file and select 'Run as Administrator', and tick all the options, then click on the Scan button - copy and paste the report to your response.

My System SpecsSystem Spec
09 Jan 2015   #5

Windows 7 - 64 bit

Farbar Service Scanner Version: 21-07-2014
Ran by Riklisi (administrator) on 09-01-2015 at 11:10:08
Running from "C:\Users\Riklisi\Downloads"
Microsoft Windows 7 Professional Service Pack 1 (X64)
Boot Mode: Normal

Internet Services:

Connection Status:
Localhost is accessible.
LAN connected.
Google IP is accessible. is accessible. is accessible.

Windows Firewall:

Firewall Disabled Policy:

System Restore:

System Restore Disabled Policy:

Action Center:

Windows Update:

Windows Autoupdate Disabled Policy:

Windows Defender:
WinDefend Service is not running. Checking service configuration:
The start type of WinDefend service is set to Demand. The default start type is Auto.
The ImagePath of WinDefend service is OK.
The ServiceDll of WinDefend service is OK.

Other Services:

File Check:
C:\Windows\System32\nsisvc.dll => File is digitally signed
C:\Windows\System32\drivers\nsiproxy.sys => File is digitally signed
C:\Windows\System32\dhcpcore.dll => File is digitally signed
C:\Windows\System32\drivers\afd.sys => File is digitally signed
C:\Windows\System32\drivers\tdx.sys => File is digitally signed
C:\Windows\System32\Drivers\tcpip.sys => File is digitally signed
C:\Windows\System32\dnsrslvr.dll => File is digitally signed
C:\Windows\System32\mpssvc.dll => File is digitally signed
C:\Windows\System32\bfe.dll => File is digitally signed
C:\Windows\System32\drivers\mpsdrv.sys => File is digitally signed
C:\Windows\System32\SDRSVC.dll => File is digitally signed
C:\Windows\System32\vssvc.exe => File is digitally signed
C:\Windows\System32\wscsvc.dll => File is digitally signed
C:\Windows\System32\wbem\WMIsvc.dll => File is digitally signed
C:\Windows\System32\wuaueng.dll => File is digitally signed
C:\Windows\System32\qmgr.dll => File is digitally signed
C:\Windows\System32\es.dll => File is digitally signed
C:\Windows\System32\cryptsvc.dll => File is digitally signed
C:\Program Files\Windows Defender\MpSvc.dll => File is digitally signed
C:\Windows\System32\ipnathlp.dll => File is digitally signed
C:\Windows\System32\iphlpsvc.dll => File is digitally signed
C:\Windows\System32\svchost.exe => File is digitally signed
C:\Windows\System32\rpcss.dll => File is digitally signed

**** End of log ****
My System SpecsSystem Spec
09 Jan 2015   #6

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Hmm - strange, as the 80070422 error is pretty specific and implies that a service has been disabled. I would have expected it to be one of the services that the FSS checks.

Please try stripping out the oldest CBSPersist cab files from your upload, until the final filesize is below 8MB, and then uploading the resulting file.

Please also run through the Blue Screen of Death (BSOD) Posting Instructions and just upload the resulting file in your reply
My System SpecsSystem Spec
09 Jan 2015   #7

Windows 7 - 64 bit

There were originally 7 cab files, so I stripped it down to the remaining and most recent one.

Attached Thumbnails
Windows Error Code 80070422 - Windows Updates-cab-files.png  
My System SpecsSystem Spec
09 Jan 2015   #8

Windows 7 - 64 bit

This is from the DM Log Collector.

Attached Files
File Type: zip (1.40 MB, 3 views)
My System SpecsSystem Spec
11 Jan 2015   #9

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

The obvious culprit here could be Norton.
The type of errors you are seeing is typical of a race condition, where the OS and the AV compete for resources and eventually one errors out.
Please try uninstalling Norton, and running their removal tool, then installing MSE temporarily (at least) until we get things on an even keel.

Download the Norton Removal Tool from here

Close all other programs, then run the tool. When it's complete, reboot the machine whether it asks for it or not.

After the reboot, open an Elevated Command Prompt, and run the following command


You'll be advised to reboot - do so.

then post another MGADiag report, and test Windows Update again.
My System SpecsSystem Spec
12 Jan 2015   #10

Windows 7 - 64 bit

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-7BKDD-YRRQ3-QPHMF
Windows Product Key Hash: euZTP8gzx5PMgT1+4yAvoxDzbaA=
Windows Product ID: 00371-OEM-9046457-34668
Windows Product ID Type: 3
Windows License Type: OEM System Builder
Windows OS version: 6.1.7601.2.00010100.1.0.048
ID: {4E9B4886-9844-4701-9E8F-EED9AF3CB0E0}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Professional
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.130828-1532
TTS Error:
Validation Diagnostic:
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{4E9B4886-9844-4701-9E8F-EED9AF3CB0E0}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010100.1.0.048</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-QPHMF</PKey><PID>00371-OEM-9046457-34668</PID><PIDType>3</PIDType><SID>S-1-5-21-822106934-892464946-280285899</SID><SYSTEM><Manufacturer>Dell Inc.</Manufacturer><Model>Precision T1700</Model></SYSTEM><BIOS><Manufacturer>Dell Inc.</Manufacturer><Version>A10</Version><SMBIOSVersion major="2" minor="7"/><Date>20140828000000.000000+000</Date></BIOS><HWID>99A83D07018400F4</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>DELL </OEMID><OEMTableID>CBX3 </OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, Professional edition
Description: Windows Operating System - Windows(R) 7, OEM_COA_NSLP channel
Activation ID: e120e868-3df2-464a-95a0-b52fa5ada4bf
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00371-00180-464-534668-02-1033-7601.0000-3252014
Installation ID: 013790783614439870656920769595286820338036748954615021
Processor Certificate URL: SpcService Web Service
Machine Certificate URL: RacService Web Service
Use License URL: UseLicenseService Web Service
Product Key Certificate URL: PkcService Web Service
Partial Product Key: QPHMF
License Status: Licensed
Remaining Windows rearm count: 3
Trusted time: 1/12/2015 10:24:51 AM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 11:24:2014 10:21
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
SSDT PmRef Cpu0Ist
SSDT PmRef Cpu0Ist
SSDT PmRef Cpu0Ist
SSDT PmRef Cpu0Ist
SSDT PmRef Cpu0Ist
My System SpecsSystem Spec

 Windows Error Code 80070422 - Windows Updates

Thread Tools

Similar help and support threads
Thread Forum
windows update error 80070422 downloads but does not register
Dear All Very bizarre: -windows 7 64bit configuration panel says that windows cannot search updates, with error code 80070422 - however the update history shows that updates have been downloaded correctly - when shutting down my machine, updates are each time downloaded anew -...
Windows Updates & Activation
Windows could not check for updates automatically error 80070422
Hello, I have bee trying to solve this problem for a few hours now. When I select "check for updates" in Windows Update it gives me the error mentioned in this thread's title (I've attached the screen shot). I tried to do the sfc scan but my command prompt box (after entering "sfc /scannow")...
Windows Updates & Activation
Windows Update Fails Error Code 80070422
The service is started and automatic, was automatic (Delayed) but changed that - no difference. I did receive 3 updates yesterday but Belarc Advisor states I'm short of 11 critical updates. I believe it as I just installed Office and no updates are being offered. Maybe the servers are down. I...
Windows Updates & Activation
Windows Updates; Windows Activation Error Code 80072EFD
I just completely reformatted my computer after a suspected malware attack. The first thing I tried after reformatting and doing a clean install of Windows 7 Professional 64 bit edition was to run windows update. I received the error code 80072EFD. This is before I installed any software,...
Windows Updates & Activation
Windows Updates fails Error Code :WindowsUpdate_8007065
Hi, My Windows Updates fails Error Code :WindowsUpdate_80070652 Definition Update for Windows Defender - KB915597 (Definition 1.71.471.0) Any thoughts ??
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:27.
Twitter Facebook Google+