Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: .Net 4.0 error 0x00000424 "the specified service does not exist"

07 Mar 2015   #1

Windows 7 Ultimate 32bit
.Net 4.0 error 0x00000424 "the specified service does not exist"

Hi! I'm Having trouble installing Microsoft .Net 4.0. I've tried every solution I found on the internet and still nothing. Also I may have accidentally removed it before from my programs. Is there any way I could fix this without having to lose my files(i.e. reformatting). Thanks a lot!

Attached Thumbnails
.Net 4.0 error 0x00000424 "the specified service does not exist"-dotnet-error-log.png  
My System SpecsSystem Spec
08 Mar 2015   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Please download the Farbar Service Scanner from

Right-click on the saved file and select 'Run as Administrator', and tick all the options, then click on the Scan button - copy and paste the report to your response.

My System SpecsSystem Spec
10 Mar 2015   #3

Windows 7 Ultimate 32bit

Here is the copy. Thank you for taking the time to look into this.


Farbar Service Scanner Version: 17-01-2015
Ran by Valued User (administrator) on 10-03-2015 at 20:06:41
Running from "C:\Users\Valued User\Downloads"
Microsoft Windows 7 Ultimate (X86)
Boot Mode: Normal

Internet Services:

Connection Status:
Localhost is accessible.
LAN connected.
Google IP is accessible. is accessible. is accessible.

Windows Firewall:

Firewall Disabled Policy:

System Restore:

System Restore Policy:

Action Center:

Windows Update:
wuauserv Service is not running. Checking service configuration:
The start type of wuauserv service is OK.
The ImagePath of wuauserv service is OK.
The ServiceDll of wuauserv: "C:\Windows\system32\wuaueng.dll".

Windows Autoupdate Disabled Policy:

Windows Defender:

Other Services:

File Check:
C:\Windows\system32\nsisvc.dll => File is digitally signed
C:\Windows\system32\Drivers\nsiproxy.sys => File is digitally signed
C:\Windows\system32\dhcpcore.dll => File is digitally signed
C:\Windows\system32\Drivers\afd.sys => File is digitally signed
C:\Windows\system32\Drivers\tdx.sys => File is digitally signed
C:\Windows\system32\Drivers\tcpip.sys => File is digitally signed
C:\Windows\system32\dnsrslvr.dll => File is digitally signed
C:\Windows\system32\mpssvc.dll => File is digitally signed
C:\Windows\system32\bfe.dll => File is digitally signed
C:\Windows\system32\Drivers\mpsdrv.sys => File is digitally signed
C:\Windows\system32\SDRSVC.dll => File is digitally signed
C:\Windows\system32\vssvc.exe => File is digitally signed
C:\Windows\system32\wscsvc.dll => File is digitally signed
C:\Windows\system32\wbem\WMIsvc.dll => File is digitally signed
C:\Windows\system32\wuaueng.dll => File is digitally signed
C:\Windows\system32\qmgr.dll => File is digitally signed
C:\Windows\system32\es.dll => File is digitally signed
C:\Windows\system32\cryptsvc.dll => File is digitally signed
C:\Program Files\Windows Defender\MpSvc.dll => File is digitally signed
C:\Windows\system32\ipnathlp.dll => File is digitally signed
C:\Windows\system32\iphlpsvc.dll => File is digitally signed
C:\Windows\system32\svchost.exe => File is digitally signed
C:\Windows\system32\rpcss.dll => File is digitally signed

**** End of log ****
My System SpecsSystem Spec

10 Mar 2015   #4

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

That at least gives me an idea of where to start!
Let's have a closer look at the wuauserv service...

Open an Elevated Command Prompt, and run the following command

REG QUERY HKLM\SYSTEM\CurrentControlSet\Services\wuauserv /S

Post the results...

Here are some instructions to make life easier
1) To open an Elevated Command Prompt Window (the ECP window), click on Start, All Programs, Accessories – then right-click on Command Prompt, and select Run as Administrator. Accept the UAC prompt.
2) To run the commands easier, highlight the block of commands, and right-click on the highlight – select Copy. In the CP Window, click on the black/white icon at top left – select Paste. The commands will run but may not complete the last command, so hit the Enter Key once.
3) To copy the results... click on the Black/White icon in the top left, and select Edit... 'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to paste it into your response.
My System SpecsSystem Spec
11 Mar 2015   #5

Windows 7 Ultimate 32bit

Hi! Here is what you requested. If its not too much to ask, could you tell me what this command do?


PreshutdownTimeout REG_DWORD 0x36ee800
DisplayName REG_SZ Windows Update
ImagePath REG_EXPAND_SZ %systemroot%\system32\svchost.exe -k netsvcs
Description REG_SZ Hiermee wordt de mogelijkheid om updates voor Windo
ws en andere programma's te zoeken, te downloaden en te installeren ingeschakeld
. Als deze service is uitgeschakeld, kunnen gebruikers van deze computer Windows
Update of de functie voor het automatisch bijwerken niet gebruiken, en programm
a's kunnen de API Windows Update Agent (WUA) niet gebruiken.
ObjectName REG_SZ LocalSystem
ErrorControl REG_DWORD 0x1
Start REG_DWORD 0x2
DelayedAutoStart REG_DWORD 0x1
Type REG_DWORD 0x20
DependOnService REG_MULTI_SZ rpcss
ServiceSidType REG_DWORD 0x1
RequiredPrivileges REG_MULTI_SZ SeAuditPrivilege\0SeCreateGlobalPrivil
FailureActions REG_BINARY 80510100000000000000000003000000140000000100

ServiceDll REG_EXPAND_SZ C:\Windows\system32\wuaueng.dll
ServiceMain REG_SZ WUServiceMain
ServiceDllUnloadOnStop REG_DWORD 0x1

Security REG_BINARY 010014807800000084000000140000003000000002001C0001
My System SpecsSystem Spec
11 Mar 2015   #6

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

REG QUERY commands reveal the data in the Windows registry that may be controlling almost any interaction with the OS - the trick to reading the output is to have some idea as to what is 'normal' for any given query.

In this case, this all looks perfectly normal - which means that we have to look elsewhere for the source of the problem.

Possibly, there'll be a clue in the Event logs...

Open Event Viewer
click on the Windows logs entry in the left pane to expand it.
Now click on the Application entry - wait while it loads.
Click on 'File' in the menu bar and select Save...
Save the file as Appevt.evtx
Repeat for the System log
then zip both, and upload them.
My System SpecsSystem Spec

 .Net 4.0 error 0x00000424 "the specified service does not exist"

Thread Tools

Similar help and support threads
Thread Forum
SP1 won't install - "Unknown error" / "Service does not exist"
Hello - I've repeatedly tried and failed to install Service Pack 1. I have run the update readiness tool, and have run chkdsk and sfc. I've tried installing through Windows Update, as well as downloading the standalone installer from Microsoft. The former results in an "unknown error"; the...
Windows Updates & Activation
Try to open a file - error: "file does not exist" when it DOES exist
I stored some files on my D drive which is an external hard drive ... Lately I have had this happen a number of times with totally unrelated files in different places on the D drive. I try to open them (in Excel, but I don't think that matters) and I get an errors saying the file does not...
General Discussion
Error Code is: 0x8007232B. It says "DNS name does not exist."
I saw all of the errors in this sub-forum, and didn't see one that matched mine. So, I apologize if I did miss it. I'm trying to Activate a LEGAL, LEGAL copy of Win7 Enterprise 64Bit! I'm getting an error code when I try to do it online: The Error Code is: 0x8007232B. It says "DNS name does...
Windows Updates & Activation
"The specified service does not exist as an installed service" problem
Hi. I am having really bad problem on my WIN 7 x32. I would appreciate some help. Here's brief description of the problem: The problem started when my mcafee anti virus removed ZEROACCESS trojans from my system. After the scan was completed, my system rebooted and I lost control of all...
General Discussion
Random "Bad Pool Header" and "System Service Exception" BSODs
I have been getting these "Bad Pool Header" and "System Service Exception" BSODs for about a day now (the "Bad Pool Header" one tends to pop up more often then the other btw). I ran a registry cleaner which didn't work and ran memtest this morning and it showed that my memory was fine. The BSODs...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App