Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Updates repeated fail to configure and are reverted 800F0826 80070005

21 Mar 2015   #1

Windows 7 Home Premium x64 SP1
Updates repeated fail to configure and are reverted 800F0826 80070005

I've been offered the same 14 updates over and over. They fail to configure after reboot and are reverted. In the attached picture all show 800F0826 except for the one marked (that one is 80070005). I suspect permissions on the registry or filesystem are to blame.

I removed IE11 from my features a year ago when IE11 updates started to fail. I tried to add IE11 back,. but the updates still failed. I also tried turning IIS off in add remove features, but those got reverted.

  • Cleaned out Catroot2, CBS and WindowsUpdate.log in repair boot shell to get logs as clean and empty as possible. Not sure if that was a bad idea, but I got frustrated.
  • Reattempted update
  • Ran SubInACL* to grant access to the Adminstrators to registry and file system. Those logs are huge (3 GB plus and I don't have tools to parse them, plus I don't know where failure to set permissions are to be expected.
  • I ran latest SURT and got a clean CheckSUR log
  • SFC /scannow found no issues.
Attached is the windows update log
The zip file for the CBS folder is too large to attach so here is the OneDrive link Microsoft services

*SubInACL used

"c:\Program Files (x86)\Windows Resource Kits\Tools\subinacl.exe" /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f
"c:\Program Files (x86)\Windows Resource Kits\Tools\subinacl.exe" /subkeyreg HKEY_CURRENT_USER /grant=administrators=f
"c:\Program Files (x86)\Windows Resource Kits\Tools\subinacl.exe" /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f
"c:\Program Files (x86)\Windows Resource Kits\Tools\subinacl.exe" /subdirectories %SystemDrive% /grant=administrators=f
"c:\Program Files (x86)\Windows Resource Kits\Tools\subinacl.exe" /subkeyreg HKEY_LOCAL_MACHINE /grant=system=f
"c:\Program Files (x86)\Windows Resource Kits\Tools\subinacl.exe" /subkeyreg HKEY_CURRENT_USER /grant=system=f
"c:\Program Files (x86)\Windows Resource Kits\Tools\subinacl.exe" /subkeyreg HKEY_CLASSES_ROOT /grant=system=f
"c:\Program Files (x86)\Windows Resource Kits\Tools\subinacl.exe" /subdirectories %SystemDrive% /grant=system=f

I also tried the similar one posted here!533

Found that people have issues with kb3033929 and multiboot. I think my PC has ability to boot into some HP utilities, but I don't use a boot loader I installed

Ran scandisk, no issues found. Recyclebin was reported corrupted under a user and was cleared out.

Attached Thumbnails
Updates repeated fail to configure and are reverted 800F0826 80070005-capture.png  
Attached Files
File Type: zip (17.5 KB, 2 views)
My System SpecsSystem Spec
23 Mar 2015   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

This appears to be the initial error...
2015-03-21 18:52:59, Info                  CSI    0000006f Begin executing advanced installer phase 38 (0x00000026) index 67 (0x0000000000000043) (sequence 106)
    Old component: [ml:318{159},l:316{158}]"Microsoft-Windows-MediaPlayer-Core, Culture=neutral, Version=6.1.7601.18150, PublicKeyToken=31bf3856ad364e35, ProcessorArchitecture=amd64, versionScope=NonSxS"
    New component: [ml:318{159},l:316{158}]"Microsoft-Windows-MediaPlayer-Core, Culture=neutral, Version=6.1.7601.18741, PublicKeyToken=31bf3856ad364e35, ProcessorArchitecture=amd64, versionScope=NonSxS"
    Install mode: install
    Installer ID: {1b265fd2-721c-4e59-ad55-9d102a5d1d7f}
    Installer name: [12]"SppInstaller"
2015-03-21 18:53:00, Info                  CBS    Progress: UI message updated. Operation type: Update. Stage: 1 out of 1. Percent progress: 71.
2015-03-21 18:53:03, Info                  CSI    00000001@2015/3/21:22:53:03.029 [68]"SPP Installer: SLpUpdateComponentTokens completed with hr=0x80070005"
2015-03-21 18:53:03, Info                  CSI    00000002@2015/3/21:22:53:03.029 [161]"SPP Installer: ProcessInstallOrUninstall (amd64_Microsoft-Windows-MediaPlayer-Core_31bf3856ad364e35_6.1.7601.18741_neutral_c59eec9d) completed with hr=0x80070005"
2015-03-21 18:53:03, Error                 CSI    00000003@2015/3/21:22:53:03.029 (F) CMIADAPTER: Inner Error Message from AI HRESULT = HRESULT_FROM_WIN32(ERROR_ACCESS_DENIED)
[19]"Access is denied.
This is an error type that I am not familiar with - but let's have a look at the file permissions and existence for the following files and registry entries...
Open an Elevated Command Prompt, and run the following commands

ICACLS C:\Windows\winsxs\amd64_Microsoft-Windows-MediaPlayer-Core_31bf3856ad364e35_6.1.7601.18741*.* /T
REG QUERY HKLM\COMPONENTS\DerivedData\Components\amd64_microsoft-windows-mediaplayer-core_31bf3856ad364e35_6.1.7601.18741_none_696c44f065d45f93
REG QUERY HKLM\COMPONENTS\DerivedData\Components\amd64_microsoft-windows-mediaplayer-core_31bf3856ad364e35_6.1.7601.18741_neutral_c59eec9d 
post the results.

Here are some instructions to make life easier :)
1) To open an Elevated Command Prompt Window (the ECP window), click on Start, All Programs, Accessories – then right-click on Command Prompt, and select Run as Administrator. Accept the UAC prompt.
2) To run the commands easier, highlight the block of commands, and right-click on the highlight – select Copy. In the CP Window, click on the black/white icon at top left – select Paste. The commands will run but may not complete the last command, so hit the Enter Key once.
3) To copy the results... click on the Black/White icon in the top left, and select Edit... 'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to paste it into your response.
My System SpecsSystem Spec
23 Mar 2015   #3

Windows 7 Home Premium x64 SP1

Noel, thank you for your help. I have fond memories of Wales - kind people (visited in 1999), all I remember of Welsh was Araf\Slow on the roads.

Other info that may help. I had an intruder on my home network 3/10 on another PC. Did an immediate system restore on that one. Few days later problems on this PC, oldest system image was of course -as luck would have it- 3/11. I did a reset on this PC too and I can easily do another reset the image if need be.

Ran processmon while doing some updates and tracked wusa.exe wuauclt.exe (hope I remembered the exe right) and noticed that it failed to find a registry entry pertaining to daylight savings. This problem started after daylight savings and I looked back and about a year ago I had problems with updates as well. Could daylight savings time be a problem as well?

Also, since I messed with the update folders I started from a clean slate. I restored an image, ran subinacl, tried updates (15 worked and now 16 are stuck - 2 new ones added). I am running SURT now to see if the results are any different than before... will post soon. EDIT. After redoing everything I get the same results in checksur.log

Here are the results. Added spaces by the colons to prevent sad smileys

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>ICACLS C:\Windows\winsxs\amd64_Microsoft-Windows-MediaPlayer
-Core_31bf3856ad364e35_6.1.7601.18741*.* /T
7601.18741_none_696c44f065d45f93 BUILTIN\Administrators:(I)(OI)(IO)(F)


                                 NT AUTHORITY\SYSTEM:(I)(OI)(IO)(F)

                                 NT AUTHORITY\SYSTEM:(I)(CI)(F)

                                 CREATOR OWNER:(I)(OI)(CI)(IO)(F)



                                 NT SERVICE\TrustedInstaller:(I)(CI)(F)

64e35_6.1.7601.18741_none_696c44f065d45f93.manifest NT SERVICE\TrustedInstaller:

                                                    NT AUTHORITY\SYSTEM:(RX)



Successfully processed 2 files; Failed processing 0 files

C:\Windows\system32>REG QUERY HKLM\COMPONENTS\DerivedData\Components\amd64_micro

    identity    REG_BINARY    4D6963726F736F66742D57696E646F77732D4D65646961506C
    S256H    REG_BINARY    4F105BFD2BB2F13B8BAC5D1E28FF3D5B99B0833128EDF4FBE941F
    f!connectionmanager_dmr.xml_89ace5092bfbbd2e    REG_BINARY    63006F006E006E
    f!dmr_48.jpg_4b5d05cc3bc49feb    REG_BINARY    44004D0052005F00340038002E006
    f!dmr_48.png_4b5d02003bc4a5a3    REG_BINARY    44004D0052005F00340038002E007
    f!renderingcontrol.xml    REG_BINARY    520065006E0064006500720069006E006700
    f!dmr_120.png_b64382024b83b1ac    REG_BINARY    44004D0052005F00310032003000
    f!dmr_120.jpg_b64376564b83c364    REG_BINARY    44004D0052005F00310032003000
    f!prod_wmpplayer.ptxml_a9d6b241b589ac24    REG_BINARY    700072006F0064005F0
    f!wmp.mof    REG_BINARY    77006D0070002E006D006F006600
    f!avtransport.xml    REG_BINARY    610076007400720061006E00730070006F0072007
    f!wmpconfig.exe    REG_BINARY    77006D00700063006F006E006600690067002E00650
    f!msdxm.ocx    REG_BINARY    6D007300640078006D002E006F0063007800
    f!dxmasf.dll    REG_BINARY    640078006D006100730066002E0064006C006C00
    f!wmpshare.exe    REG_BINARY    77006D007000730068006100720065002E0065007800
    f!wmplayer.exe    REG_BINARY    77006D0070006C0061007900650072002E0065007800
    f!wmpplayer-ppdlic.xrm-ms    REG_BINARY    57004D00500050006C006100790065007
    f!spwmp.dll    REG_BINARY    7300700077006D0070002E0064006C006C00
    f!wmp.dll    REG_BINARY    77006D0070002E0064006C006C00
    f!wmploc.dll    REG_BINARY    77006D0070006C006F0063002E0044004C004C00

C:\Windows\system32>REG QUERY HKLM\COMPONENTS\DerivedData\Components\amd64_micro
ERROR: The system was unable to find the specified registry key or value.

My System SpecsSystem Spec

05 Apr 2015   #4

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

That looks OK to me - which raises the question of why WU is looking for that last file?
The implication is that there's a problem with the logic involved in naming update files generated during the install.
I don't honestly have any idea how to either find or fix it
My System SpecsSystem Spec

 Updates repeated fail to configure and are reverted 800F0826 80070005

Thread Tools

Similar help and support threads
Thread Forum
Windows Updates won't install, Error Code: 80070005
I am having an issue installing Windows Updates (WU) all have Error Code: 80070005. Nine updates installed after several tries, but there are about 50 updates waiting to be downloaded and installed. I ran the SURT, but it kept spinning...all day, so I canceled it. Tried running it again, but...
Windows Updates & Activation
Windows Updates fail, Errors 8004402F and 800F0826
Sigh, again sand in the engine on another machine. The recent batch of updates fail to install, probably because of one single update. The culprit is probably Update for Windows 7 for x64-based Systems (KB2952664) Installation date: ‎17.‎07.‎2015 08:34 Installation status: Failed Error...
Windows Updates & Activation
Reverted back - Where did those Updates go?
I was working on my Uncle's office PC installing 13 Optional Updates including NetFramework 4.5.2 which had queued for restart. During the interim Malwarebytes found what appeared to be serious infection Rogue.multiple (it said it Quarantined but isn't in that file) which when googled said...
Windows Updates & Activation
windows could not search for new updates, Code 80070005
"an error occurred while checking for new updates for your computer." Most recent check for updates: never updates were installed: never I am trying to update my windows 7 to sp1 but I could not find a solution for error 80070005, help would be greatly appreciated!
Windows Updates & Activation
PC Rolled Back after updates failures, Errors: 800F0826, 800700B7
My PC is a HP Desktop. Win 7 Home Premium SP1. Motherboard: Pegatron IPISB-CU (Carmel2), Chipset:Intel H61. Processor:Intel Core i3-2130. Memory 8GB. Hard Drive 1.5 TB. The PC is two years old and has 484GB of information on it. After downloading the Microsoft updates and my PC re-started, all...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:11.
Twitter Facebook Google+