Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Updates Error Code's 8024000E & C80003FA

29 Apr 2015   #21

Windows 7 64 bit Home Premium

Hi Noel,

I installed the chipset drivers, however they appear to have made no improvements, I still receive the same Windows Update error codes


My System SpecsSystem Spec
29 Apr 2015   #22

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

OK - let's see if the other fix I know of has any effect...

Please run the following commands in an Elevated Command Prompt


once complete, leave the system alone for at least an hour to rebuild the database, then reboot, and run another MGADiag report and post the results.

Note that this may delete your Update History - but all updates will remain installed, and can be viewed in the Installed Updates listing.
My System SpecsSystem Spec
30 Apr 2015   #23

Windows 7 64 bit Home Premium

Hi Noel,

I ran the commands listed above as you requested and left the computer for over an hour, still no joy, same error code 8024000E.

I'll post the MGADiag log below.

My System SpecsSystem Spec

30 Apr 2015   #24

Windows 7 64 bit Home Premium

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-CBQ2X-BF4QT-GC8MP
Windows Product Key Hash: BLUXnngjWpbwzDlNEOZXPEkgS1I=
Windows Product ID: 00359-OEM-8702004-48810
Windows Product ID Type: 3
Windows License Type: OEM System Builder
Windows OS version: 6.1.7601.2.00010300.1.0.003
ID: {EC6B8D13-C2A6-4868-9C35-A5CF0541772E}(3)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: Registered,
Signed By: Microsoft
Product Name: Windows 7 Home Premium
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.140303-2144
TTS Error: 
Validation Diagnostic: 
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{EC6B8D13-C2A6-4868-9C35-A5CF0541772E}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-GC8MP</PKey><PID>00359-OEM-8702004-48810</PID><PIDType>3</PIDType><SID>S-1-5-21-1790793413-3061751505-1455069250</SID><SYSTEM><Manufacturer>System manufacturer</Manufacturer><Model>P5QL PRO</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>1004   </Version><SMBIOSVersion major="2" minor="5"/><Date>20090701000000.000000+000</Date></BIOS><HWID>0B633F07018400F8</HWID><UserLCID>0809</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>GMT Standard Time(GMT+00:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>  

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, HomePremium edition
Description: Windows Operating System - Windows(R) 7, OEM_COA_NSLP channel
Activation ID: 586bc076-c93d-429a-afe5-a69fbc644e88
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00359-00174-020-048810-02-2057-7601.0000-2692013
Installation ID: 014615819315954692080531984300034992389230286831557472
Processor Certificate URL: SpcService Web Service
Machine Certificate URL: RacService Web Service
Use License URL: UseLicenseService Web Service
Product Key Certificate URL: PkcService Web Service
Partial Product Key: GC8MP
License Status: Licensed
Remaining Windows rearm count: 3
Trusted time: 30/04/2015 15:27:24

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: N/A
HealthStatus: 0x0000000000000000
Event Time Stamp: N/A
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes, but no SLIC table
Windows marker version: N/A
OEMID and OEMTableID Consistent: N/A
BIOS Information: 
  ACPI Table Name    OEMID Value    OEMTableID Value
  APIC            A_M_I_        OEMAPIC 
  FACP            A_M_I_        OEMFACP 
  HPET            A_M_I_        OEMHPET 
  MCFG            A_M_I_        OEMMCFG 
  OEMB            A_M_I_        AMI_OEM 
  OSFR            A_M_I_        OEMOSFR
My System SpecsSystem Spec
30 Apr 2015   #25

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Sorry - didn't mean to ask for an MGADiag - it was just a hangover from one of my standard scripts!
(you'll be happy to know that your report was fine though :))

I was pretty certain that that would be the case - let's check something though...

Open an ELevated Command Prompt, and run the following command.

DIR C:\Windows\System32\Catroot2

post the results.

Here are some instructions to make life easier :)
1) To open an Elevated Command Prompt Window (the ECP window), click on Start, All Programs, Accessories – then right-click on Command Prompt, and select Run as Administrator. Accept the UAC prompt.
2) To run the commands easier, highlight the block of commands, and right-click on the highlight – select Copy. In the CP Window, click on the black/white icon at top left – select Paste. The commands will run but may not complete the last command, so hit the Enter Key once.
3) To copy the results... click on the Black/White icon in the top left, and select Edit... 'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to paste it into your response.
My System SpecsSystem Spec
30 Apr 2015   #26

Windows 7 64 bit Home Premium

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>DIR C:\Windows\System32\Catroot2
Volume in drive C has no label.
Volume Serial Number is 4EAD-9B85

Directory of C:\Windows\System32\Catroot2

30/04/2015 11:53 <DIR> .
30/04/2015 11:53 <DIR> ..
30/04/2015 11:53 71,033 dberr.txt
30/04/2015 11:54 8,192 edb.chk
30/04/2015 11:53 65,536 edb.log
30/04/2015 11:53 65,536 edb002D9.log
30/04/2015 11:53 65,536 edb002DA.log
30/04/2015 11:53 65,536 edb002DB.log
30/04/2015 11:53 65,536 edb002DC.log
30/04/2015 11:53 65,536 edb002DD.log
30/04/2015 11:53 65,536 edb002DE.log
30/04/2015 11:53 65,536 edb002DF.log
30/04/2015 11:53 65,536 edb002E0.log
30/04/2015 11:53 65,536 edb002E1.log
30/04/2015 11:53 65,536 edb002E2.log
30/04/2015 11:53 65,536 edb002E3.log
30/04/2015 11:53 65,536 edb002E4.log
30/04/2015 11:53 65,536 edb002E5.log
30/04/2015 11:53 65,536 edb002E6.log
30/04/2015 11:53 65,536 edb002E7.log
30/04/2015 11:53 65,536 edb002E8.log
30/04/2015 11:53 65,536 edb002E9.log
30/04/2015 11:46 65,536 edbres00001.jrs
30/04/2015 11:46 65,536 edbres00002.jrs
30/04/2015 11:46 <DIR> {127D0A1D-4EF2-11D1-8608-00C04FC295EE}
30/04/2015 11:46 <DIR> {F750E6C3-38EE-11D1-85E5-00C04FC295EE}
22 File(s) 1,389,945 bytes
4 Dir(s) 72,456,986,624 bytes free

My System SpecsSystem Spec
01 May 2015   #27

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

That looks normal enough - so let's have a look at the event logs and see if they give us a clue...

Open Event Viewer
click on the Windows logs entry in the left pane to expand it.
Now click on the Application entry - wait while it loads.
Click on 'File' in the menu bar and select Save...
Save the file as Appevt.evtx
Repeat for the System log
then zip both, and upload them.
My System SpecsSystem Spec
03 May 2015   #28

Windows 7 64 bit Home Premium

Hi Noel,

Sorry for the delay getting back to you.

I have run windows update again a couple of times this morning, I'm still getting the same error code.

I have attached the Event Viewer logs as requested. I picked out the logs relating to this mornings update attempts to make life a little easier for you, however, if you do require the full logs I can of course post these for you also.


Attached Files
File Type: zip Event Viewer (17.9 KB, 1 views)
My System SpecsSystem Spec
03 May 2015   #29

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

I really need all of the log data I asked for - there's a lot of stuff that goes on in the background that may give me a clue.

There's only one error there that relates to each update - 8024000e - which we already know about. It's what's happening at boot that I'm more interested in.
My System SpecsSystem Spec
03 May 2015   #30

Windows 7 64 bit Home Premium

No problem, see attached.

My System SpecsSystem Spec

 Windows Updates Error Code's 8024000E & C80003FA

Thread Tools

Similar help and support threads
Thread Forum
Windows Update fails in Update Check. Error code C80003FA.
Hello, I recieve error C80003FA whenever I do a Windows Update run. It doesn't get past the stage of checking for updates. I've tried several fixes including: - Waiting 15 minutes and running Windows Update again. - Letting Windows Update run on its own schedule. - SFC /Scannow -...
Windows Updates & Activation
Cannot Update - Error Code 8024000E
Hi. Unfortunately, I cannot update. I repeatedly get the error code 8024000E. I tried installing the System Update Readiness Tool (SURT) as instructed in the tutorial, but it will not install. I get the message "The following updates were not installed HotFix for Windows (KB947821)". I...
Windows Updates & Activation
Windows Update doesn't update. Error code C80003FA
Hello, First, excuse my english, I'm trying my best. I get error C80003FA whenever I do a Windows Update run. I did the Windows Update Posting instructions. When I did the SURT installation, it didn't finish and I had to reboot the PC. Then it work. I've tried sfc /scannow several times...
Windows Updates & Activation
Unable to run updates, error 8024000E, sfc failing
New XPS13 (originally 8.1) was loaded with Win7x64 enterprise. Sporadic BSOD's when running Outlook/Adobe Acrobat Pro, analyzing memory dumps resulted in "was not able to determine the cause of the problem" issue. Tried running sfc /scannow, gor the "Windows Resource Protection could not perform...
General Discussion
code 8024000E Updates Error
I'm getting this error code when searching for new updates and I also have 3 updates pending to install but I can't install them automatically from updates or manually when I download them from Microsoft separately.. 3 Updates in question are; KB2891804 KB2847077 KB2926765 in attachment is...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:09.
Twitter Facebook Google+