Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Startup Trouble After Windows Update

17 May 2015   #1

Windows 7 Home Premium 64bit
Startup Trouble After Windows Update


I have a Sony Vaio SVE141D11L with Window 7 that had been running beautifully until yesterday, when I restarted the computer to apply the Windows Updates that were installed on 05/15/2015. Upon restarting, Windows failed to load, and StartUp Repair began. StartUp Repair failed, and I tried F8 and Last Known Good Configuration, but it simply goes back to Startup Repair. With Advanced System Recovery Options, I have tried the following:

1. System Restore: Two dates are available, but both fail: "System Restore failed to extract the file (D:\Windows\Help\Windows\en-US\access.h1s) from the restore point. The restore point was damaged or was deleted during the restore."

2. Windows Memory Diagnostic: everything seems ok

3. Command Prompt:
A. Chkdsk: seemed to find no problem, but "failed to transfer logged messages..."
B. sfc, when /scannow is run on D:, "found corrupt files but was unable to fix some." I am unable to access the log from the command prompt.

I, by no means, consider myself knowledgeable about computers, but I am willing (and, hopefully, able) to try fixes, with instructions; therefore, any information or advice you may have will be greatly appreciated.

My System SpecsSystem Spec
17 May 2015   #2

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Hello and welcome DDTN mate run this in safe mode < if necessary include the /f and /r in the command line as per Option2
My System SpecsSystem Spec
17 May 2015   #3

Windows 7 Home Premium 64bit

Thank you for your reply! I am unable to get into safe mode, but I am currently running (with /R, as I had not tried that previousiosly) in the Command Prompt from the Advanced System Recovery Options menu.
My System SpecsSystem Spec

17 May 2015   #4

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Please follow the Windows Update Posting Instructions and post the requested data

If the file is too large (8MB compressed), remove the older CBSPersist cab files until the final file is below the limit - you can always post them separately after zipping them. (the forum doesn't allow the upload of bare CAB files, for a number of reasons)

Please also post the C:\Windows\windowsudpate.log file
My System SpecsSystem Spec
17 May 2015   #5

Windows 7 Home Premium 64bit

Hi Noel,

I would gladly post the requested data, if I could access it. At the moment, I am very limited in what I can access with my computer, as Windows will not load. If there are ways I can access the required information from the Advanced System Recovery Options Command Prompt, please let me know, and I will be happy to do so.
My System SpecsSystem Spec
17 May 2015   #6

Windows 7 Ultimate x64 SP1

Hey, KB3022345 (12/5/2015) causes corruption.

In command prompt (if it runs, since it may not have finished installing) execute:
wusa /uninstall /kb:3022345

then run another sfc /scannow

Hopefully friends here will help you with the nastier problem you are experiencing.
My System SpecsSystem Spec
17 May 2015   #7

Windows 7 Home Premium 64bit

Yes, from what I've read, KB3022345 seems to be the culprit. wusa /uninstall /Kb:3022345 doesn't seem to work, however. It says "'wusa' is not recognized as an internal or external command, operable program or batch file." I believe this is because I have Windows 7 64bit. Do you know if there is a different prompt I should use to remove KB3022345, which is what I think needs to be done at this point? Thank you!
My System SpecsSystem Spec
17 May 2015   #8

Windows 7 Ultimate x64 SP1

I took that command from

I believe it should run in x64 as well. Ask in that thread please, though maybe you would need a service running to use the command.

If you can use F8, did you try safe mode?
My System SpecsSystem Spec
17 May 2015   #9

Windows 7 Ultimate x64 SP1

Found this!

It is for server 2008, which is based on Win7?

Got it ... dism is the way to go.
For the archive ;-)
dism /image:c:\ /remove-package /packagename:Package_for_KB967351~31bf3856ad364e35~amd64~~ /scratchdir:c:\temp
How you can find the part after KB number I have no idea though.

If this works, you could just try to uninstall all updates that caused this problem and see if it helps.

After some digging: Windows/SoftwareDistribution/Download - inside there some folders with "random letters and numbers". Some of them contain the "Package_for_KB##" style files, others have zip files.

package_1_for_kb3022345_bf~31bf3856ad364e35~amd64~~ this is inside folder 4cd9ee4dd600ff2423b7df10c650461c for me, not sure if relevant. upto package_250

Others in the folder:
- package_for_kb3022345_rtm_bf~31bf3856ad364e35~amd64~~
- package_for_kb3022345_rtm~31bf3856ad364e35~amd64~~
- package_for_kb3022345_sp1_bf~31bf3856ad364e35~amd64~~
- package_for_kb3022345_sp1~31bf3856ad364e35~amd64~~

I guess you need one or more of these last 4 I listed.
My System SpecsSystem Spec
17 May 2015   #10

Windows 7 Home Premium 64bit

Thank you for all of this! I will try it!
My System SpecsSystem Spec

 Startup Trouble After Windows Update

Thread Tools

Similar help and support threads
Thread Forum
Trouble with Windows Update Agent 7.6.7600.320
Reinstalling from scratch. Having just started updates, done SP1. Windows Update Agent updates itself to 7.6.7600.256, then to 7.6.7600.320 and trouble starts. Checking for updates brings nothing, no Internet traffic (I know this is supposed to be "normal", but bear with me). System Tray...
Windows Updates & Activation
Trouble with Windows 7 SP1 update error 800B0100
hello, after all search on google and here nothing works. System Update Readiness Tool whas my first option. (this did't work (it say succes install but at instal updates it don't show up and at the system it don't show that sp1 is instalt)) after this i try the sfc command (windows mode),...
Windows Updates & Activation
Windows Update Trouble
My computer doesn't seem to be able to download service pack 1 for windows 7(KB976932). It says there is a file missing(on my computer) All other updates have downloaded sucessfully.
Windows Updates & Activation
Mouse Pointer trouble and startup trouble
I have trouble whenever start windows the start button appears as a white box and nothing appears on the desktop just the (just the background, no icons nor the gadgets) then I tried starting it on safe mode and did system restore however when it does start the mouse pointer keeps on appearing as...
General Discussion
Windows Update trouble.
When I click check for updates it goes on and on. It never takes this long so I restart. Restarting, etc. will not resolve this problem, it remains constant. I think a recent update has led to this although when visiting installed updates... nothings there.
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:29.
Twitter Facebook Google+