Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: KB2952664 error code 8004402F

05 Aug 2015   #1

Windows 7 Ultimate x64
KB2952664 error code 8004402F

Alrighty, so, Windows 10 is upon us, and of course, I run into problems.

So. I've been having a heck of a time getting my update. Initially, my Windows 10 logo would not appear in my system tray.

I verified that my copy of Windows was activated and genuine, although I initially had problems with Windows' genuine verification tool, but I have since resolved that.

Once that was done, I used this to troubleshoot my problem.

I'll admit, I'm no Windows expert, but I was able to pinpoint the problem to being related to KB2952664 based on that troubleshooting guide. The odd thing is that when I run the console commands noted in that link, both return "Package identity".

However, when I try to install KB2952664 in WU, my computer reboots, applies the update, fails, reverts, and boots back up to desktop, only to have that same update available for installation in WU. Rinse and repeat.

Right clicking the failed update for more info gives me a Code 8004402F

The other update, KB3035583, installs just fine.

It gets a bit more weird. When looking for alternative solutions to get that logo to appear in my tray, I came across this tool here on Reddit. [Linky link]

I give it a try, and it verifies that my Win 7 is activated and genuine, and even says that BOTH the previously mentioned KB updates are installed... even though 2952664 has failed every single time...
Well, I proceed with the steps in the bat, and hey! The logo appears in my system tray! Yay!

I pop open the window, reserve my copy of windows 10, and then proceed to use the Windows Media Creation tool to avoid having to wait for my copy of 10.

And then this happens... the creation tool just spits out “Something happened 0x80070002 - 0x20016”
That's it. No other clues as to what happened.

Well, some more Googling reveals that, yes, you guessed it, that error with the creation tool is related to Windows Updates. People have pointed it to corrupted updates etc.

Back to square one it looks like.

I then proceed to basically wipe all my updates and reinstall them, just in case that's the problem. I stop related update services, rename related folders as backups, restart services, and let Windows reinstall all updates.

Reboot time. Fail. Revert. KB2952664 fails to install, yet again.

What gives?

My System SpecsSystem Spec
06 Aug 2015   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

We need to see a full copy of the report produced by the MGADiag tool
(download and save to desktop - )
Once saved, run the tool.
Click on the Continue button, which will produce the report.
To copy the report to your response, click on the Copy button in the tool (ignore any error messages at this point), and then paste (using either r-click/Paste, or Ctrl+V ) into your response.x
- in your own thread, please

Please also state the Version and Edition of Windows quoted on your COA sticker (if you have one) on the case of your machine (or inside the battery compartment), but do NOT quote the Key on the sticker!
How to tell - Hardware

Please follow the Windows Update Posting Instructions and post the requested data

If the file is too large (8MB compressed), remove the older CBSPersist cab files until the final file is below the limit - you can always post them separately after zipping them. (the forum doesn't allow the upload of bare CAB files, for a number of reasons)

Please also post the C:\Windows\windowsudpate.log file
My System SpecsSystem Spec
06 Aug 2015   #3

Windows 7 Ultimate x64

Here we go.

I also should mention that I am no longer in possession of my COA sticker. It was lost due to a shipping error on behalf of FedEx while I was moving several years ago. (Grr, I never liked FedEx... lost a bunch of computer parts as well, and they were only able to reimburse me 100 bucks, even though I included a full cost estimate report.)

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-*****-*****-HYRR2
Windows Product Key Hash: svMwPgD+rq940J0hGYDMl1okMLg=
Windows Product ID: 00426-OEM-8992662-00006
Windows Product ID Type: 2
Windows License Type: OEM SLP
Windows OS version: 6.1.7601.2.00010100.1.0.001
ID: {73B8034B-902E-449B-9631-29877DE33622}(3)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Ultimate
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.150525-0603
TTS Error: 
Validation Diagnostic: 
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 100 Genuine
Microsoft Office Enterprise 2007 - 100 Genuine
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3_E2AD56EA-765-d003_E2AD56EA-766-0_E2AD56EA-134-80004005_E2AD56EA-765-b01a_E2AD56EA-766-0_E2AD56EA-148-80004005_16E0B333-89-80004005_B4D0AA8B-1029-80004005

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{73B8034B-902E-449B-9631-29877DE33622}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010100.1.0.001</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-BBBBB</PKey><PID>00426-OEM-8992662-00006</PID><PIDType>2</PIDType><SID>S-1-5-21-3880479307-3453630397-3837220176</SID><SYSTEM><Manufacturer>System manufacturer</Manufacturer><Model>System Product Name</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>0301   </Version><SMBIOSVersion major="2" minor="5"/><Date>20110222000000.000000+000</Date></BIOS><HWID>368F0C00018400F4</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>FOUNDR</OEMID><OEMTableID>FOUNDRPC</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{90120000-0030-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Enterprise 2007</Name><Ver>12</Ver><Val>64BC76978749586</Val><Hash>GW6PzcEVEDTVKeO5Ym5UUm41dBk=</Hash><Pid>89388-707-0441865-65372</Pid><PidType>14</PidType></Product></Products><Applications><App Id="15" Version="12" Result="100"/><App Id="16" Version="12" Result="100"/><App Id="18" Version="12" Result="100"/><App Id="19" Version="12" Result="100"/><App Id="1A" Version="12" Result="100"/><App Id="1B" Version="12" Result="100"/><App Id="44" Version="12" Result="100"/><App Id="A1" Version="12" Result="100"/><App Id="BA" Version="12" Result="100"/></Applications></Office></Software></GenuineResults>  

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, Ultimate edition
Description: Windows Operating System - Windows(R) 7, OEM_SLP channel
Activation ID: 7cfd4696-69a9-4af7-af36-ff3d12b6b6c8
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00426-00178-926-600006-02-1033-7601.0000-2162015
Installation ID: 018084757415309465667672593064691566299552391862330830
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: HYRR2
License Status: Licensed
Remaining Windows rearm count: 0
Trusted time: 8/6/2015 3:51:03 PM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 8:4:2015 20:07
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->
N/A, hr = 0x8007000d

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information: 
  ACPI Table Name	OEMID Value	OEMTableID Value
  APIC			022211		APIC1738
  FACP			022211		FACP1738
  HPET			022211		OEMHPET 
  MCFG			022211		OEMMCFG 
  OEMB			022211		OEMB1738
  OSFR			022211		OEMOSFR 
  SSDT			DpgPmm		CpuPm

Attached Files
File Type: log WindowsUpdate.log (1.92 MB, 1 views)
My System SpecsSystem Spec

07 Aug 2015   #4

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

The SLIC table here is one I've never seen before -
What is the make and model?
The motherboard appears to be a retail one - there's no manufacturer code in there - but the Key is from an ACER computer.
My System SpecsSystem Spec
07 Aug 2015   #5

Windows 7 Ultimate x64

It's an Asus p6x58-e ws
My System SpecsSystem Spec
07 Aug 2015   #6

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

In that case the install is counterfeit, enabled by a hacker's activation exploit - and doesn't qualify for the upgrade to Windows 10, which is what this update is designed to facilitate.

You need to reformat and reinstall using genuine media and Key
My System SpecsSystem Spec

 KB2952664 error code 8004402F

Thread Tools

Similar help and support threads
Thread Forum
Another case of failure with update KB2952664 - Error Code 8004402F
Hi, I am getting repeated failure of installation of the above package, necessary for the Windows 10 update next month. Every night the package tries to install, and then fails, reverting the changes and restarting a few times in the process. After Windows finally boots, in "Update History" it is...
Windows Updates & Activation
Trouble with windows update kb2952664, error code 8004402F
The update downloads fine, but during the restart it hangs during configuration at 59%. Then fails and restarts back to the latest restore point. is Thank you.
Windows Updates & Activation
Trouble with windows update kb2952664, error code 8004402F
I'm having trouble getting this update installed. It will download fine, but during configuration it fails at 59% and kicks me back to the restore point. Here are the CBS logs. Thank you.
Windows Updates & Activation
[Need Help] Failing to install KB2952664 with code 8004402F
Hello, I really need help with this one!
Windows Updates & Activation
Windows update error code 8004402F with KB2952664
Hi, I've had this update issue going on for few days: Code 8004402F. Log files here. Thank you. Kind regards,
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:29.
Twitter Facebook Google+