Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Having Issues With Getting Windows Update To Work Properly

02 Oct 2015   #1

Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130318-1533)
Having Issues With Getting Windows Update To Work Properly

Hello Seven Forums,

Lately, I have been having issues with getting Windows Update to install all of the updates as usual. There are times where it takes hours just to even get Windows Update to find any available updates. When it starts the download process, it would once again take hours, only to tell me it failed to update several things.

As you can see, I get the error code 80080008. Here is the list of the past few update attempts:

I did a little research on what to do before coming here and I suspect it may have something to do with Windows Modules Installer not being able to be turned on, giving me error 193 0xc1 as I try to start the Windows Modules Installer service:

And using the SFC Scan command gave me this error:

I tried the system update readiness tool, which supposedly installed something called "Hotfix For Windows", but it still didn't solve my problem. I don't know what to do!

My System SpecsSystem Spec
02 Oct 2015   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

The SURT/CheckSUR tool found the following problem - but couldn't fix it...
Checking Component Store
(f)	CSI Payload File Corrupt	0x00000000	CbsCore.dll	amd64_microsoft-windows-servicingstack_31bf3856ad364e35_6.1.7601.17592_none_672ce6c3de2cb17f

You say you have MSE installed - but there appear to be traces of Norton AV installed? When you uninstalled that, did you also run the Norton Removal tool?
If not, then please do so now...

Download the Norton Removal Tool from here

Close all other programs, then run the tool. When it's complete, reboot the machine whether it asks for it or not.

After the reboot, open an Elevated Command Prompt, and run the following command


You'll be advised to reboot - do so.
then post another MGADiag report.
My System SpecsSystem Spec
02 Oct 2015   #3

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Once you've done that....

I've uploaded a file - - to my OneDrive at Noel's OneDrive
Please download and save it.

Right-click on the saved file and select Extract all...
Change the target to C:\ and click on Extract
Close all windows (it would be a good idea to print these instructions!)

Now reboot to the Repair Environment - as soon as the machine restarts, start tapping F8 - this should bring up the Advanced Boot Menu, at the top of which should be the option 'Repair my Computer'
Pick that
You'll have to log in with your username and password.

Pick the option to use a Command Prompt
At the prompt type
DIR C:\dj2aa
hit the enter key - if you get a 'Not Found' error try
DIR D:\dj2aa
DIR E:\dj2aa

The drive letter in use when you find the folder will need to be substituted (for<drive>) into the following command...

XCOPY <drive>:\dj2aa <drive>:\windows\winsxs /y /i /s /v /h

(e.g. XCOPY P:\wfire P:\windows\winsxs /y /i /s /v /h )

run the command (it should take almost no time) and when the prompt returns, type
and hit the Enter key to exit Command Prompt - reboot to Normal Mode Windows.

Now run SFC /SCANNOW in an Elevated Command Prompt
then reboot and upload the new CBS.log file to your reply
My System SpecsSystem Spec

04 Oct 2015   #4

Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130318-1533)

Sorry for the late response, NoelDP!
When I try to zip the CBS folder (after copying it into the desktop), the zipped file became over 8 mb, so I ended up having to attach all the CBSPersist.cap files separately.

Attached Files
File Type: txt MGADiag.txt (4.8 KB, 1 views)
My System SpecsSystem Spec
06 Oct 2015   #5

Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130318-1533)

Update: Although I can now start the Windows Modules Installer and use the sfc /scannow command, Windows Update itself still doesnt work, it just gets stuck at the "Downloading Updates" at 0%.
My System SpecsSystem Spec
06 Oct 2015   #6

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

That's a common problem - and sometimes not the fault of the machine.
You need to leave it a few hours to do the catching-up.

Please post the C:\Windows\windowsupdate log, and then run the CheckSUR tool again, and post the new CheckSUR.log file
My System SpecsSystem Spec

 Having Issues With Getting Windows Update To Work Properly

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 Search Doesn’t Work Properly – Yet Again!
I realise this subject has just about been done to death, e.g. by Lithium on 07-06-2011, but I just have to let off steam somehow - it really doesn't seem to work! Let me explain. I recently acquired an HP Pavilion dv7 laptop computer, with Windows 7 64-bit Home Premium pre-installed. ...
General Discussion
Re-installed windows 7 and windows update will not work properly
Since I re-installed my Windows 7 last week, Windows Update would not work. When I got to the section to check for updates, there is a red shield with an 'x' in it. When i click the button that says "check for updates" I get a message saying "Windows Update cannot check for updates because the...
Windows Updates & Activation
Windows update will not work properly
Hi all, I just posted in another thread the same problem but it was a little old so I decided to start this thread anyway. So, my problem is this. "Windows Update cannot check for updates, because the service is not running. You may need to restart your computer." Background information.
Windows Updates & Activation
Windows 7 Search Does Not Work Properly.
Hello, I seem to be having an annoying problem with my Windows search. (The one at the bottom of the 'Start' menu..) The past few months it doesn't search for files I KNOW are on the computer. (In my documents) It just says 'No items match your search'. My search settings are as follows ...
General Discussion
Does Litestep work properly with Windows 7?
Hi, recently i had tested out Litestep on windows 7 to see if it works properly.. it had loaded up and started the default theme, I then downloaded a skin and tried to apply it via the theme manager ... it had imported the theme however as it was to apply the theme it had crashed.. I reloaded...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:17.
Twitter Facebook Google+