Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Computer says I am not Admin but I am when updating

18 Oct 2015   #1

Windows 7 home premium 64-bit
Computer says I am not Admin but I am when updating

I have a HP laptop (it's my home computer) Running Windows 7 64-bit I am the only user & I am Admin

So I have been trying to upgrade my computer from windows 7 to windows 10. My computer will not allow me to upgrade. I have read many post about it but all the problems other people are having and how they got it fixed doesn't work for me.

When I go to control panel - System & security - windows update
I click on the side where it says -Check for updates- and I get an error message that says

"Windows update cannot currently check for updates, because updates on this computer are
controlled by your system administrator"

I went to control panel - User account and Family Safety - User account
I am administrator & the only account this is my home laptop

Turned User Account Control (UAC) off - Reset my computer & tried still "cannot update, not admin"

The built-in "elevated" Administrator account
I went to Command prompt typed in "net user administrator /active:yes"
Log off, seen the built-in Administrator account log on icon added. Clicked it logged on.
Tried doing update. still same problem

I tried even creating a whole new account, giving it administrator rights, still same thing.

Whats weird is that whenever I am doing something that says "Need admin rights" Such as a
downloading or deleting a file, I am allowed it, I have no problem with it. A message pops up and it says "This action requires Admin" I click it and it allows it to happen.

but for some reason, ANY KIND OF UPDATE not just windows 10, it will not allow me to do it.
My computer hasn't been updated since July that's the last update to gone thru. Auto updates are
turned off too, I tried turning it back on. I cannot. "Need admin permission"

Someone also adv me to look for a update called KB2871389 and uninstall it. I searched my whole
update list and could not find "KB2871389"

I have no idea what else to do. I no longer even care about upgrading to windows 10, now i'm
just annoyed that I cannot access my updates all together. I am running Mcafee idk if that helps

Showing that I am Admin and have unlocked that hidden admin account but still will not work on either account][/URL]


I have not made any major changes to my computer. I used Mcafee & ccleaner. I ran scans on both & still not issue found.

Please help me.

My System SpecsSystem Spec
19 Oct 2015   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Please turn UAC back on

This type of problem is often due to malware creating spurious Policy prohibitions.
Please download and install Malwarebytes Anti-malware (free version) from Malwarebytes | Free Anti-Malware Detection & Removal Software - UNtick 'Enable free trial of MBAM Premium' at the end of the installation - and update it, then run a full scan in your main account, and Quick scans in any other user accounts.

Quarantine everything it finds

Please download the Farbar Service Scanner from

Farbar Service Scanner Download

Right-click on the saved file and select 'Run as Administrator', and tick all the options, then click on the Scan button - copy and paste the report to your response.
My System SpecsSystem Spec
19 Oct 2015   #3

Windows 7 home premium 64-bit

Ok cool, i'll try it out thank you!
My System SpecsSystem Spec

20 Oct 2015   #4

Windows 7 home premium 64-bit

Farbar Service Scanner Version: 26-07-2015
Ran by Tripp (administrator) on 19-10-2015 at 22:03:51
Running from "C:\Users\Tripp\Downloads"
Microsoft Windows 7 Home Premium Service Pack 1 (X64)
Boot Mode: Normal

Internet Services:

Connection Status:
Localhost is accessible.
LAN connected.
Attempt to access Google IP returned error. Google IP is unreachable is accessible.
Attempt to access returned error: is unreachable

Windows Firewall:

Firewall Disabled Policy:

System Restore:

System Restore Policy:

Action Center:

Windows Update:

Windows Autoupdate Disabled Policy:

Windows Defender:
WinDefend Service is not running. Checking service configuration:
The start type of WinDefend service is set to Demand. The default start type is Auto.
The ImagePath of WinDefend service is OK.
The ServiceDll of WinDefend service is OK.

Windows Defender Disabled Policy:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender]

Other Services:

File Check:
C:\Windows\System32\nsisvc.dll => File is digitally signed
C:\Windows\System32\drivers\nsiproxy.sys => File is digitally signed
C:\Windows\System32\dhcpcore.dll => File is digitally signed
C:\Windows\System32\drivers\afd.sys => File is digitally signed
C:\Windows\System32\drivers\tdx.sys => File is digitally signed
C:\Windows\System32\Drivers\tcpip.sys => File is digitally signed
C:\Windows\System32\dnsrslvr.dll => File is digitally signed
C:\Windows\System32\mpssvc.dll => File is digitally signed
C:\Windows\System32\bfe.dll => File is digitally signed
C:\Windows\System32\drivers\mpsdrv.sys => File is digitally signed
C:\Windows\System32\SDRSVC.dll => File is digitally signed
C:\Windows\System32\vssvc.exe => File is digitally signed
C:\Windows\System32\wscsvc.dll => File is digitally signed
C:\Windows\System32\wbem\WMIsvc.dll => File is digitally signed
C:\Windows\System32\wuaueng.dll => File is digitally signed
C:\Windows\System32\qmgr.dll => File is digitally signed
C:\Windows\System32\es.dll => File is digitally signed
C:\Windows\System32\cryptsvc.dll => File is digitally signed
C:\Program Files\Windows Defender\MpSvc.dll => File is digitally signed
C:\Windows\System32\ipnathlp.dll => File is digitally signed
C:\Windows\System32\iphlpsvc.dll => File is digitally signed
C:\Windows\System32\svchost.exe => File is digitally signed
C:\Windows\System32\rpcss.dll => File is digitally signed

**** End of log ****
My System SpecsSystem Spec
20 Oct 2015   #5

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Were you connected to the internet when you ran that?
What AV and Firewall are you running?
My System SpecsSystem Spec
20 Oct 2015   #6

Windows 7 home premium 64-bit

Yes I was connected to the internet when I ran that. I have Mcafee. For some reason all this is shut off. It will not allow me to turn it back on "ran by admin"

Attached Thumbnails
Computer says I am not Admin but I am when updating-untitled.png  
My System SpecsSystem Spec
21 Oct 2015   #7

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

I would uninstall McAfee, then run the MCPR tool -

Download the McAfee removal tool from:

Click Save, and save the file to a folder on your computer.
Navigate to the folder where you saved the file.
right-click on MCPR.exe and select 'Run as Administrator' to run the removal tool.

when complete, reboot.

After the reboot, open an Elevated Command Prompt, and run the following command


You'll be advised to reboot - do so.

Check that Windows Firewall is switched on, and install MSE (at least temporarily) as your AV.

then see how things behave.
My System SpecsSystem Spec

 Computer says I am not Admin but I am when updating

Thread Tools

Similar help and support threads
Thread Forum
Updating computer - not gaming though
My computer is about 7 years old. I made it when the i7 came out and Geforce 8800gtx was the rage. I'm now going off gaming and use it for general use. I have turn tables connected to the PC and use this regularly. I want to upgrade my motherboard and processor. I want go keep my ddr3 muskin...
PC Custom Builds and Overclocking
Updating a vista/win 7 computer that is permenantely offline.
Hi all. My problem is my Nephews computers, He lives in a long term hospital and has no means to connect to the internet. He does however run two computers to help him with his hobby of studio music production. One of the computers, a 4/5 year old toshiba laptop OS vista home premium has not had...
Windows Updates & Activation
no sounds after updating computer
Hi everyone I am new to this forum so if I wrote anything wrong please pardon me because I don't know much about computers. So to begin with like the title says my laptop (DELL Inspiron N4010) have no sounds after I update it. It appear a cross on the sounds icon and when I click on it it will auto...
Sound & Audio
Updating computer to SP1 x64, causes a BSoD on startup
As the title says, I'm trying to update to SP1 (New Windows install as I have a new SSD, due to my old HDD failing). When it restarts to complete installation, it gets to the windows loading screen, and instantly BSoDs every time. As it's flashing and is there for less than a second, I can't...
BSOD Help and Support
Is there a way to tell your computer you ARE Admin?
Didn't know how to title the thread, but is there a way to tell your computer "listen compy, I am the administrator and everything I click should be taken as 'Run as administrator', got it?" Just wondering. Any tweaks out there? ;)

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:39.
Twitter Facebook Google+