Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WU Error 800B0100, Crypto Svc Components not registered

21 Nov 2015   #1

7 Pro x64
WU Error 800B0100, Crypto Svc Components not registered

Looking for some expert help with this issue.

New Win-7 Pro SP1 x64 installation on HP Elitebook, will not install KB3033890, KB3055642, and KB3084135. All other updates (both before and after these 3) install without any problems. All drivers installed, everything else running great.

I've done Chkdsk, SFC /scannow, WSURT, reset SoftwareDistribution folder, removed/recreated catroot2 folder, and run just about every fixit and WU repair tool there is. Disabled W7 firewall, and there is no AV/Malware s/w installed. Even tried a "clean boot" installation. No change.

Edit: I also tried downloading the individual KBxxxxx update files to install manually. These all fail as well.

After running the MS WU diagnostic tool, it reports:

Windows Update Error 0x800B0100 (date time)Not fixed.
Cryptographic service components are not registered Not fixed.

All other components show up as FIXED (green check).

DISM log reports errors, however I've no idea how to read/interpret that.

CBS logs are here (too large to attach to message, so posted on OneDrive).

Would appreciate help getting this seriously annoying issue resolved. I can blow it up and reinstall, but hate to waste another day. Plus I'm really, really curious what would cause this on a new installation.

Thanks in advance for any help.

My System SpecsSystem Spec
22 Nov 2015   #2

7 Pro x64
Update - Installed but now Status=Pending


After posting the problem, I continued researching these forums and found an excellent explanation by tom982 of how to correct the damaged installation files (review CheckSUR.log for unavailable repair files, then manually extract the missing files from the KBxxxxx download files, and place them into the %Windir%\Temp\CheckSur... folders).

After replacing these files, I was able to successfully install all 3 updates using the manually downloaded KBxxxxxx files, and they all appear now in the Windows Update History, however the status for all 3 is now Pending (vs. Successful or Failed).

I have shut down (a few times), restarted, checked for new updates (none found) but the Pending status persists.

Note: the 3 updates all show up as Pending in the Update History view, but do not appear in the Installed Updates view, implying they are somehow partially installed, but clearly not fully.

Any suggestions on how to complete the installation of these 3 troublesome updates?

Thanks in advance.
My System SpecsSystem Spec
27 Nov 2015   #3

Win 7 Home Premium x64/Linux Lite 2.6 x64

try attached

Please check out this KB article:
Error 0x800B0100 when you try to install Windows Updates or Microsoft Updates
How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

Attached Files
File Type: bat Reset_Windows_Update_History.bat (413 Bytes, 27 views)
File Type: bat WU pendings delete.bat (127 Bytes, 13 views)
My System SpecsSystem Spec

29 Nov 2015   #4

7 Pro x64

Thanks for your assistance.

I've been to that web-page, tried all that, no help.

I tried both commands in the .bat file in an elevated CMD prompt, neither file existed.

Also tried, from F8->Repair my computer->Cmd Prompt

"DISM /image:\ /cleanup-image /revertpendingactions" [In repair mode, my C: drive is seen as D: - smiley should be D:]

It reported removal of pending actions to be completed on next boot.

Rebooted, shut down, rebooted again.

Pending files remain in the log (expected), are not visible in "Installed updates" (expected) and are not proposed for install when I check for updates.

Another, unrelated minor update (defender updated) installed with no problem.

Any further suggestions??
My System SpecsSystem Spec
29 Nov 2015   #5

Win 7 Home Premium x64/Linux Lite 2.6 x64

Run SURT again & post



Off to dinner with Father, back in a few hours...

You could Repair Install
My System SpecsSystem Spec
29 Nov 2015   #6

7 Pro x64

Ran SURT again, logs are attached in .zip file.

I can blow it up and start again, but really would like to avoid if possible as lots of other stuff installed, etc. and hate to waste a another day.

I'd like to stick with it for a bit if you don't mind helping; reviewing several of these have resulted in success, so it seems feasible. Otoh, there are a lot of folks that just reinstall. My main issue is, what the hell caused it, like I said, this is a new system, no browsing history, no malware, etc.
My System SpecsSystem Spec
29 Nov 2015   #7

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Have a look at this will tell you how to remove the pending updates

And this one to reregister Crypto services.

Note you should run SFC /scannow 3 times to successfully correct errors.

Hope it helps

My System SpecsSystem Spec
29 Nov 2015   #8

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
very odd

Just looked at those KB's,
the 1st relates to only 32 bit OS, the other 2 only relate to W8,

Your comp should have ignored them.

If after following my instructions in the previous post,
change your Update settings to LET me chose and hide them if they reappear.
Then reset back to automatic, and run the troubleshooter for Windows update.

My System SpecsSystem Spec
29 Nov 2015   #9

Win 7 Home Premium x64/Linux Lite 2.6 x64

Thanks again for your assistance torchwood

Reading 1st post, resetting software distribution folder has been done.

Here's batch files to automate process

After you run re-register Cryptographic components

reboot run it again.

Follow rest of torchwood's instructions

Hope this helps!

Attached Files
File Type: bat Software Distribution Rename.bat (148 Bytes, 34 views)
File Type: bat Re-register Cryptographic Services.bat (344 Bytes, 54 views)
My System SpecsSystem Spec
29 Nov 2015   #10

7 Pro x64


Thanks for your posts.

Replies to 2nd post:

All these KB's apply to x64 Win-7 - I just verified them all. Again. I have downloaded them, and each ran without error (that said, they didn't install right, but not due to getting wrong versions).

Will try this WU config change after making progress in 1st post

Replies to 1st post:

Which step in the above post are you recommending? I've been to that page, and pretty sure I've tried everything there, there are many suggestions in that thread, which suggestion are you recommending?

For re-registering Crypto Services, I've done this I believe, however without restarting between un-registering the services and re-registering. Does this not require an Administrative CMD session?

Is running SFC /scannow 3 times unique to re-registering Crypto setvices, I've not see that technique before.

Thanks again.
My System SpecsSystem Spec

 WU Error 800B0100, Crypto Svc Components not registered

Thread Tools

Similar help and support threads
Thread Forum
Catalog Error - 80040154 - Class not registered
I hope this is the right place to post this. I was just running windows updates for Office 2010 and when the computer rebooted I got an error about a COM class factory (see attached). So I tried to open Component Services and I got a Catalog Error when browsing into COM+ Applications. How might...
Windows Updates & Activation
IE9/Outlook2010: General error. The URL is: ..... Class not registered
Windows 7 Home Premium x64 Most recents updates applied. Office 2010 Outlook Problem: When email is opened and a weblink in the email is clicked Microsoft Outlook 2010 responds: General error.
Browsers & Mail
Library Not Registered Error, The Movies PC Windows 7
Hello, I may need some of your expertise :) I recently bought the PC game The Movies. I tried downloading but "Compatibility Issues" and "Library Not Registered" shows up. So I went "COMPUTER" right clicked the game "OPEN IN NEW WINDOW" than tried to install it by "RUN AS ADMINISTRATOR" on Setup....
Class not registered error
Anyone know how to fix the attached error? This error comes up when I try to go into Computer Management, Services, Component Services but not MSConfig. I have tried System Restore points, but no go.
Performance & Maintenance
mmc.exe class not registered error
Haven't had this error since Win 2000, but after installing a clean copy of Windows 7 on my workstation, and a number of programs, when I try to run mmc from the run prompt I get a Class Not Registered Error, which is causing havoc on all my software installations. Any ideas on how to fix or...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:49.
Twitter Facebook Google+