Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows7 SP1 install fails 0x800B0100

04 Dec 2015   #1

Windows 7 Professional 32bit
Windows7 SP1 install fails 0x800B0100

I have a windows 7 32bit install and when I attempt to install service pack 1 I get the following error message: Trust_E_NoSignature 0x800B0100

I have also run the Windows update diagnostic tool which tells me it can not fix 2 items
the 0x800b0100 error and cryptographic service components are not registered.
see picture attached
When I look in services Cryptographic Services are started.

SFC found no errors

attached is the cbs log file as well

Any help will be greatly appreciated


Attached Images
Windows7 SP1 install fails 0x800B0100-capture.png 
My System SpecsSystem Spec
07 Dec 2015   #2

Windows 7 Professional 32bit

The following is the results of SURT

Checking System Update Readiness.
Binary Version 6.1.7601.22471
Package Version 26.0
2015-12-07 13:18
Checking Windows Servicing Packages
Checking Package Manifests and Catalogs
(f) CBS MUM Corrupt 0x800F0900 servicing\Packages\Package_for_KB2454826~31bf3856ad364e35~x86~~ Line 1:
(f) CBS Catalog Corrupt 0x800B0100 servicing\Packages\
Checking Package Watchlist
Checking Component Watchlist
Checking Packages
(f) CBS Registry Error 0x80070103 Package_for_KB2454826_RTM~31bf3856ad364e35~x86~~ failed to get owner for package.
Checking Component Store
Seconds executed: 351
Found 3 errors
CBS MUM Corrupt Total count: 1
CBS Catalog Corrupt Total count: 1
CBS Registry Error Total count: 1
Unavailable repair files:

Help would be greatly appreciated

Please & Thank you
My System SpecsSystem Spec

 Windows7 SP1 install fails 0x800B0100

Thread Tools

Similar help and support threads
Thread Forum
update fails, SP1 install fails, troubleshooter fails
I'm simply attempting to run update on my Windows 7 machine. Update will not run, downloading and running the SP1 update fails, downloading and running the Update Readiness Tool fails, trying to launch a troubleshooter fails. I ran sfc and have attached the log along with all the error codes...
Windows Updates & Activation
KB2729452 fails with error code 0x800b0100 - Windows 7 Prof. 32 bit
Hi, I'm having trouble installing this update. I've tried System Update Readiness Tool, but with no effect. The CheckSur log says: ================================= Checking System Update Readiness. Binary Version 6.1.7601.21645 Package Version 17.0
Windows Updates & Activation
Unable To install SP1, error 0x800b0100
I am getting the "TRUST_E_NOSIGNATURE 0x800b0100" error when trying to install SP1. System is Windows 7 64bit ENU. Issue is same as: but with different files. I am needing this fairly...
Windows Updates & Activation
Windows & SP1 Fails Error 0x800b0100
I am having trouble with the Windows 7 Premium 64 Bit SP 1 installing. I have tried all kinds of the Microsoft repairs and they are not getting it done. I did the tool fixer, the updater Repair, lots of other stuff but was careful not to get in the Registry even though I have been ther...
Windows Updates & Activation
Two issues: Upgrade install of W7x86 fails and W7x64 fails to clean install
Clean installing W7 x86 is no problem. But 1) upgrading Vista x86 to W7 x86 fails and automatically rolls back to Vista, and 2) attempt to clean install W7 x64 results in BSOD when rebooting to finalize the process. Any suggestion would be appreciated.
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:45.
Twitter Facebook