Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't install language pack, runtime terminates when attempting update

05 Dec 2015   #1

Windows 7 Ultimate x64
Can't install language pack, runtime terminates when attempting update

I have a computer (an Apple iMac with Windows 7 Ultimate x64) that had automatic updates disabled, with no manual updates made, for 2 whole years. I decided to try and update it, which there were around 150 updates to install, and naturally there were some hiccups and failures not that I understand it all. But, one the things I wanted to install most, was the Japanese language pack (just for fun and for other reasons). But I get this error: "This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information."

So I read that CheckSUR is a useful way to get a lock on these update problems, I downloaded the latest version from The first and last CheckSURs I did are attached (CheckSUR2.log was the last one). The first CheckSUR I ran seemed to fix something:
(fix) CSI Catalog Missing CSI File Replaced File: From: C:\Windows\servicing\Packages\
The KB number on there, KB2732059, is part of two other errors that didn't go away in the last CheckSUR I did. I also ran an sfc /scannow which gave perfect results.

Apparently you're supposed to run these commands to run CheckSUR stuff:
DISM.exe /Online /Cleanup-image /Scanhealth
DISM.exe /Online /Cleanup-image /Restorehealth
The first one worked fine but the second one gave this error message:
"Error: 87
The restorehealth option is not recognized in this context. For more information, refer to the help."

I guess the first command is for finding problems and the second command is for fixing found problems?
I tried using these instructions:
to get some of the files (update files like Windows6.1-KB2563227-x64.msu) and place them in C:\Windows\Temp\CheckSUR\Packages. I guess the /Restorehealth is supposed to grab those and do something with them? The /Scanhealth command did nothing with those files.

So I'm stuck with three pairs of error messages about packages that aren't installed, and it's weird, because two of those are different versions of the same package, and I don't even know if the version I downloaded is EITHER of those two versions, a couple of missing manifests which I have no idea what to do about those, and a couple of missing copies of SOS.dll files. I notice my system already has like ten or so of those installed, but the SOS files are apparently a debugging extension for .NET programs. As a programmer that might be interested in that, should I be worried?

The bottom line is that I can't get the language pack installed. My system seems stable enough...unless I was worried about security holes left by missing updates or something along those lines.

Attached Files
File Type: log CheckSUR.log (3.8 KB, 0 views)
File Type: log CheckSUR2.log (3.3 KB, 0 views)
My System SpecsSystem Spec
05 Dec 2015   #2

Windows 7 Ultimate x64

Hey, what the ****! I actually got it to work this time! I lied, I wasn't using the latest version of CheckSUR, but then I was and I figured I could use Restorehealth to make it work maybe cause it was newer and that's how I need to fix the files (which didn't work, so...)...but just now the CheckSUR (Scanhealth, though) that I figured I'd try and run anyway using the new version...came out clean! I'm really surprised, I didn't think it could just fix itself like that. Sorry for posting. I guess it really needs to be STRESSED that the CheckSUR version is very important for all the scanning/fixing procedures.
My System SpecsSystem Spec

 Can't install language pack, runtime terminates when attempting update

Thread Tools

Similar help and support threads
Thread Forum
Microsoft Update - Language Pack Error 800706BE
Hi I've been trying to install Japanese for the last few hour when Update gave me this code 800706BE and whenever I'd install it, it give a message box saying Microsoft Visual C++ Runtime Library This application has requested the Runtime to terminate it in an unsual way. Please contact the...
Windows Updates & Activation
How do I install Korean language pack
I am using Windows 7 Home Premium SP1 64bit on my Dell. I will be living in Korea and studying Korean, so I need the Korean language pack. I've done a little googling, found a tutorial and followed it. Only to discover that particular file only works on Windows 7 Home Premium RTM. Please...
General Discussion
I Can t install the downloaded language pack
Hi all I am running windows 7 sp1 and downloaded the german language service pack. but i can t install it and at the end of the progress it fails, with out mentioning the reason or giving an eror. I didn t do that from windows update because i wanted to have the installation file for the...
General Discussion
Install W7 Language pack .mlc
Hi all I need to install the W7 Icelandic Language pack on some computers. The file is LIP_is-IS-64bit.mlc. which I've got from MS. These files used used to have the prefix MUI -- I'm a bit flummexd on how to install a language pack manually with the *.MLC suffix -- can't see much help...
General Discussion
How to install a language pack?
I have got an unofficial danish language-pack for ver 7127, but I don't know how to install it? It is a file called No setup or anything, so how do I do it?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:00.
Twitter Facebook Google+