Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Clean OS install on OCZ Trion SSD Win update stalls while "Checking"

18 Dec 2015   #1

Windows 7 Professional 64-bit SP1
Clean OS install on OCZ Trion SSD Win update stalls while "Checking"

Windows 7 Professional 64-bit SP1
AMD FX-8120 Zambezi 32nm Technology
MSI 760GM-P23(FX) (MS-7641) (CPU1)
10.0GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)
Graphics Card(s)
1024MB ATI AMD Radeon HD 6670 (MSI)
Hard Drives
223GB OCZ-TRION100 ATA Device (SSD)
AntivirusEdit Value

Performed a fresh Windows install on a new OCZ-TRION100 (SSD). Now, when I go to run Windows Update it stalls on "Checking for updates" message and never progresses. Most processes that use windows update are also failing. I have tried several different methods to fix this with no success yet.

I've cleared the SSD and freshly reinstalled Windows 7 more times than I can count in the pursuit of a fix. Each time I reinstall, I delete all partitions using the windows install disk interface. I run BIOS once the SSD is entirely un-allocated space. I attempted most of these fixes in either IDE or AHCI mode with varying results. Yet ultimately the problem persists.

I would post the Windows update error code, but since it never proceeds past "checking" and never stops "checking" unless stopped through CMD; I receive no legitimate error code or error message.

Attempt A:
Ran SFC Scan successfully. It came up with no errors. Rebooted, yet problem persists...

Attempt B:
Ran the Update Readiness Tool. The first time I ran it; it installed the hotfix successfully. Rebooted, and it says "configuring updates" for a split second then appears to fail. It continues the reboot and does the same thing when starting.

After the reboot, the problem persists. Attempted running it again and now it stalls on "Searching for updates on this computer..." and never progresses further. Also, pressing the 'close' button does not respond.

Method C:
I have tried going into CMD as Administrator, and typing
stop wuauserv
stop bits
stop crypsvc
ren %systemroot%\System32\catroot2 catroot2.old
ren %systemroot%\softwaredistribution softwaredistribution.old
start wuauserv
start bits
start crypsvc

On some attempts of this method; I was successful in renaming the files, but it fixed nothing. The majority of times I try this method it says "access denied" when renaming SoftwareDistribution, even though I had ran as admin and stopped crypsvc. The problem persists in in any event.

Method D:
Updated the drivers for my CPU through the AMD Catalyst 15.7.1(which also successfully installs .netFX 4.5). Drivers update successfully. Rebooted, and problem persists...

Method E:
On a few attempts I had enabled AHCI mode in BIOS before installing Windows. The install is successful, though the problem persists....

While in AHCI mode, if I update my AMD drivers; upon reboot I get a black screen with a "No bootable device found" message after post. I then have to go into BIOS, revert settings to default so that I can boot from the windows disk. Once booted, in the interface in which you choose which drive to install on, it says it's unable to install onto the SSD. I have the option to format it, but that does nothing. I must delete the drive, so that I can do a new clean OS install.

Subsequently tried to install AMD SATA AHCI drivers before restarting to avoid this. This uses the AMD Catalyst to install. Install stops at %99, never ticked over to completed state. Forcing me to restart and get he result mentioned above.

Method F:
Ran MC Fix It 50123, it created a system restore point, then appeared to have completed successfully. Didn't see any indication that it had actually done anything. Rebooted, yet problem persists...

Method G:
Ran Windows Update troubleshooter successfully. Says all of the problems are fixed. Rebooted, yet problem persists...

Method H:
Ran Checkdisk successfully, Problem persists...

Method I:
Ran as Admin all of the .bat methods in this post
Windows Update - Reset
They all run successfully. Rebooted, yet problem persists... If anyone has any ideas, I am willing to do a new clean install, start from scratch following the steps that you lay out. I figure one or all of these fixes could work, maybe I'm just doing it wrong or in the wrong order. But from my research it seems like there is some problem associated with my SATA configuration.

I don't know what to do. I see other forum post with similar problems but have yet to find a fix to my problem. And infuriatingly, have seen others running an SSD on Win 7 on the with the same processor. This should not be as impossible as it has proven to be so far. There has to be a solution. Thank you in advance to anyone who attempts help me.

Attached Thumbnails
Clean OS install on OCZ Trion SSD Win update stalls while "Checking"-untitled.jpg   Clean OS install on OCZ Trion SSD Win update stalls while "Checking"-untitled2.jpg  
Attached Files
File Type: log WindowsUpdate.log (48.4 KB, 0 views)
My System SpecsSystem Spec
18 Dec 2015   #2

Windows 7 Professional 64-bit SP1

Used auto patcher to download the bulk of my initial updates. now with most of them downloaded, windows update does not take days to search. Thanks to these forums for finding that solution.
My System SpecsSystem Spec

 Clean OS install on OCZ Trion SSD Win update stalls while "Checking"

Thread Tools

Similar help and support threads
Thread Forum
Windows Update - reset but still stuck on "Checking for Updates"
Hi I've been trying to set up a few second hand laptops for a charity youth club. One went without a hitch, one won't update Windows at all. It's running Windows 7 SP1, I've tried various fixes but nothing seems to be working. I've followed the instructions on the post. Attached is my CBS...
Windows Updates & Activation
Windows Update Hangs at "Checking for Updates"
Good morning, I just registered, so I'm not entirely sure how this forum runs. I'm assuming you can see my computer information in my user profile, but please let me know if you need me to post it here again. When I run Windows Update, it hangs permanently on "Checking for Updates." No error...
Windows Updates & Activation
Windows Update stuck forever in "Checking for updates"
Hi, I installed win 7 recently and activated it. The updates dont seem to install automatically. I have tried many FixIt and manuall installation past 3 to 4 days, but nothing worked. The maximum I could go was getting "193 updates available" alert. Even if I select one update out of those it...
Windows Updates & Activation
Windows Update on 7 stalls while "Installing Updates (2/3)" on AMD64 m
Hello All, This is yet another issue with Windows Update on 7; I recently (a couple of weeks or so ago) upgraded my father's computer to Windows 7 and he loves it. However, whenever either of us try and use Windows Update, it sits there for hours and hours on "Installing Updates 1 of 2." ...
Windows Updates & Activation
fresh install, stalls right after "windows starting" screen. mbr?
Hello, all. I'm flirting with my sanity and have decided to finally reach out for help. I have been googling and searching these forums for the better part of 26 hours, yielding little in the way of results. I'm also browsing/typing with my cell phone; you might imagine nerve endings.... ...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:27.
Twitter Facebook