Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Updates Failed to install - Error Code 80071A91

25 Jan 2016   #1

Windows 7 Home Premium SP1 64bit
Updates Failed to install - Error Code 80071A91

I have been unable to install Windows updates since mid-December, and now have some 11 outstanding.

My machine is a 5 year old Acer Aspire M3910 64 bit Intel Core i3 CPU 540 @3.07GHz with 8GB RAM running Windows 7 Home Premium SP1.

I have downloaded and installed the System Update Readiness Tool from the Microsoft site. However the file generated from the CBS file produced by running this tool is some 12 MB in size and falls foul of the 8MB limit imposed by the forum, and I cannot attach it. How do I get over this?

I have also run SFC /SCANNOW, but it identified no issues.

Help to resolve this updating error would be very much appreciated.

Thank you in advance!

My System SpecsSystem Spec
25 Jan 2016   #2

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Drainbolt,
Can you run Chkdsk,
Then try updates again.

My System SpecsSystem Spec
26 Jan 2016   #3

Windows 7 Home Premium SP1 64bit

Hi Roy

Thank you for your response. I have run chkdsk and tried updating again. The updates failed again, and I do not think chkdsk threw up any issues. I attach the chkdsk log.

I am conscious that I have not been able to submit the file because it exceeded the size limitation spacifed by the forum, but I am not sure as to the best way to proceed with getting this posted. Can anyone help?

Attached Files
File Type: txt chkdsk 26-1-16 .txt (4.6 KB, 2 views)
My System SpecsSystem Spec

26 Jan 2016   #4

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Drainbolt,

Can you just copy and compress(zip) the last 2 days entries.

Your error code is a bit of a strange one, never mind we'll press on regardless.

Can you also run the MXdiag tool anr post those results as well, from the link below
Windows Genuine and Activation Issue Posting Instructions


Attached Images
Updates Failed to install - Error Code 80071A91-wuodd.png 
My System SpecsSystem Spec
28 Jan 2016   #5

Windows 7 Home Premium SP1 64bit

Hi Roy,

I have been having trouble breaking my CBS file into bite-sized pieces - it's 197MB in size, hence the delay. Because of the size I have copied portions only. These portions miss out a lot but I hope they are nevertheless of some use. The 4 zips are attached. I will write again on your other suggestions shortly. Thanks for your time.
My System SpecsSystem Spec
28 Jan 2016   #6

Windows 7 Home Premium SP1 64bit

Hi again Roy,

The link you posted - Windows Genuine and Activation Issue Posting Instructions - led me to the MGADiag tool, not the Mxdiag tool you referred to, so I ran that. Its report is posted below.

Perhaps you can clarify what is an Mxdiag tool?

Also, I would feel happier about running the DOS commands you ask me to execute if you could let me know what their purpose is. Would you mind telling me what they are to do, please?

Diagnostic Report (1.9.0027.0):
 Windows Validation Data-->
 Validation Code: 0
 Cached Online Validation Code: 0x0
 Windows Product Key: *****-*****-WJ2H8-R6B6D-7QJB7
 Windows Product Key Hash: ckKNc+BBPDWmo1LUlOkraNjlQ34=
 Windows Product ID: 00359-OEM-8992687-00006
 Windows Product ID Type: 2
 Windows License Type: OEM SLP
 Windows OS version: 6.1.7601.2.00010300.1.0.003
 ID: {4639B1E8-CA66-48E3-A81B-F7CAED32B5AA}(3)
 Is Admin: Yes
 TestCab: 0x0
 LegitcheckControl ActiveX: N/A, hr = 0x80070002
 Signed By: N/A, hr = 0x80070002
 Product Name: Windows 7 Home Premium
 Architecture: 0x00000009
 Build lab: 7601.win7sp1_gdr.151019-1254
 TTS Error: 
 Validation Diagnostic: 
 Resolution Status: N/A
 Vista WgaER Data-->
 ThreatID(s): N/A, hr = 0x80070002
 Version: N/A, hr = 0x80070002
 Windows XP Notifications Data-->
 Cached Result: N/A, hr = 0x80070002
 File Exists: No
 Version: N/A, hr = 0x80070002
 WgaTray.exe Signed By: N/A, hr = 0x80070002
 WgaLogon.dll Signed By: N/A, hr = 0x80070002
 OGA Notifications Data-->
 Cached Result: N/A, hr = 0x80070002
 Version: N/A, hr = 0x80070002
 OGAExec.exe Signed By: N/A, hr = 0x80070002
 OGAAddin.dll Signed By: N/A, hr = 0x80070002
 OGA Data-->
 Office Status: 100 Genuine
 Microsoft Word 2002 - 100 Genuine
 OGA Version: N/A, 0x80070002
 Signed By: N/A, hr = 0x80070002
 Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3_E2AD56EA-765-d003_E2AD56EA-766-0_E2AD56EA-134-80004005_E2AD56EA-765-b01a_E2AD56EA-766-0_E2AD56EA-148-80004005_16E0B333-89-80004005_B4D0AA8B-1029-80004005
 Browser Data-->
 Proxy settings: N/A
 User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
 Default Browser: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
 Download signed ActiveX controls: Prompt
 Download unsigned ActiveX controls: Disabled
 Run ActiveX controls and plug-ins: Allowed
 Initialize and script ActiveX controls not marked as safe: Disabled
 Allow scripting of Internet Explorer Webbrowser control: Disabled
 Active scripting: Allowed
 Script ActiveX controls marked as safe for scripting: Allowed
 File Scan Data-->
 Other data-->
 Office Details: <GenuineResults><MachineData><UGUID>{4639B1E8-CA66-48E3-A81B-F7CAED32B5AA}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-7QJB7</PKey><PID>00359-OEM-8992687-00006</PID><PIDType>2</PIDType><SID>S-1-5-21-2610313068-3905579158-1376742768</SID><SYSTEM><Manufacturer>Acer</Manufacturer><Model>Aspire M3910</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>P01-A3        </Version><SMBIOSVersion major="2" minor="6"/><Date>20100517000000.000000+000</Date></BIOS><HWID>43DB3A07018400FC</HWID><UserLCID>0809</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>GMT Standard Time(GMT+00:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>ACRSYS</OEMID><OEMTableID>ACRPRDCT</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{911B0409-6000-11D3-8CFE-0050048383C9}"><LegitResult>100</LegitResult><Name>Microsoft Word 2002</Name><Ver>10</Ver><Val>A445E3CEEDD9BF2</Val><Hash>OURolXztc+pHZKDC6mf94VI7e6c=</Hash><Pid>54189-OEM-1693002-08569</Pid><PidType>4</PidType></Product></Products><Applications><App Id="1B" Version="10" Result="100"/></Applications></Office></Software></GenuineResults>  
 Spsys.log Content: 0x80070002
 Licensing Data-->
 Software licensing service version: 6.1.7601.17514
 Name: Windows(R) 7, HomePremium edition
 Description: Windows Operating System - Windows(R) 7, OEM_SLP channel
 Activation ID: d2c04e90-c3dd-4260-b0f3-f845f5d27d64
 Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
 Extended PID: 00359-00178-926-800006-02-1033-7600.0000-1322010
 Installation ID: 000802580412178553128364960321335161626152750543165923
 Processor Certificate URL: SpcService Web Service
 Machine Certificate URL: RacService Web Service
 Use License URL: UseLicenseService Web Service
 Product Key Certificate URL: PkcService Web Service
 Partial Product Key: 7QJB7
 License Status: Licensed
 Remaining Windows rearm count: 3
 Trusted time: 28/01/2016 11:41:24
 Windows Activation Technologies-->
 HrOffline: 0x00000000
 HrOnline: 0x00000000
 HealthStatus: 0x0000000000000000
 Event Time Stamp: 12:6:2015 18:06
 ActiveX: Registered, Version: 7.1.7600.16395
 Admin Service: Registered, Version: 7.1.7600.16395
 HealthStatus Bitmask Output:
 HWID Data-->
 OEM Activation 1.0 Data-->
 OEM Activation 2.0 Data-->
 BIOS valid for OA 2.0: yes
 Windows marker version: 0x20001
 OEMID and OEMTableID Consistent: yes
 BIOS Information: 
   ACPI Table Name    OEMID Value    OEMTableID Value
   APIC            ACRSYS        APIC1139
   FACP            ACRSYS        FACP1139
   HPET            ACRSYS        OEMHPET 
   MCFG            ACRSYS        OEMMCFG 
   SLIC            ACRSYS        ACRPRDCT
   OEMB            ACRSYS        OEMB1139
   ASF!            LEGEND        I865PASF
   GSCI            ACRSYS        GMCHSCI 
   AWMI            ACRSYS        OEMB1139
   SSDT            DpgPmm        CpuPm

My System SpecsSystem Spec
28 Jan 2016   #7

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Drainbolt,

Those commands reset the the update store.

Now that i've looked at your logs,
The problem may relate to in iffy MS update, there were lots of people having probs with it on its release.

Before you try the command mode changes,
can you confirm if you have KB2984972 Installed, if you do please remove it via
control panel >> programs/features >> installed updates.

Then try updating a gain.

My System SpecsSystem Spec
29 Jan 2016   #8

Windows 7 Home Premium SP1 64bit

Hi Torchwood,

I do have KB2984972 installed. It was installed on 6 Dec 2015 along with a whole lot more - I did a repair install shortly before that (system restore would not work) and was in the process of getting the machine up-to-date with Windows updates. I have tried several times to uninstall that update but each time I am told that it could not be uninstalled. "An erreor has occurred. Not all of the updates were successfully uninstalled." Updates were however installing OK on 7 and 9 Dec in bulk, and one or two have come through after that, but I have had this rump of 11 updates that will not install for several weeks now.

For what its worth I tried to install the outstanding updates again after trying to uninstall KB 2984972, but again they failed.

I will try the command mode changes once you confirm I now should.
My System SpecsSystem Spec
29 Jan 2016   #9

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Drainbolt,
Can you try this first, Method 1 from this tutorial
Windows Update - Uninstall from Console Level

My System SpecsSystem Spec
30 Jan 2016   #10

Windows 7 Home Premium SP1 64bit

Hi Torchwood
I have tried Method 1 from the tutorial you referred to, but without success. The standalone installer came up with the following message: "Transaction support within the specified resource manager is not started or was shut down due to an error."

Shall I now try to reset the update store in line with the method given in your post #4? By the way, can you point me to the tutorial from which those steps are copied, please?
My System SpecsSystem Spec

 Updates Failed to install - Error Code 80071A91

Thread Tools

Similar help and support threads
Thread Forum
Failed to install updates: Error Code 80070308
Good Afternoon, I am also having problems installing updates with the error code 80070308. I have spent this afternoon reading the other posts and following the Windows Update Posting Instructions thread so hopefully I've gathered has much info as I can. I downloaded and ran the System...
Windows Updates & Activation
Failed to install 9 updates: Error Code 80070308
Hi, Since 10/07/2014 I am having serious problems with 9 updates in Windows Update. I just took a look at some other topics in this forum section and it seems I am not the only one having these problems. I've already tried several things i've found on the internet, but nothing really...
Windows Updates & Activation
Unable to install Windows Updates, error code 80071A91
I keep getting this error, and following Error message when you try to install a Windows update, a hotfix, or a service pack after you perform System Restore in Windows Vista: "0x80071A91" and removing files manually did not resolve the problem. Diagnostic Report (1.9.0027.0):...
Windows Updates & Activation
windows failed updates with Error Codes 80070643, 80071A91 and 78f
I am having this issue for months now, and i keep getting these errors. I have searched and tried different methods from other forums but only one worked for me, unfortunately just once ( flushing of the software distribution) but after the next day, when my pc was having its automatic update, it...
Windows Updates & Activation
windows updates, error code 80071a91, 80070643, 9c47
keep on getting this error anytime i want to update on windows 7. have a log here
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:07.
Twitter Facebook