Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: GWX.exe windows 10 upgrade won't open

11 Feb 2016   #1

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
GWX.exe windows 10 upgrade won't open

I know many people have been fighting the windows 10 upgrade battle to the death and I have as well. I'm now ready to take the plunge into windows 10 on my laptop since I've used 10 on a new computer and like it. I had been using the registry tweak here to block the upgrade listed here:

Upgrade to Windows 10 Update - Enable or Disable in Windows 7 or 8.1 - Windows 10 Forums

I re-enabled it using the same link but when I click on the task bar upgrade icon or even try and run the standalone file from Microsoft's website, nothing happens. I read somewhere that once GWX.exe is running, it needs a day or 2 to do compatibility testing? Is that true? If not, how can I get GWX to run and do the upgrade?


My System SpecsSystem Spec
11 Feb 2016   #2

64-bit Windows 10 Pro

Hello Drew, :)

If you like, you might also check using the tutorial below to make sure that you have the GWX icon enabled.

Get Windows 10 Icon - Remove from Taskbar in Windows 7 and 8.1 - Windows 10 Forums

You can also always manually upgrade to Windows 10 for the free offer if needed.

Windows 10 - Upgrade Installation - Windows 10 Forums
My System SpecsSystem Spec
11 Feb 2016   #3

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

The icon is enabled, it's just that when I click on it, nothing happens.
My System SpecsSystem Spec

11 Feb 2016   #4

64-bit Windows 10 Pro

If you don't have the "Upgrade to Windows 10" update available in Windows 10, then you could manually upgrade instead.
My System SpecsSystem Spec

 GWX.exe windows 10 upgrade won't open

Thread Tools

Similar help and support threads
Thread Forum
how to open a TRX file to upgrade router firmware
Hello, i am trying to update a Router model Asus RT N10 firmware but the files have a TRX ending , anybody know how to open these? Thank you
Network & Sharing
Windows upgrade starter to premium current key not valid for upgrade
I have got myself into a bit of a mess. I installed my version of windows starter on my mom's PC which was previously running vista. To see if it improved the performance or if the laptop itself was rubbish. It did so I purchased an upgrade to windows home premium. When I enter the upgrade key...
Installation & Setup
Can't Open Zip Files After Windows 7 Upgrade
I just updated my pc from Vista to Windows 7 Ultimate x64. I also use IZARC to zip and unzip files and everything worked fine until the windows 7 installation. The only software downloaded after the Windows 7 update was AVG 2013 and Dual Monitor Tools, which allows me to custom fit wallpapers...
XP to windows 7 upgrade incompatibility issues caught by Upgrade Advis
I am trying to prep a computer to give to a friend. Last night, I reformatted it using the recovery discs that came with it. It is a Tosh Satellite A105. Today, I have been finding and installing updates to the system, trying to prepare it for an upgrade to win7, which is no easy task since I...
Installation & Setup
Can't get a program to open after upgrade from 7 Home to 7 Pro
Hello, I used Windows Anytime to upgrade from Windows 7 Home to Windows 7 Professional and now a program that ran fine under Home will not even open. I've tried reinstalling, using compatibility mode for XP, but nothing seems to work. When I double click on the .exe, it seems to try to open, but...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:45.
Twitter Facebook Google+