Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Application Log Full of ESENT 474 Errors

21 Mar 2016   #1

Windows 7 Pro N x64
Application Log Full of ESENT 474 Errors

I don't believe this issue is limited to just Windows Update, and believe it is more of a core system issue. But there seems to be more information on resolving this as a Windows Update problem rather than any of the other affected components. At this point, the next thing I need to do is get Windows Updates installed, so let's start with that...

This all started Wednesday-Thursday last week. I have a Windows 7 workstation that started having problems with Internet Explorer. It would crash displaying an error with mshtml.dll and restart several times before settling down. Also, it could not install Windows Updates and would give an error. Also the user could not search inside of Outlook 2007.
While troubleshooting, I discovered the Application log was full of ESENT 474 errors messages. They all said essentially "the database page read from file <see below> failed verification" The affected files were:

C:\Users\(username)\AppData\Local\Microsoft\Windows\WebCache\WebCacheV01.dat C:\Windows\system32\CatRoot2\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\catdb

Research showed these files were all safe to delete because Windows would rebuild them. So I did. Had to reboot and/or go into Safe Mode to get rid of some of them, but they were deleted. After reboot the errors immediately returned. These are all Jet databases, so I tried to see if there was a way to maybe reinstall that engine, but didn't find much on it. I made sure all the drivers and firmware were up to date just in case that was the issue but it didn't solve anything. Also ran sfc and it came back clean.

At this point, I figured Windows was corrupted, so I tried to do a repair install. It got past the first reboot, got to the last step were it migrates settings and data and got stuck there. It stayed that way overnight. So, with little other choice, I powered the PC off and rebooted it. It got stuck in a repair loop and wouldn't continue.

This machine came preinstalled with Windows on a SATA drive. I had been meaning to install an SSD drive in it, so I took the opportunity now to do so. After this machine was purchased, I had created an image in FOG and successfully deployed it to 20+ workstations. So, I decided to deploy this image onto the SSD. No issues. After the images is loaded the PC gets joined to the domain automagically. As soon as I logged in and tried to get Updates... same issue. I thought maybe something from the Domain and WSUS server might be the culprit so I renamed the PC, removed it from the domain and told it to fetch Updates from Microsoft. I started that at around noon on Friday. When we left for the day it was still checking for updates. Came in this morning... still checking for updates. Rebooted - all the files are corrupted again. No antivirus has been deployed on the workstation yet, so that shouldn't do it.

I've also ran the Dell hardware diagnostics from the boot menu and they say everything is fine.

Current Windows Update error is C80003FA.

I Installed and ran SURT. It installed the one KB patch and said it installed successfully. Checked the log and it was pretty sparse. Ran it again and this time got the Windows Update error as above

I followed the procedure to generate and attach the CBS.log but when I zipped the entire directory the ZIP file was over 110MB. This zip file attached only contains the most recent sfc results. There are a couple large persist files in there. I can upload if required.

I'm totally stumped. Any ideas?

My System SpecsSystem Spec

 Application Log Full of ESENT 474 Errors

Thread Tools

Similar help and support threads
Thread Forum
Esent errors bringing down OS to a crawl, hard power off to use PC
Pics show the error. Claims a hardware error. Has trouble writing to these log files. How can I delete these log files, maybe they are damaged? How to fix, the PC when this happens is useless until you turn off the power, nothing responds. This has happened many times over months of use.
General Discussion
Multiple application errors
I tried to start up my computer this morning and almost all of my application kept giving me a stopped working unexpectedly error message things from steam to outlook to explorer and what not. any ideas on what I could do to find out what is wrong?
Hardware & Devices
full screen application minimizes and windows loses focus
Hi!, i have a very annoying problem that's driving me crazy for 3 days now, windows tends to lose focus every exactly 1 min and some sort of a program blinks in the task bar and disappear, it happens all the time right after i log in to windows, i can't play any game as it minimizes it every...
General Discussion
Full Screen Application Focus Issue
I'm having a problem with any game that I try to play full screen. When I start the game I have to click rapidly in order for the game to keep focus and not minimize. I have trouble being able to get the games to stay focused. DirectX is up to date. NVIDIA drivers are up to date. All windows...
Application Errors
Stupid Windows 7 had to bug itself on the right moment... 1. Can't install Google Chrome. It says installation failed 2. It says that Windows Live Movie Maker is installed... IT'S NOT. It's annoying me. It says that Movie Maker is installed but the entire "Windows Live" folder isn't even in...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:48.
Twitter Facebook Google+