Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 updater fails to finish and causes svchost to use 50% CPU

27 Jun 2016   #1

Windows 7 Home Premium 64 bit
Windows 7 updater fails to finish and causes svchost to use 50% CPU

With my Windows 7 Home Premium 64 bit version the svchost is stuck on nearly 50% CPU use, and updates is stuck too so that it stays on searching for windows updates but never completes to show any available.If I remove that Windows 10 upgrade offer will it then get fixed ?

My System SpecsSystem Spec

 Windows 7 updater fails to finish and causes svchost to use 50% CPU

Thread Tools

Similar help and support threads
Thread Forum
cannot run surt, updater fails code 80092026
good evening, I have tried following your instructions to post information regarding the error, but surt fails to execute the hotfix. For the past month, I kept getting disconnected from my wifi, it would stop working, and could not run the troubleshooter either. I ran windows updater, it did...
Windows Updates & Activation
Windows update fails after reformat, multiple errors, svchost cpu
Hello, I'm having a hard time fixing Windows update after doing two clean installs. Having tried a lot of things after the first clean install, I did another one, this time installing sp1 offline, followed by the June 2015 windows agent update, also done offline. This didn't work either. At that...
Windows Updates & Activation
win 7 updater downloads but fails to install updates error 80073712
This is my first time here so I hope I'm doing this right. Diagnostic Report (1.9.0027.0): ----------------------------------------- Windows Validation Data--> Validation Code: 0 Cached Online Validation Code: N/A, hr = 0xc004f012 Windows Product Key: *****-*****-QCPVQ-KHRB8-RMV82...
Windows Updates & Activation
Windows 7 Pro 64-bit installation fails to finish on home build ASUS
Hi, I have recently purchased Windows 7 Pro 64-bit to install on another partition on my Vertex III SSD drive. For work related reason I have mainly used Windows XP Pro (32-bit), so this also is the case for my home desktop PC. I recently purchaed Windows 7 and have attempted to install it on...
Installation & Setup
Sysprep Fails After Deployment With: Windows could not finish configur
Getting the message after Sysprep stating "Sysprep Fails After Deployment With: Windows could not finish configuring the system...." This is a new out-of-box Lenovo T530 laptop, it came pre-loaded with Windows 7 Pro. I pulled laptop from box and inserted our Windows 7 Pro SP 1 disk and...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:48.
Twitter Facebook Google+