Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Update is not functioning (Code 8007370A)

06 Jul 2016   #1

Windows 7 Home Premium 64-bit SP1
Windows Update is not functioning (Code 8007370A)


I'm new around here, yet I hope you're willing to help me anyway.

Last year I ran into a problem which involved a group of Windows updates not installing correctly; some of them would fail outright and others would at first glance install correctly but reappear (in the list of scheduled updates) upon restarting the PC. Over time the trouble with Windows Update intensified; my list of installed updates started showing up as empty, updates started failing more often when trying to install them, and nowadays I can no longer even search for updates. I've tried numerous methods to resolve the issues, but none of them have worked thus far.

I'll just go by the instructions posted here one by one:

1. I've tried several times to use the System Update Readiness Tool and although each time it seemed to have installed itself correctly, it has yet to fix the problems I'm having with Windows Update.

2. I am unable to normally use sfc /scannow, whenever I try do it in normal mode I get the message that the requested application can not be started. I have managed to use sfc /scannow while running in safe mode, it started up as it is supposed, it found corrupt files, it fixed several of said files, but unfortunately Windows Update remains broken.

(2. Addendum: A short time ago, while searching on the internet for a solution, I came across several posts which suggested that an inability to use sfc /scannow (while running in normal mode) could indicate a failing harddrive. While I didn't seem to be suffering most of the problems commonly found with bad/failing HDDs, I decided to run chkdsk anyway. I scheduled a full disk check ("chkdsk /f /r C:") and although it took quite a while, it found no bad sectors and it did not fix Windows Update.)

3. The error code I'm getting when trying to search for updates is "Code 8007370A - An unknown error occurred in Windows Update".

4. I'll will post my log collection below.

Just as a heads-up: first off, I'm Dutch so any error messages I wrote down will be translated from Dutch to English; secondly, as it is getting quite late here I might not be able to read your message in time.

I really hope you're able to help me out here and I thank you for any time you invest in assisting me.
My System SpecsSystem Spec
06 Jul 2016   #2

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Alotty,
Have you installed another language pack or removed/replaced the original one.
could you copy/post your windowsUpdate log. (only need 1 days entries)

My System SpecsSystem Spec
06 Jul 2016   #3

Windows 7 Home Premium 64-bit SP1

The entries of a full day wouldn't fit in a single post, so I copied the entries to a new notepad file and attached it to this post. I am not entirely certain about the language packs, I think its always been in Dutch, although I may have installed a Korean language pack in order to support certain programs; is there any way for me to check this?

Attached Files
File Type: txt WindowsUpdate6thofJuly.txt (62.4 KB, 2 views)
My System SpecsSystem Spec

06 Jul 2016   #4

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Alotty,
Only 1 language allowed on Home premium, and Korean language packs are run on different paramaters, which is why this error is possibly being generated; from you CBS log
Error CSI 00000009 (F) Unable to parse identity version: [l:28{14}]"6.17601.17514"

In theory MS does not offer language packs to home premium users.
How did you install it Vistalator??
You can check here, (see screenshot)

can you also run this tool, copy/paste the results

Uninstall the Korean language pack/program, it might just correct itself.


Attached Thumbnails
Windows Update is not functioning (Code 8007370A)-lanpack.png  
My System SpecsSystem Spec
06 Jul 2016   #5

Windows 7 Home Premium 64-bit SP1

Hey Roy,

It seems I might have uninstalled the Korean language pack some time ago. I did find something else among the Language packs however.

I think the "Verenigde Staten (Internationaal)" (meaning United States - International) might belong there, though I'm uncertain as to the Japanese language option. Should I try to remove it via the same menu?

Attached Thumbnails
Windows Update is not functioning (Code 8007370A)-2016-07-07_00h41_46.png  
My System SpecsSystem Spec
07 Jul 2016   #6

Windows 7 Home Premium 64-bit SP1

I have removed the Japanese language option, it does not seem to have had an effect.

Edit: I forgot about the MGADiag file.

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-X3W7K-TV7MH-D2MXB
Windows Product Key Hash: taOAD7nAKA9K4vMiVXNJKQyn1zw=
Windows Product ID: 00359-OEM-8703505-98989
Windows Product ID Type: 3
Windows License Type: OEM System Builder
Windows OS version: 6.1.7601.2.00010300.1.0.003
ID: {F20BCC1F-F494-48BC-ADFE-2E92F727BB90}(3)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Home Premium
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.150427-0707
TTS Error:
Validation Diagnostic:
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: N/A, hr=0x80070002
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{F20BCC1F-F494-48BC-ADFE-2E92F727BB90}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-D2MXB</PKey><PID>00359-OEM-8703505-98989</PID><PIDType>3</PIDType><SID>S-1-5-21-559876803-3838849406-1593329752</SID><SYSTEM><Manufacturer>System manufacturer</Manufacturer><Model>System Product Name</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>1503</Version><SMBIOSVersion major="2" minor="6"/><Date>20110310000000.000000+000</Date></BIOS><HWID>639B3007018400FE</HWID><UserLCID>0413</UserLCID><SystemLCID>0413</SystemLCID><TimeZone>West-Europa (standaardtijd)(GMT+01:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>

Spsys.log Content: 0x80070002

Licensing Data-->
Versie van Software Licensing-service: 6.1.7601.17514

Naam: Windows(R) 7, HomePremium edition
Beschrijving: Windows Operating System - Windows(R) 7, OEM_COA_NSLP channel
Activerings-id: 586bc076-c93d-429a-afe5-a69fbc644e88
Uitgebreide PID: 00359-00174-035-098989-02-1043-7601.0000-2432011
URL van processorcertificaat: SpcService Web Service
URL van computercertificaat: RacService Web Service
URL van gebruikte licentie: UseLicenseService Web Service
URL van productcodecertificaat: PkcService Web Service
Gedeeltelijke productcode: D2MXB
Licentiestatus: licentie
Resterend aantal nieuwe Windows-activeringen: 3
Vertrouwde tijd: 7-7-2016 18:43:34

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 7:3:2016 12:44
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes, but no SLIC table
Windows marker version: N/A
OEMID and OEMTableID Consistent: N/A
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value

My System SpecsSystem Spec
07 Jul 2016   #7

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Alotty,
Right there gone, NO others i hope
can you run SURT again

Then run sfc /scannow.

Post the results of the surt (checksur) report its in the CBS folder, hopefully now it has repaired these errors

hearts_31bf3856ad364e35_6.1.7600.1*385_none_4ffeefd67d89d45b.manifest amd64_microsoft-windows-s..l-inboxgames- * = WRONG SYMBOL should be a 6

There are 8 of these
winsxs\manifests\amd64_microsoft-windows-printing-spooler-core_31bf3856ad364e35_6.1.7601.17 14_none_3471a890d8284f57.manifest

My System SpecsSystem Spec
07 Jul 2016   #8

Windows 7 Home Premium 64-bit SP1

You mean running sfc /scannow in safe mode, right?
My System SpecsSystem Spec
07 Jul 2016   #9

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Both in normal mode please.

My System SpecsSystem Spec
07 Jul 2016   #10

Windows 7 Home Premium 64-bit SP1

As I stated in the original post, I am unable to run sfc in normal mode. Whenever I try to run it it tells me that the requested application can not be started.
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Windows Update no longer functioning properly
It fails to install updates and claims that updates have never been installed. When I search for updates, I receive 80080005. I attempted to install the latest SURT, twice, but it failed both times. I was considering going onto SFC scan step, but since SURT failed, I thought I should ask first.
Windows Updates & Activation
Windows update error 8007370a
I have to reinstall Windows to fix some errors. I tried to do a repair installation but I took a message something like "Installation cannot continue. Please try to update windows and then try again". I thought to reinstall only SP1 but just after installation starts I take the message...
Windows Updates & Activation
How do I know windows update is functioning well?
In the wake of IE red alert from Homeland Security, I am concerned whether or not my Windows updating system is intact. The last important update installed was on April 8th. Everyday I check for update and all I get without fail is one optional definition update for MSE. (I wonder why MSE is...
Windows Updates & Activation
Windows Update and BITS not functioning
Hi! So today I bought a new Wireless Xbox360 controller receiver for my Gaming PC, and I couldn't install the drivers! I got code 37 or something but it turns out it's because my Windows Update was not working. When promted to 'check for updates' It would give the message: "Windows Update...
Windows Updates & Activation
update error 8007370A (can't run SFC Scan )
I haven't been able to update windows (7x64) for past week ,i have CheckSUR log but i can't run SFC Scan I've followed all of the online Microsoft recommendations here; Unable to install updates in Windows Vista, Windows 7, Windows Server 2008 and Windows Server 2008 R2 Method 3 is where i hit...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:50.
Twitter Facebook