Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Any and all .MSU's fail to install with 0x8000FFFF unexpected error

08 Aug 2016   #21

Win-7-Pro64bit 7-H-Prem-64bit

No problem
You can save a lot of time installing these 2 updates without connecting to the internet after getting to the desktop,
After installing them connect to the internet and activate windows
Then search for updates and the rest should show up shortly

Manually install KB3020369 first

Win-7 64 bit

Manually install KB3172605 2nd

Win-7 64 bit,

My System SpecsSystem Spec
14 Aug 2016   #22

Windows 7 Professional x64

No problems installing via that .ISO, no issues installing windows updates, activation went through no problem.

System's running like a charm now, performance is all-around improved, 7.8 experience index. Feels good.

Now then, as I've gone through and re-installed programs/drivers and migrated a few files over from my main HDD, I've noticed a few things that may have contributed to the original issue (though it's unclear).
Turns out the driver disc that came with my motherboard includes Intel Rapid Storage Technology!
I don't recall choosing to install it back when I built this rig, and I have still yet to find any evidence of it being installed when searching for it, but there is the possibility of it being present at one point, and then corrupted to the point of near invisibility. (Didn't show up in DriverView)

Also, while adding Full Control permissions to my HDD for my new User Account, a decent handful of files spat out I/O errors. I ran a disk check and found 104 files in bad sectors. Most of them were in subdirectories of my User folder, but most of the check was running while I was asleep so I wasn't able to see if any system files were affected.
Unfortunately the Chkdsk log seems to get cut off, so I suppose it will remain a mystery.

Oh well, even if we fixed my weird problem, I should've gotten a boot SSD a while ago, and it's also been a great excuse to update all of my programs to their latest versions while leaving behind what I don't use anymore.

Thanks for your help, guys.
My System SpecsSystem Spec

 Any and all .MSU's fail to install with 0x8000FFFF unexpected error

Thread Tools

Similar help and support threads
Thread Forum
error code 0x8000FFFF
Hello I just had something that looked like a BSOD with a code attached it happened so fast I did not have a chance to write it down. It happened just after windows 7 update then it was gone. How do I find it and upload it to the forum.
General Discussion
Windows RE with 0x8000ffff error
I have an Acer Aspire 5736Z computer with Windows 7 (I am not sure whether 64 or 32 bits). When after an automatic upgrade the computer showed too long the same screen the user switched it off by pressing the on/off button for a few seconds. Since then when the computer starts up it reports an...
Backup and Restore
.NET updates fail to install with error 800B0100 and 80070308
KB 2518869, KB2572077, KB2633873, KB2656356 repeatedly fail to install with errors 800B0100 and 80070308. These four security patches have repeatedly failed to install since 23 March. Win 7 SP1 was installed on 21 March 2012 I have run the Microsoft FixIt and the System Update Readiness Tool...
Windows Updates & Activation
Language Packs fail to install, error 103, error 5.
I've no idea what's causing this. I tried installing the language packs last night and woke up the next morning to the error codes mentioned above. Please help.
Windows Updates & Activation
File system error (-1073741792), Sys restore error (0x8000ffff)
Hi all, Huge problem regarding permissions on my (massively unstable) PC. I try to run ANYTHING including .dlls with admin permissions and i get a nice little "ding", and error message regarding the relevent .dll and File system error -1073741792, including one just before I get to the logon...
General Discussion
USB3 install fail: feature transfer error: 2
I tried installing my NEC USB3 3.0 Host Controller File after a repair/upgrade install. Now, I get the above error during the driver setup. I downloaded the driver directly from Asus. Any ideas on the workaround? Thanks

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App