Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: KB2670838-x64 won't install. Error code: 0x80240022

05 Nov 2016   #1

Windows 7 Home Premium 64bit
KB2670838-x64 won't install. Error code: 0x80240022

I've been stuck on this problem for weeks now. I can't seem to get this windows 7 sp1 platform update to install no matter what I try. I have tried /scannow, system update readiness tool, I even had I microsoft rep take over my computer for 2 hours and they couldn't get it to install. Error code in windowsupdate.log shows 0x80240022, error code in update history shows code 800736b3. It would make my year if someone were to help me get this working.

My System SpecsSystem Spec
05 Nov 2016   #2

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Viper,
The 2nd error code tends to imply registery corruption, not good.
can you post the logs from checksur, (CBSlog).

My System SpecsSystem Spec
06 Nov 2016   #3

Windows 7 Home Premium 64bit

Thanks torchwood for replying. I reran checksur and posted the log. From what I can tell all seems normal there. Thanks again.

Checking System Update Readiness.
Binary Version 6.1.7601.22471
Package Version 26.0
2016-11-06 05:22

Checking Windows Servicing Packages

Checking Package Manifests and Catalogs

Checking Package Watchlist

Checking Component Watchlist

Checking Packages

Checking Component Store

Seconds executed: 560
No errors detected

EDIT: sorry forgot to post cbs.log as well. Here we go.
My System SpecsSystem Spec

06 Nov 2016   #4

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Viper,
Its not the registry, its your windows updates, all the following + at least >>30 more<< are corrupt/incomplete within the SXS folder.
KB2656356~KB3126593 KB3140410 KB3126587 KB3121212 KB3101746 KB3088195 KB3060716 KB3045999 KB2872339 KB2859537 KB3031432 KB3004375 KB3035131

I would suggest a clean re-install with this amount of corruption.
Copy your files personal files to external media first.
note what is your install media?

My System SpecsSystem Spec
06 Nov 2016   #5

Windows 7 Home Premium 64bit

originally the install media was a CD, but i'm almost positive I've lost that at this point though I do have the product key for window 7 home premium still.

Is there no way to individually uninstall and reinstall the corrupt updates even if it is severely time consuming?
My System SpecsSystem Spec
06 Nov 2016   #6

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Viper,
run this tool, copy/paste the output.

If its OK then ill get you a link for a W7 SP1.

My System SpecsSystem Spec
06 Nov 2016   #7

Windows 7 Home Premium 64bit

Here is a result of the diagnostic.

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-JX9MH-PV4Y4-GRQJH
Windows Product Key Hash: 8k8RKYSJutFRZYc27vg27kHy/34=
Windows Product ID: 00359-OEM-8802064-48783
Windows Product ID Type: 3
Windows License Type: OEM System Builder
Windows OS version: 6.1.7601.2.00010300.1.0.003
ID: {450B7D05-B16B-456E-B2EC-0A6DF7DE9087}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Home Premium
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.120830-0333
TTS Error:
Validation Diagnostic:
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{450B7D05-B16B-456E-B2EC-0A6DF7DE9087}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-GRQJH</PKey><PID>00359-OEM-8802064-48783</PID><PIDType>3</PIDType><SID>S-1-5-21-2931781167-2605702340-3431157870</SID><SYSTEM><Manufacturer>Gigabyte Technology Co., Ltd.</Manufacturer><Model>X58A-UD3R</Model></SYSTEM><BIOS><Manufacturer>Award Software International, Inc.</Manufacturer><Version>FB</Version><SMBIOSVersion major="2" minor="4"/><Date>20100824000000.000000+000</Date></BIOS><HWID>34623F07018400FE</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Mountain Standard Time(GMT-07:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, HomePremium edition
Description: Windows Operating System - Windows(R) 7, OEM_COA_NSLP channel
Activation ID: 9f83d90f-a151-4665-ae69-30b3f63ec659
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00359-00176-020-648783-02-1033-7600.0000-0282011
Installation ID: 019646480006811256592891674452608493246130438191605096
Processor Certificate URL: SpcService Web Service
Machine Certificate URL: RacService Web Service
Use License URL: UseLicenseService Web Service
Product Key Certificate URL: PkcService Web Service
Partial Product Key: GRQJH
License Status: Licensed
Remaining Windows rearm count: 1
Trusted time: 11/6/2016 11:12:22 AM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 10:6:2016 15:14
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes, but no SLIC table
Windows marker version: N/A
OEMID and OEMTableID Consistent: N/A
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value

Thanks again for all your help Roy.
My System SpecsSystem Spec
06 Nov 2016   #8

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Viper,
follow link W7 Home premium SP1 64bit English,
ITS only valid for 24hrs from 18.50 UK time.

My System SpecsSystem Spec
06 Nov 2016   #9

Windows 7 Home Premium 64bit

Just to be safe I obviously can't just mount it with daemon tools and go since it will be reinstalling the OS, so I need to burn then mount in the physical disk drive right?
My System SpecsSystem Spec
07 Nov 2016   #10

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

either burn it or create a bootable usb

My System SpecsSystem Spec

 KB2670838-x64 won't install. Error code: 0x80240022

Thread Tools

Similar help and support threads
Thread Forum
Error configuring of Windows Update (KB2670838)
Hello sevenforums community, I want to install the platform update (KB2670838) on my system. I downloaded the update manually from microsoft website and installed it; so far so good. Now i need to reboot my system to "activate" the update. Windows comes to a point where it says "error when...
Windows Updates & Activation
Internet Explorer 11 Error 9C59, KB2670838 Error 80004005
So I've been trying to fix this for more than 20 hours now and I haven't made the slightest bit of progress. The issue: The update "Internet Explorer 11 for Windows 7 x64" fails with error code 9C59. Currently installed is IE9. The update "KB2670838" fails with code 80004005. Google reveals...
Windows Updates & Activation
Can't upgrade IE, KB2670838 returns error 800B0100
Hi there I recently discovered that this old laptop is still running IE9, insted of the much newer IE11. Thus I set out to figure out why the update hadn't happened automatically. But after spending most of my day trying most of the solutions Google could find me, I haven't reached my goal....
Windows Updates & Activation
IE10 and now IE11 fail to install. Prereq KB2670838 not applicable
Hi, I have tried via the Microsoft forums and got no where. Initially I tried to install IE10, but it keeps failing as pre-requisite KB2670838 will not install. On trying the standalone installer it comes back saying 'This update is not applicable to your computer'. Now the same is...
Windows Updates & Activation
Windows6.1-KB2670838-x64 Error 0x80070422
Hello All, I'm using the win7 home basic x64 SP1 and when i try to install the DX upgrade Windows6.1-KB2670838-x64 i receive the error 0x80070422. Can anyone help me solve this issue ... i have no idea why it's not accepting the upgrade. Really Thanks
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:49.
Twitter Facebook Google+