Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Ultimate: Cannot install service pack 1 Error: 0x8007370b

23 Apr 2017   #1
Figgy27

Windows 7 Ultimate x64
 
 
Windows 7 Ultimate: Cannot install service pack 1 Error: 0x8007370b

**Note to Moderator: I apologize for the double post, I did not realize my thread would not be available to post twice in without approval from a mod and did not include the required log report within the previous thread posting, please approve this thread instead as it has everything necessary to be reviewed.**

Greetings, new to sevenforums. Here is a short paragraph detailing why I am trying to solve this issue. Recently bought Steel Division Normandy 1944 off of steam. It won't launch. Figured out that the game requires Windows Service Pack 1 to run, and I don't have it. I cannot for the life of me get it on my computer. Looking through the windows update history, I can see my comp has been trying to automatically update to this service pack since at least 2014, and it fails every night (that the computer is on, at least). I have been able to run previous titles from this company (Wargame European Escalation) just fine.

The game also requires Microsoft Visual C++ 2015, and it was recommended to me to delete any previous versions of visual C++ and re download only the 2015 version of it again. I have gotten rid of all the previous Microsoft Visual C++ programs (dating back to 2008 at the earliest I believe) but have yet to put Visual C++ 2015 back on my comp, as I have been too busy being stuck on this confounding Windows Service Pack 1 update issue.

I have tried using Windows Update to acquire service pack 1, to no avail. It gets stuck midway through the process and presents with this error code about 30 minutes in:

"Installation was not successful

The name of an attribute in an identity is not within legal range.

Code: ERROR_SXS_INVALID_IDENTITY_ATTRIBUTE_NAME(0x8007370b)"


I have also tried manually downloading the service pack from microsoft's website to only achieve the same result.

I have downloaded microsoft security essentials as apparently it was a solution for another user, to no avail. I have also tried SURT numerous times and have not gotten anywhere with that either. I ahve tried Fixit (i do believe it goes by a different name now) and that failed due to an error I just did not have the energy to investigate.

Attached is the zipped log from the sfc / scannow command I ran, as instructed.

Any help regarding this issue would be very much so appreciated.

Please let me know if any more info is required and I will get back ASAP


CBS.zip

EDIT:

I do believe Norton antivirus USED to be on this comp, no longer is. Actually just found an old Norton file in my music folder (???) it was created by symantec (Norton's company) so I deleted it due to the known conflicting issues with windows and some antivirus software. I am currently running Malwarebytes.

EDIT: What exactly should the results of the SURT tool be? I have successfully downloaded and ran SURT multiple times. It only ever asks if I would like to install Hotfix (KB947821), which from what I understand is SURT. the installation was successful, as shown by update history in Windows Update.

I do, however now, have a new problem. It seems my error code may have changed. I will try to automatically update to Service Pack 1 again and see if I once again receive this new code. Will update soon. Sigh.

EDIT:
Yes, indeed I now have a new error code upon attempting to automatically update via Windows Update to Service PAck 1 from Windows 7. The code presented is: 800736b3

Things I've done between the previous error code (in title) and this new (yay.) error code:

1) I have downloaded and successfully installed SURT (also known as KB947821)

2) I have run a sfc /scannow twice via cmd menu. Once before reboot, and once after. The first time a few system files wee repaired, some were not. The second time it did not find anything it could fix, though it did find issues.

EDIT:

Reran windows update troubleshooter (ran it previously to no avail) but did get at least an interesting result.

Windows 7 Ultimate: Cannot install service pack 1 Error: 0x8007370b-meep.png

Interesting to note that the error reported back to me is now the original error code and not the "new" one.

WHAT IS GOING ON

EDIT: Further info retrieved from the Windows Update Troubleshooter. Tabulating it all here because I don't know what to do with the results, and it's just dumbfounding to me that it tells me the problem is not fixed one page earlier and now telling me it is on the "next" click. Shaking my head. Seriously, what to do? Heres the full scroll bar of info generated from the Windows Troubleshooter that I did not get my first time running it:

Windows 7 Ultimate: Cannot install service pack 1 Error: 0x8007370b-meep.png

Windows 7 Ultimate: Cannot install service pack 1 Error: 0x8007370b-merp.png

Windows 7 Ultimate: Cannot install service pack 1 Error: 0x8007370b-merp2.png


I am also going to tag on one last Paint photo of an error I always get upon booting recently (as recently as this whole 'can't get Normandy 1944 to run on my comp'). It may be that I messed with something and this error comes up, not sure if it relates to anything but I'm not taking chances. Here it is, for what it's worth.

Windows 7 Ultimate: Cannot install service pack 1 Error: 0x8007370b-derp1.png




My System SpecsSystem Spec
.
23 Apr 2017   #2
Figgy27

Windows 7 Ultimate x64
 
 

You can see from the pics provided that it totally says "Not fixed" and upon me clicking for more detailed information, the following pics show clearly that it suddenly flips and says "fixed".

At a complete loss right now, probably have put about 3 work days into solving this issue.

Will do backflips for assistance
My System SpecsSystem Spec
Reply

 Windows 7 Ultimate: Cannot install service pack 1 Error: 0x8007370b




Thread Tools




Similar help and support threads
Thread Forum
Service Pack 1, SP1, for my Windows 7 Ultimate system will not install
Hi, Windows Sevenforums I am having a problem installing the Service Pack 1, SP1, for my Windows 7 Ultimate system. I need to install the SP1 so that I can go to the next step and upgrade to Windows 10. I found this “old” posting:...
Windows Updates & Activation
Windows 7 Service Pack 1 install error 8024200d
Hi, I already tried installing different tools (Fixits, Tool System Update Readiness etc.) from Microsoft Knowledge Base - none of them worked. It neither installs with Windows Update nor with downloading the update manually. I use windows 7 professional 64bit. Hope anyone can help...
Windows Updates & Activation
Can't install Windows 7 Service Pack 1, error 800B0100
Hello I am having trouble installing Windows 7 Service Pack 1 using Windows Update. I really want it so that I can get IE10 on my machine. I tried the following: 1. Running System Update Readiness Tool 2. Running Windows Update diagnostic tool 3. Running Fix WU utility 4. Disabling...
Windows Updates & Activation
Trying to install Windows 7 Service Pack 1 SP1 error 80070002
I am trying to install SP1 and am not able to either from Windows Update or the complete x64 package. I get the error File_Not_Found(0x80070002). I get this error after the computer restarts and the service pack fails to configure (around 10%). I have 7 Home Premium x64. This happens after...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:37.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App