Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Update error 80070490

12 Nov 2017   #1

Windows 7 Ultimate x64
Windows Update error 80070490

I get a 80070490 error while Windows update is trying to install KB4022719(June 13, 2017 monthly rollup) and KB2962872(MS14-037: Security update for Internet Explorer)

Here are the following things that I have tried so far.

Ran Windows Update Troubleshooter
Cleared all files in C:\Windows\SoftwareDistribution
Cleared all files in %systemroot%\system32\catroot2
Cleared all files in %ALLUSERSPROFILE%\Application Data\Microsoft\Network\Downloader\
Ran sfc /scannow
Ran chkdskc c: /f
regsvr32 /s.exe atl.dll
regsvr32 /s.exe urlmon.dll
regsvr32 /s.exe mshtml.dll
regsvr32 /s.exe shdocvw.dll
regsvr32 /s.exe browseui.dll
regsvr32 /s.exe jscript.dll
regsvr32 /s.exe vbscript.dll
regsvr32 /s.exe scrrun.dll
regsvr32 /s.exe msxml.dll
regsvr32 /s.exe msxml3.dll
regsvr32 /s.exe msxml6.dll
regsvr32 /s.exe actxprxy.dll
regsvr32 /s.exe softpub.dll
regsvr32 /s.exe wintrust.dll
regsvr32 /s.exe dssenh.dll
regsvr32 /s.exe rsaenh.dll
regsvr32 /s.exe gpkcsp.dll
regsvr32 /s.exe sccbase.dll
regsvr32 /s.exe slbcsp.dll
regsvr32 /s.exe cryptdlg.dll
regsvr32 /s.exe oleaut32.dll
regsvr32 /s.exe ole32.dll
regsvr32 /s.exe shell32.dll
regsvr32 /s.exe initpki.dll
regsvr32 /s.exe wuapi.dll
regsvr32 /s.exe wuaueng.dll
regsvr32 /s.exe wuaueng1.dll
regsvr32 /s.exe wucltui.dll
regsvr32 /s.exe wups.dll
regsvr32 /s.exe wups2.dll
regsvr32 /s.exe wuweb.dll
regsvr32 /s.exe qmgr.dll
regsvr32 /s.exe qmgrprxy.dll
regsvr32 /s.exe wucltux.dll
regsvr32 /s.exe muweb.dll
regsvr32 /s wudriver.dll
regsvr32 /s.exe wuwebv.dll
regsvr32 /s winhttp.dll
Ran "fsutil resource setautoreset true C:"
Ran System Update Readiness tool.
Uninstalled .Net Framework 4.6.1 using the .Net cleanup tool and reinstalled.

The ChecSUR.log is as follows and I have attached the CBS.log

Checking System Update Readiness.
Binary Version 6.1.7601.22471
Package Version 26.0
2017-11-11 14:48

Checking Windows Servicing Packages

Checking Package Manifests and Catalogs

Checking Package Watchlist

Checking Component Watchlist

Checking Packages

Checking Component Store

Seconds executed: 601
No errors detected

System Specifications:

Dell Optiplex 3040
Windows 7 Pro x64
Intel i5-6500 processor
8GB memory

My System SpecsSystem Spec
12 Nov 2017   #2

Win7 Home Premium x64 W10Pro&Home

You may not receive responses unless you fill out your system specs in your profile. Info about your computer model, cpu brand and model, installed memory etc.
My System SpecsSystem Spec
12 Nov 2017   #3

Windows 7 Ultimate x64

I have updated the original post with the computer model number, processor, and version of Windows for the machine that I am inquiring about.
My System SpecsSystem Spec

12 Nov 2017   #4

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi KAugsburger,

can you post the cbs log,
and run these tools, copy/paste the output for both

My System SpecsSystem Spec
12 Nov 2017   #5

Windows 7 Ultimate x64

I have attached the CBS.log after running SFCFix

I have included the output from the MGA diagnostic tool below:

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-M3DJT-4J3WC-733WD
Windows Product Key Hash: xo+ajVSpae7/4VoZjS7m6JL0f3A=
Windows Product ID: 00371-OEM-8992671-00524
Windows Product ID Type: 2
Windows License Type: OEM SLP
Windows OS version: 6.1.7601.2.00010100.1.0.048
ID: {284F4873-ADB6-4E4C-82EE-C2B8C3F41E97}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Professional
Architecture: 0x00000009
Build lab: 7601.win7sp1_ldr.170512-0600
TTS Error:
Validation Diagnostic:
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files\Internet Explorer\iexplore.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{284F4873-ADB6-4E4C-82EE-C2B8C3F41E97}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010100.1.0.048</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-733WD</PKey><PID>00371-OEM-8992671-00524</PID><PIDType>2</PIDType><SID>S-1-5-21-709947874-3165255298-3320918020</SID><SYSTEM><Manufacturer>Dell Inc.</Manufacturer><Model>OptiPlex 3040</Model></SYSTEM><BIOS><Manufacturer>Dell Inc.</Manufacturer><Version>1.4.3</Version><SMBIOSVersion major="2" minor="8"/><Date>20160506000000.000000+000</Date></BIOS><HWID>DF363007018400FE</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Pacific Standard Time(GMT-08:00)</TimeZone><iJoin>1</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>DELL </OEMID><OEMTableID>CBX3 </OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, Professional edition
Description: Windows Operating System - Windows(R) 7, OEM_SLP channel
Activation ID: 50e329f7-a5fa-46b2-85fd-f224e5da7764
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00371-00178-926-700524-02-1033-7601.0000-0762016
Installation ID: 003040282076179302470796561923140666420986941325941282
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: 733WD
License Status: Licensed
Remaining Windows rearm count: 1
Trusted time: 11/12/2017 10:24:35 AM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 11:11:2017 13:01
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
SSDT SataRe SataTabl
SSDT SataRe SataTabl
SSDT SataRe SataTabl
SSDT SataRe SataTabl
SSDT SataRe SataTabl
SSDT SataRe SataTabl
SSDT SataRe SataTabl
SSDT SataRe SataTabl
My System SpecsSystem Spec
12 Nov 2017   #6

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring


Can you confirm there is a COA sticker on this comp.
There appear to be some anomolies within the report
When did it first go non genuine, (its done it twice)

please post the other 2 logs

My System SpecsSystem Spec
12 Nov 2017   #7

Windows 7 Ultimate x64

Here is the log from SFCFix

SFCFix version by niemiro.
Start time: 2017-11-12 10:28:21.529
Microsoft Windows 7 Service Pack 1 - amd64
Not using a script file.

SUMMARY: No corruptions were detected.
AutoAnalysis:: directive completed successfully.

Successfully processed all directives.

Failed to generate a complete zip file. Upload aborted.

SFCFix version by niemiro has completed.
Currently storing 0 datablocks.
Finish time: 2017-11-12 10:35:37.899
I have attached the CBS.log file.

There is only 1 rearm remaining because Windows was installed from our corporate image. It is normal for the count to go down after you sysprep the reference machine. I am unaware of any issues this machine has had with activation since it was imaged.

My System SpecsSystem Spec
12 Nov 2017   #8

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring


This is gonna take a while, its a big ol file and allthough after findind the first failure/error does not mean its been successfull further down the line

so far from the CBS there are at least 13 missing packages from half a dozen updates

Do you or your system admin know how to extract packages and then insert them??
Cant see any GPO restrictions so it could be you

My System SpecsSystem Spec
12 Nov 2017   #9

Windows 7 Ultimate x64

I can extract the MSU files if I can figure out which ones that I need to extract.
My System SpecsSystem Spec
13 Nov 2017   #10

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring


Finally got thru it

there are 31 updates that are only partially installed, and over 100 packages within them have failed.

However the root of the problem could be this,

Failed to find file: amd64_microsoft-windows-s..-downlevel.binaries_31bf3856ad364e35_6.3.9600.18524_none_5fab5bb4ff4130dd\MsSpellCheckingFacility.exe [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]

I do not have a copy of this file folder, if you have another comp that you could copy/import it from and to it may well let you update

My System SpecsSystem Spec

 Windows Update error 80070490

Thread Tools

Similar help and support threads
Thread Forum
Windows Update Error 80070490
Hi, First post here. I work with seniors helping them with computer issues and this one is on an HP Desktop WIndows 7 Home Premium 64 bit. I only help him about once a week so any suggestions may not be attempted for a few days. Windows Update gives error 80070490 when trying to install...
Windows Updates & Activation
Windows Update Error 80070490?
Windows Update has a problem on my machine. Most of the updates get installed with no problem. However now and then (more then than now) one or more of them won't install. I have a couple from last year that are still sitting there. Today I ran the rediness tool a couple of times with no change....
Windows Updates & Activation
Windows Update Error 80070490
Hello Running Windows Vista Home Premium 32bit SP2 Been getting this error when I update windows, tried many fixes to no avail including Windows6.0-KB947821-v33-x86.exe MicrosoftFixit.wu.LB.383193783898689.1.1.Run.exe sfc /scannow
Windows Updates & Activation
Error 80070490 when doing Windows Update
Hi there We have an error every time we did the Windows Update for Windows 7 SP1 for x64-based Systems (KB976932). We have the posting instruction as follow: 1. We did the SURT and complete. 2. We also did "sfc /scannow" and no found any errors 3. Error Code: 80070490 - Windows Update...
Windows Updates & Activation
Windows update Error 80070490
I have problem to windows update 80070490, to this KB, 2769369 - 2778344, 2647753. I has tried very methods but unsuccessful. Any help? Any program or ti to fix it? Thank Nikos Tsaptsalis
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:04.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App