Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win7 Pro 64-Bit: Update Wervice not running...recent issue

03 Dec 2017   #1

Win7 Pro 64-Bit
Win7 Pro 64-Bit: Update Service not running...recent issue

This appears to be the issue I am experiencing:

Windows Update Service not running - Windows 7 Help Forums

Note, this laptop did have several updates performed recently...perhaps last week? I did not want to lose my update history so, I chose to fix the problem myself as suggested on this MS webpage:

I have a background in some pc interfacing and IT so, I checked the administrative service and found both to be in a started state rather than running as the MS information indicates.

I do not want to go too far without obtaining professional assistance. At the moment, the update remains disabled as is shown by the "x" in the red shield.

I also chose to read and print this page of info yet, have not attempted to implement the instructions it contains until later.

My System SpecsSystem Spec
03 Dec 2017   #2

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi RickV,

have you just tried the troubleshooter option, it doesn't clear the installed updates section just checks the services.
Windows Update Troubleshoot Shortcut - Create - Windows 7 Help Forums

Losing the update history is not actually a problem now that MS has introduced Cumulative updates policy anything missing is picked up via the >>monthly<< "super" (cumulative) update.
(and the latest was last week or so)
I only install the monthly Security update BUT if you use IE11 take them both.

My System SpecsSystem Spec
03 Dec 2017   #3

Windows 7 Professional 64-bit


I am having exactly same issue since yesterday on 2 different computers, both running Windows 7.
And seeing I am not the only one makes it definitely something on Microsoft side. I haven't updated anything during last 7 days and 2 days ago Windows Update was still working fine. I get the feeling they remotely disabled something in our computers for whatever reason.
My System SpecsSystem Spec

03 Dec 2017   #4

Win7 Pro 64-Bit


I appreciate the suggestion but, executing this diagnostic informed me it could not identify a problem. This is a surprise.

Edit - I am now concerned about the (much) older laptop I took into work temporarily because my work desktop was determined to have a video hardware problem. I may have two laptops impacted by this as well.
My System SpecsSystem Spec
04 Dec 2017   #5

Windows 7 Professional 64 bit

I have the exact same problem with both my computer and my laptop both have Windows 7 installed (one professional 64-bit and one home 32-bit), only starting from today. They both successfully last checked for update at different times yesterday. They both had different last windows update on different dates. I also tried uninstalling the last windows update on one of the computers but it made no difference. My other computers that have Windows 10 installed do not have the same problem.

I searched around and found many people having the same issue with Windows 7 in the last 24 hours. The suggestion in the link below to rename the softwaredistribution folder worked but it also erased all the past update history, which is not something I want, so I reversed the change.

Windows Updates

It seems like everyone's Windows 7 softwaredistribution folder get corrupted in the last day for some reason. Like Xenoid said, either Microsoft modified something to make Windows 7 update stopped working, or a mass hacking attempt that exploit a weakness in Windows 7. If someone could pinpoint what to fix within the softwaredistribution folder without having to remove it altogether so we can keep the installed update history, that would be ideal.
My System SpecsSystem Spec
04 Dec 2017   #6

Windows 7 64bit

I am also experiencing the same problems with the Windows Update and Microsoft Security Essentials Update. It all started for me on Saturday during the day. Last successful check for Updates was Saturday morning and since then its broken.

Renaming the SoftwareDistribution Folder got it working again, but the EvenLog still gets spammed with error messages as soon as the Security Essentials try to get a new definition (which works, but it generates error messages as well).

My guess is a forced update on 02.12.2017, because I got an "important" update on that date according to my System Restore Point log and thats the date it stopped working for me.

Every Windows 7 PC at work suffers the same problems. I think its safe to say, that it is Microsofts fault.
My System SpecsSystem Spec
04 Dec 2017   #7

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1

I am having the same problem, just checked updates today after several days of last check. I have win 7 pro x64.

At least, even with not being able to update (red x) I am functional - the computer is a little sluggish tho.
After doing basic research, I figured I better come here and get more help before I really do something that completely disables me.

I hope MS comes up with a fix or hopefully will wake up tomorrow & updates magically works again :)
My System SpecsSystem Spec
04 Dec 2017   #8

Windows 7 Ultimate 32 bits

There is another issue to add to this, at least in my case.

You see I had Windows Update with the Office and other microsoft products updates enabled and all was working fine. Actually my updates history showed only correct status on the updates as in that over the years I never had an issue with Windows Update.

This takes us to November 30, 2017. I checked Windows Update because I saw the Windows Update icon on the shut down button, there were 3 optional updates. 2 were office related updates, and the other was the 2017-11 Preview of Monthly Rollup - KB4051034

The computer seemed to work normally, other than that one morning when I turned it on, the desktop appeared in a Aero disabled mode, but a couple of seconds later it enabled, nothing seemed to be out of normal. Some hours ago I decided to check Windows Update and I came across this issue of Windows Update Service not started but on the Services window it did appear started.

I did the solution of rename the SoftwareDistribution folder and Windows Update worked again, but this got me a new issue. The issue is that I can't re-enable the updates for other Microsoft Products.

I tried everything. Compatibility mode on Internet Explorer 11, The enable through script solution, re-enable the optin prompt in Office 2010, I even returned to Internet explorer 9 and 10 and no go, tried the Microsoft Silverlight installation and didn't work.

Heck! I even disabled the antivirus thinking it may be clashing with the Microsoft Update enabling, but it was the same thing, so it wasn't the Antiviru's fault =/

Windows Update do work though, updates for Windows download and install correctly, I downloaded cumulative updates for internet explorer 9, 10 and 11, installed the monthly rollout (it came out today) and even installed that preview of monthly rollout again and everything is fine, but I can get updates for Microsoft Office anymore

I'm pretty sure it was something Microsoft did on that preview of monthly rollout, since other than that and updating Firefox and Adobe Reader (which those two programs Adobe and Firefox I really doubt they have something to do in this), I didn't install anything else.

By the way. When I tried the Internet Explorer 11 compatibility mode to get the "Learn more" link to work from Windows Update to work correctly so I could get the install button for Microsoft Update, I got this error after clicking on install:

No se ha podido instalar Microsoft Update en el equipo
Asegúrese de iniciar sesión como administrador o como miembro del grupo Administradores y vuelva a intentarlo.

Más opciones de solución de problemas
  • Si el equipo está conectado a una red y el problema persiste, póngase en contacto con el administrador del sistema para ver si la configuración de Microsoft Update se administra mediante directivas de grupo..
  • Si el equipo no está conectado a una red o si el administrador del sistema no ha deshabilitado Microsoft Update, compruebe si el servicio Windows Update se ha deshabilitado o detenido. Para ver cómo iniciar un servicio, busque en la ayuda y soporte técnico de su equipo..

Nota: si experimenta problemas al instalar Microsoft Update, puede seguir instalando actualizaciones para el equipo si selecciona Windows Update en el Panel de control.

[Número de error: 0x80248015]

I noticed the error number which usually is related to either date and time being incorrect, among other possible causes. I tried the solutions but nothing worked.

In my case is Windows 7 Ultimate x86. I know the thread says 64bit, but since both Windows builds (32 and 64bit) got the same issue of the Windows Update Service is not running, I guess we can use the thread for both right? :)
My System SpecsSystem Spec
04 Dec 2017   #9

Windows 7 64 Bit

I lost the Windows Update Service late last night... the red "x" appeared. I had had no problems with updates for over a year. I figured it had to do with my PC, so I looked around the web, tried some kludges all of which caused error messages, and reluctantly decided on major surgery. I shut off the Service and deleted the Software Distribution Folder, restarted, and checked for updates and it is back working. History is preserved in the "Installed Updates" window, but wiped on the main windows.

On bootup this AM same thing occurred on my second machine, same "cure".

FWIW, I never download the "preview" updates and do not dl the malicious software tool or optional updates, no other software changes, so this must be a glitch from Microsoft.
My System SpecsSystem Spec
04 Dec 2017   #10

Windows 7 Pro x64

add me to the list... Red X on ms updates win 7 x64
Troubleshooter did not find problem
My System SpecsSystem Spec

 Win7 Pro 64-Bit: Update Wervice not running...recent issue

Thread Tools

Similar help and support threads
Thread Forum
Recent Experience with Windows 64-bit Win7 Pro Update (KBs Listed)
My system is an Acer TMP645-MG w/i7-4500U, 8GB RAM on Windows 7 Pro 64-bit. The state of Windows Update on this Acer remains that desired to prevent the automatic update for Window 10. Please inform me if I need to unhide any of the (3) KB's involved in that fiasco. Here is the list of KB's MS...
Windows Updates & Activation
Win7 Pro recent "Windows is not genuine" issue
This is a custom-built desktop that has been running since 2014. No recent changes to hardware (only change ever might have been RAM addition). After years of updates, recently started getting the notices with 0xC004F200 error on startup. Screen is now black with Build 7601 Windows is not genuine...
Windows Updates & Activation
Win7 - Windows Update Error "Service is not running"
Hello, can someone here please kindly help me with my problems re Windows Update --- I have tried to run Windows Update on my computer and received the following error message: I have tried the Windows Update Troubleshooter for Windows 7 from "Windows Update Cannot Check For Updates"...
Windows Updates & Activation
BSOD when running utorrent- recent development
I am running Windows 7 Home Premium x 64 Service Pack-1 on a custom PC with i3 processor & 4GB Ram. I started getting BSOD around a week ago- whenever I use utorrent. Sometimes I get the BSOD within minutes of starting the utorrent, sometimes after several hours. I have been using utorrent on this...
BSOD Help and Support
Recent W7 repair install issue
For reasons in another thread I today did a W7 repair install. This has left my SSD drive which had 15.6gb free space out of 59.6gb now has only 12gb flat. Question is has this repair doubled up on certain windows files with which I can delete now? Is there a method which can assure removal of only...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:13.
Twitter Facebook