Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Another W7 Update Problem Child, Won't Run Update, Won't Run Installer

06 Feb 2018   #11
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi FlyingPhill,

Hope you've got a good memory
Appears this all started in 2012, an update failure for a Language package, further corruption also appeared in your components hive
Then i believe the update process started to use all your resources, so you turned them Off in February 2013
IF your system specs are correct 2GB RAM is NOT enough you need at least 3GB
and from what i can find about it, it was shipped with Ultimate and would have come with more than 2GB

The CBS log files you posted jump from 2013 to 2018 - looks like WU has not been running for 5 years
There have been many security updates since then and i suspect 1 of them was the reason why QB failed
Not sure what fix's you attempted back then but i'd guess it was something to do with certain files that control windows updates licencing, which is also out of date hence the server error
you could run this tool and copy/paste the output
http://go.microsoft.com/fwlink/?LinkID=52012

BUT
Your best bet is a repair install NO loss of personal data.

Repair Install - Windows 7 Help Forums

Roy

note as you appear to be using your comp for business purposes i hope you use something like Macrium free to make images of your data externally


My System SpecsSystem Spec
.
06 Feb 2018   #12
flyinphill

W7 Pro 64 bit
 
 

Quote   Quote: Originally Posted by torchwood View Post
Hi FlyingPhill,

Hope you've got a good memory
Appears this all started in 2012, an update failure for a Language package, further corruption also appeared in your components hive
Then i believe the update process started to use all your resources, so you turned them Off in February 2013
IF your system specs are correct 2GB RAM is NOT enough you need at least 3GB
and from what i can find about it, it was shipped with Ultimate and would have come with more than 2GB

The CBS log files you posted jump from 2013 to 2018 - looks like WU has not been running for 5 years
There have been many security updates since then and i suspect 1 of them was the reason why QB failed
Not sure what fix's you attempted back then but i'd guess it was something to do with certain files that control windows updates licencing, which is also out of date hence the server error
you could run this tool and copy/paste the output
http://go.microsoft.com/fwlink/?LinkID=52012

BUT
Your best bet is a repair install NO loss of personal data.

Repair Install - Windows 7 Help Forums

Roy

note as you appear to be using your comp for business purposes i hope you use something like Macrium free to make images of your data externally
This machine was purchased in 2011 when I was in engineering school at the University. It was bought to run LabVIEW for a project that was part of my senior design class, as well as to run Pro Engineer parametric CAD. After that, it was relegated to be primarily a business computer used by my wife with our tax, sales, etc info stored on it. One of my daughters has used it a few times when her laptop has been down for whatever reason. But other than that, it sits for weeks or even months at a time without even being powered on.

When all of these issues began, 2013 you are reporting, I have no idea about. I never turned anything off, but someone else could have. In fact, until this problem, I probably have not turned this machine on myself more than a dozen times since 2012 when I completed my undergraduate degree.

My memory was that the machine was purchased with W7 Pro and 2GB. The Microsoft tag under the battery says Pro, and the service tag on my Dell account also says Pro with 2GB of RAM. I will agree 100% that it needs more RAM, I already looked up purchasing 8GB for it. But it does seem to have originally come with 2GB. RAM was so expensive as an option from Dell at the time, and my budget as a college student was very limited. So I chose to get the minimum RAM with the intent of upgrading myself. That obviously never happened.

I ran the Microsoft Diagnostic tool as you asked. At the end, the "Copy" button won't do anything. Not sure what it is supposed to do, maybe output to a notepad file or something. It appears that it may be an ActiveX issue judging by the licensing tab. So I used Paint to create a screen shot of the page that displays at completion. I attached this, but if you need something else let me know. In the meanwhile I will try your repair approach tonight and see what happens.


Attached Images
Another W7 Update Problem Child, Won't Run Update, Won't Run Installer-microsoft.png 
My System SpecsSystem Spec
06 Feb 2018   #13
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi Phil,

the bit of the report im interested in is in another section,
can you follow this, includes the posting instructions.
Its primarily a genuine check but provides more info, I do know that comp came with Pro downgrade rights . I also believe this is not the problem
Windows Genuine and Activation Issue Posting Instructions - Windows 7 Help Forums


However you may want to re-install
Dell ISO W7 SP1 instructions

AS you are running with only 2GB and as long as Quick Books can run as a 32 bit program, choose that but both are available
Dell Linux Recovery Image
note the titles wrong it is for W7



This Tool can be ran on a non-Dell system provided that a Dell Service Tag is input. There seems to be no limitations on how many times a Service Tag is input:
  • 5KR9DC2 - Windows 7 Pro 64 Bit
  • 7GXLCS1 - Windows 7 Pro 32 Bit
Roy
My System SpecsSystem Spec
.

06 Feb 2018   #14
flyinphill

W7 Pro 64 bit
 
 

Diagnostic Report (1.9.0027.0):
-----------------------------------------
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-M3DJT-4J3WC-733WD
Windows Product Key Hash: xo+ajVSpae7/4VoZjS7m6JL0f3A=
Windows Product ID: 00371-OEM-8992671-00524
Windows Product ID Type: 2
Windows License Type: OEM SLP
Windows OS version: 6.1.7601.2.00010100.1.0.048
ID: {78B12EA8-610B-4949-B058-825AFDD5F289}(3)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Professional
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.120830-0333
TTS Error:
Validation Diagnostic:
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{78B12EA8-610B-4949-B058-825AFDD5F289}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010100.1.0.048</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-733WD</PKey><PID>00371-OEM-8992671-00524</PID><PIDType>2</PIDType><SID>S-1-5-21-1223673647-947130279-3379226297</SID><SYSTEM><Manufacturer>Dell Inc.</Manufacturer><Model>Precision M4500</Model></SYSTEM><BIOS><Manufacturer>Dell Inc.</Manufacturer><Version>A06</Version><SMBIOSVersion major="2" minor="6"/><Date>20101120000000.000000+000</Date></BIOS><HWID>1F003B07018400FE</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>DELL </OEMID><OEMTableID>E2 </OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>

Spsys.log Content: 0x80070002

Licensing Data-->
C:\Windows\system32\slmgr.vbs(22, 1) Microsoft VBScript runtime error: ActiveX component can't create object: 'Scripting.Dictionary'

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 11:26:2017 14:18
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:


HWID Data-->
HWID Hash Current: NgAAAAEAAQABAAEAAQACAAAABQABAAEAJJQGx1M5GM6m6ep1/mmKUrjpHUUovj6RG+N6H3ZW

OEM Activation 1.0 Data-->
N/A

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
APIC DELL E2
FACP DELL E2
HPET DELL E2
BOOT DELL E2
MCFG A M I GMCH945.
TCPA
SLIC DELL E2
SSDT PmRef CpuPm
My System SpecsSystem Spec
06 Feb 2018   #15
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi Phil,

Bingo, from the report

Licensing Data-->
C:\Windows\system32\slmgr.vbs(22, 1) Microsoft VBScript runtime error: ActiveX component can't create object: 'Scripting.Dictionary'


1 AM here in Blighty will post a fix in the morning.

Roy

Upto you if you want to go with the re-install
My System SpecsSystem Spec
06 Feb 2018   #16
flyinphill

W7 Pro 64 bit
 
 

Would rather try your fix first. I don't have enough space on C: to do a repair without deleting stuff. It is an early SSD with only 60GB.

I am also going to order an 8GB kit for it tonight. Only 7 years late :)
My System SpecsSystem Spec
07 Feb 2018   #17
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi Phil,

can you follow the instructions in the screenshot,

Wont hurt to run all 3, then
REBOOT

next from run
slmgr /rilc

REBOOT

rerun the tool


Once completed navigate to
C >> WINDOWS >> System32
(then in the search box top right)
slmgr

you should get 3 entries, what are the file sizes on 2 and 3, hopefully
37.8 kb
110 kb

Quite a rare error unfortunately

Roy


Attached Thumbnails
Another W7 Update Problem Child, Won't Run Update, Won't Run Installer-script2.png  
My System SpecsSystem Spec
07 Feb 2018   #18
flyinphill

W7 Pro 64 bit
 
 

Sorry to take so long today getting back to this. It has been an absolutely wide-open day, this is my first chance to touch this problem.

Quote   Quote: Originally Posted by torchwood View Post
Hi Phil,

can you follow the instructions in the screenshot,

Wont hurt to run all 3, then
REBOOT
1) Would not run

2) Ran successfully

3) Ran successfully


Quote:
next from run
slmgr /rilc
Shows folder named "0409" with Modified date 7/14/2009

Quote:

REBOOT

rerun the tool
Not clear which tool you are referencing here. I assume you mean the reinstall license script slmgr /rilc

Quote:

Once completed navigate to
C >> WINDOWS >> System32
(then in the search box top right)
slmgr

you should get 3 entries, what are the file sizes on 2 and 3, hopefully
37.8 kb
110 kb
Gives 3 entries. Size for 2 and 3 are 38KB and 111KB. All 3 have 2009 dates.


Quote:
Quite a rare error unfortunately

Roy
I am not clear whether this was intended to correct the Update issue or the Installer issue, but nothing has changed. I went through all of this again and nothing was different, except that Step 1 in your screenshot ran successfully this time. I will reun the Diagnostic Tool again and post the results.
My System SpecsSystem Spec
07 Feb 2018   #19
flyinphill

W7 Pro 64 bit
 
 

Results from diagnostic tool. ActiveX still shows as a problem.


Diagnostic Report (1.9.0027.0):
-----------------------------------------
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-M3DJT-4J3WC-733WD
Windows Product Key Hash: xo+ajVSpae7/4VoZjS7m6JL0f3A=
Windows Product ID: 00371-OEM-8992671-00524
Windows Product ID Type: 2
Windows License Type: OEM SLP
Windows OS version: 6.1.7601.2.00010100.1.0.048
ID: {78B12EA8-610B-4949-B058-825AFDD5F289}(3)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Professional
Architecture: 0x00000009
Build lab: 7601.win7sp1_gdr.120830-0333
TTS Error:
Validation Diagnostic:
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{78B12EA8-610B-4949-B058-825AFDD5F289}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010100.1.0.048</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-733WD</PKey><PID>00371-OEM-8992671-00524</PID><PIDType>2</PIDType><SID>S-1-5-21-1223673647-947130279-3379226297</SID><SYSTEM><Manufacturer>Dell Inc.</Manufacturer><Model>Precision M4500</Model></SYSTEM><BIOS><Manufacturer>Dell Inc.</Manufacturer><Version>A06</Version><SMBIOSVersion major="2" minor="6"/><Date>20101120000000.000000+000</Date></BIOS><HWID>1F003B07018400FE</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>DELL </OEMID><OEMTableID>E2 </OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>

Spsys.log Content: 0x80070002

Licensing Data-->
C:\Windows\system32\slmgr.vbs(22, 1) Microsoft VBScript runtime error: ActiveX component can't create object: 'Scripting.Dictionary'

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 11:26:2017 14:18
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:


HWID Data-->
HWID Hash Current: NgAAAAEAAQABAAEAAQACAAAABQABAAEAJJQGx1M5GM6m6ep1/mmKUrjpHUUovj6RG+N6H3ZW

OEM Activation 1.0 Data-->
N/A

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
APIC DELL E2
FACP DELL E2
HPET DELL E2
BOOT DELL E2
MCFG A M I GMCH945.
TCPA
SLIC DELL E2
SSDT PmRef CpuPm
My System SpecsSystem Spec
07 Feb 2018   #20
flyinphill

W7 Pro 64 bit
 
 

I have another machine sitting here with a perfectly operating W7 Pro OS. It is a Dell M6800 that is about 1.5 years old. Is there any way to copy the required files or folders from one machine and overwrite them in the trouble machine?
My System SpecsSystem Spec
Reply

 Another W7 Update Problem Child, Won't Run Update, Won't Run Installer




Thread Tools




Similar help and support threads
Thread Forum
Windows update + wsus offline installer problem
Did a fresh install of win7 x64 and had the problem with windows update checking for update forever so decided to install updates via wsus offline installer Wsus found and installed 210 updates and installed them then found another 28 but in the meantime window updater that i left running found...
Windows Updates & Activation
Windows Update Installer Update failing - Code 80073712
Logs attached. Attempting to update Windows results in attempt to update Windows Update Installer, which fails with Code 80073712. Logs attached. sfc /scannow reported no problems found. Windows 7 SP1 Home Premium x64 Thanks in advance! - Tim
Windows Updates & Activation
Windows update and system update readiness tool problem.
I have am currently running IE9 and see an error code of 9C59 when installing the update to IE11. The Windows Update Troubleshooter reported the service registeration is missing or corrupt (not fixed), and the Windows updat error 0x80070490(2014-12-12-T-07_49_01P) (not fixed). I then downloaded...
Windows Updates & Activation
Windows Installer 5 - trying to update to Skype 5.1 from 5.0
Starting a new thread. Prior one's subject is "Error 1663". This time lets talk, specifically, about the Windows Installer for Windows 7. Is the installer a stand alone program? Can it be deleted? How? Where can I find a replacement? Bill
Software
which update installs trusted installer
Can anyone tell me which update installs Trustedinstaller.exe in win 7? I'd like to uninstall that update, I have heard that it creates a lot of pronlems
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:43.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App