Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ?!? windows HANGS at P.O.S.T after restart? (have to hard-reset)

20 Feb 2018   #1
7point5

windows
 
 
?!? windows HANGS at P.O.S.T after restart? (have to hard-reset)

so I noticed that only now windows hangs at POST every time I restart (fans running, no signal to monitor)

shutdown goes without a problem, only restart is buggy

2 things:

1) it only hangs after the latest cumulative monthly rollups. before that it would restart normally, signal to monitor would still get cut off but only for a second, then Bios would beep & POST

2) it only hangs if C3 & C6 states are enabled (however before the rollups I could leave them enabled & still restart normally)
which means there's a bug in the rollups (at least the last 2 ones)

so my question is, since disabling C-states is out of the question and since reverting pre-rollup is also out of the question, how can I fix this & have the system restart normally like it used to?


My System SpecsSystem Spec
.
21 Feb 2018   #2
fireberd

Windows 10 64 bit
 
 

Just a comment. If it hangs at "POST" (Power On Self Test) that has nothing to do with Windows. Windows hasn't started to load yet.
My System SpecsSystem Spec
21 Feb 2018   #3
7point5

windows
 
 

Quote   Quote: Originally Posted by fireberd View Post
Just a comment. If it hangs at "POST" (Power On Self Test) that has nothing to do with Windows. Windows hasn't started to load yet.
so somehow

- BEFORE installing monthly rollup, Restart works normally

and

- AFTER installing monthly rollup, Restart no long works normally? (no signal to monitor but cpu fan still running)

yet this has nothing to do with windows? so could the monthly rollup somehow alter the bios itself or something???
My System SpecsSystem Spec
.

21 Feb 2018   #4
fireberd

Windows 10 64 bit
 
 

Quote:
o I noticed that only now windows hangs at POST every time I restart (fans running, no signal to monitor)
By that statement it hangs up at the Power On Self Test. If this is true then yes it has nothing to do with Windows as its just going through the self test and then the BIOS takes over but even that is not loading Windows.

However, if its really getting by the POST and the BIOS, and hanging up not loading Windows then it could be something in the update. Try starting in Safe Mode (Press F8 before Windows starts to load) and if that starts, you can try a system restore before the updates.
My System SpecsSystem Spec
21 Feb 2018   #5
mrjimphelps

Linux Mint 18.2 xfce 64-bit (VMWare host) / Windows 8.1 Pro 32-bit (VMWare guest)
 
 

If you shut down first and then restart (as opposed to just restarting), do you have the same problem?
My System SpecsSystem Spec
21 Feb 2018   #6
7point5

windows
 
 

Quote   Quote: Originally Posted by fireberd View Post
By that statement it hangs up at the Power On Self Test. If this is true then yes it has nothing to do with Windows as its just going through the self test and then the BIOS takes over but even that is not loading Windows.

However, if its really getting by the POST and the BIOS, and hanging up not loading Windows then it could be something in the update.
it hangs before the "bios beep" (which happens before POST & before signal to monitor returns right?)

Quote:
Try starting in Safe Mode (Press F8 before Windows starts to load) and if that starts, you can try a system restore before the updates.
that's the thing I want it to restart normally without uninstalling something as critical as the monthly rollups
My System SpecsSystem Spec
21 Feb 2018   #7
7point5

windows
 
 

Quote   Quote: Originally Posted by mrjimphelps View Post
If you shut down first and then restart (as opposed to just restarting), do you have the same problem?
nope like I said the windows shutdown ("acpi shutdown" as they call it) still works normally after the monthly rollup so I can do a clean shutdown then turn on the PC again as usual

only the direct restart is buggy after the monthly rollup
(and even then, only when C-states are enabled in bios. disabling those allows a normal restart, but then why disable them now when I didn't have to disable them before the monthly rollup?)



so to sum it up Windows 7 + monthly rollup + C-states* = no restarting

basically the monthly rollups are somehow incompatible with C-states

* C3 & C6 only. I can still leave C1 enabled & have a normal restart, even after monthly rollup
My System SpecsSystem Spec
21 Feb 2018   #8
Bat 1

8.1 home x64
 
 

Bat just wondering what led you to disable c states to try to fix the problem ? Something specific to your configuration (Not Listed) that was posted elsewhere ?
My System SpecsSystem Spec
21 Feb 2018   #9
7point5

windows
 
 

Quote   Quote: Originally Posted by Bat 1 View Post
Bat just wondering what led you to disable c states to try to fix the problem ? Something specific to your configuration (Not Listed) that was posted elsewhere ?
no I just tried changing different bios settings till something worked ^^

then again I shouldn't have to disable the Cstates now since I didn't need to disable them before the monthly rollups
My System SpecsSystem Spec
21 Feb 2018   #10
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

This website might help you with the Cstates & what the various setting do.

Everything You Need to Know About the CPU C-States Power Saving Modes | Hardware Secrets
My System SpecsSystem Spec
Reply

 ?!? windows HANGS at P.O.S.T after restart? (have to hard-reset)




Thread Tools




Similar help and support threads
Thread Forum
BSOD and computer also hangs requiring hard reset,
I keep getting blue screen of death as well as computer hanging requiring a hard reset, particularly when using ableton live music software, but also happens when not. Have run memtest and memory passed fine. Not done any other tests, what is weird is the memory dmp, seemed to point to a...
BSOD Help and Support
Windows 7 64bit. Hangs when I restart, but shutdown/restart works fine
I just rebuilt my game pc and ever since I installed windows 7 64bit anytime I hit restart it says windows is shutting down, the screen goes black and stays black. I have to press the power button to force a shut down and then restart it. BUT, if I shut down windows with the shut down button the pc...
General Discussion
After 6 hours, the PC just hangs and I have to hard reset
This happened EVERY DAY. I have my PC set to turn off automatically at 1 AM. If I leave it on all day then the next morning I'll come to it and it'll just have the desktop there and none of the icons or ctrl alt del or even pressing the power button will work. I have to hard reset. It's screwing up...
BSOD Help and Support
PC hangs on post screen after doing Windows 7 restart
I just built my computer today, everything is working fine and all drivers are installed from official websites etc. When I start my computer from complete off (cold startup) the BIOS splash screen lasts for 1 second before Windows 7 starts booting, and the computer startup speeds are fine....
Hardware & Devices
Windows 7 Hangs on Shutdown / Restart
Every other day or so when shutting down or restarting Windows gets to the "Logging Off" stage and sits there until I just get tired of waiting and hit the reset button. I remmeber having the same problem years back on numerous machines and having to do download a patch for the problem. Windows 7...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App