Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cant install netFramework 4.7

19 Apr 2018   #1
Dariusz

Windows 7 Proffesional x64
 
 
Cant install netFramework 4.7

Hey

I have win7 running SP1 6.1 Build 7601. Running in offline mode - its a storage system that needs some update to run an app.

I tried downloading from this site Latest Windows Service Packs and Updates (April 2018) this pack Convenience Rollup (April 2016) but it does not install. It says that the update is not for my computer.

When I try to install net 4.7 I get:

A certificate chain processed but terminated in a root certificate which is not trusted by the trust provider.

I have no idea how to solve it. I cant update windows and I cant install framework :- (


My System SpecsSystem Spec
.
19 Apr 2018   #2
abbeyon

Win 10 pro 64 bit
 
 

First make sure 4.7 is supported on your system or not. Try win+r and and type winver if your version isn't 1703 or 1709 then it won't support 4.7
My System SpecsSystem Spec
19 Apr 2018   #3
Dariusz

Windows 7 Proffesional x64
 
 

What I did is once I started install and it errors at the end. I dont close window. I go to c:/tempfoldername, and run FULL_.exe there. That ingores all the checks, and instals framework just fine. everything works after that. So I dont need latest patches/etc etc to get it running :- )
My System SpecsSystem Spec
.

Reply

 Cant install netFramework 4.7




Thread Tools




Similar help and support threads
Thread Forum
Is my .netframework 4.0 plus installed?.
Hi I have just looked in turn on and off windows features. I Was looking threw it and noticed only Microsoft .NET Framework 3.5.1 was listed. I pressed the + sign and only thing there is. Windows Communication Foundation HTTP Activation Windows Communication Foundation Non-HTTP Activation. ...
Windows Updates & Activation
How to reinstall .netframework after using dotnetfx_cleanup_tool?
Im trying to reinstall netframework after runnning "dotnetfx_cleanup_tool". Im doing this because techsupport from razer said to remove all versions, then reinstall netframework and reinstall synapse (however the program still isn't working) When i do try to install 3.0 i get an error saying...
Software
.netFramework and Ugrade Advisor ?
Greetings, I am trying to run a pgm named 'FileToFolder' and it tells me I need to install '.netFramework,Version=v4.0' before it will run. I am quite sure i used to have it, but RevoInstall says no more. So I thought i would run the 'windows 7 upgrade Advisor'. But i can't find anything...
Software
Windows 7 can't install Microsoft .Netframework 3.5 SP1
I tried a lot of things for this. My common errors are to "Turn 3.5 SP1 in control panel" which it already is. And if I get a chance to use the recommended settings on the setup, I get an error and everything reinstalls. Please help! I have uninstalled my computer 3 times and I don't want to...
Software
Netframework download failing
Hopefully someone will still be running XP along with Win 7...have 2 laptops still using XP and have a problem that I hope someone here can help with. When running Windows Update..I get repeated errors on the attached (failed.jpg) Net Framework update. Have disabled a/v and firewall for...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:39.
Twitter Facebook Google+