Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: UPDATE trashed my OS stuck on " updating system settings"

09 Jun 2019   #1

UPDATE trashed my OS stuck on " updating system settings"

I was surprised that I could not get to windows update in safe mode. And make sure to turn automatic updates OFF on my computer before I do a drive image next time !
Anyway It was "configuring updates" for about 12 hours overnight and I figured it was time to give up. Now it wont roll them back. I booted into safe-mode because the desktop said "updating desktop personal settings"
ANd now I find that I can not start safe mode there to undo updates. what the heck ? I dont remember XP being that way. Why is windows safe mode programmed this way?
Anyway how can I get my PC - other than restoring to the image I made ? It it possible to recognize what update was not working ? Since I can not see it in safe mode and cant get past the never ending personalized settings what do I do ? I could let "Please wait while windows updates your personalized desktop settings"
its little white message on a black screen that comes up after logging in.
How do I roll this update back?

My System SpecsSystem Spec
11 Jun 2019   #2

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Don,

Windows Updates have never been allowed to automatically run in Safe mode, certain services are not initialised, by design

Please note, the message - updating desktop personal settings
is NOT a true update
Its your user profile (preference settings) being changed

Can you get to a Command Prompt screen, if so we can revert the pending update,
BUT NOT a profile change

Option 1
type cmd and press enter
type net stop wuauserv and press enter
type rename c:\windows\SoftwareDistribution softwaredistribution.oldand press enter
type net start wuauserv and press enter
type exit and press enter

if the above fails then
Open an Elevated Command Prompt, and run the following commands...


reboot and then attempt Windows Update again.


Click Start, and then type regedit in the Start Search box.
In the Programs list, click regedit.exe.
Locate and then select the following registry subkey:
Right-click COMPONENTS.
Click Export.
In the File Name box, type COMPONENTS.
In the Save in box, click Desktop, click Save, and then save the file to your desktop.
In the details pane, right-click PendingXmlIdentifier, and then click Delete. If this value does not exist, go to the next step.
In the details pane, right-click NextQueueEntryIndex, and then click Delete. If this value does not exist, go to the next step.
In the details pane, right-click AdvancedInstallersNeedResolving, and then click Delete. If the value does not exist, go to the next step.
Restart the computer.


Have you tried a Hard reboot, press and hold the power button for 7 seconds, it forces the system to reboot and perform a mini-reset

My System SpecsSystem Spec
11 Jun 2019   #3


Thank you for all of this information. !
I restored my system to from a image. I beleive it was one of the 2019 o5 updates that had my computer forever trying to configure updates. It said " please do not shut your machine off configuring updates " Im not leaving my machine of for more than 12 hours. something is wrong. Maybe because microsoft and nvida are putting me in the middle of their conflict ?

For now I hope to identify what update is causing me all the heartache because I went through his before on this computer. I think it was
UPDATE trashed my OS stuck on " updating system settings"-updates-what-one.jpg







Im pretty sure its the 164 update that is giving me the grief.

Soon I am going to do a bare bones OS install and install my NVIDA 980Ti drivers then do this update and see if it will work.
I am Leary of this OS I received from the guy who I purchased this computer from it was on a USB stick with a COA key.

My System SpecsSystem Spec

11 Jun 2019   #4

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Don,

Your last sentence " I'm a bit leary" is of some concern.
for 2 reasons as far as im aware W7 was never genuinually sold on a USB with the key included on it
this leads me to believe its possibly suspect, and if so non-standard code could be included on it.

We can check the key, run this MS tool and copy/paste the output

I would plump for a clean install, then use either Dism++ or simplex to install the updates

for info
Reinstall Win7 what updates to avoid for telemetry & winX preparation?

My System SpecsSystem Spec
4 Weeks Ago   #5


Roy - I am grateful for this info thank you ! I am re-arranging my place and trying to find the usb flash
My System SpecsSystem Spec
4 Weeks Ago   #6


This Output Copy :
I did find the install USB - Can this be tested in some way with a HASH ?? I will download the windows iso from the place shown on this forum but still is there a way to check these iso files with a hash ?

This is the report from WINDIAG That

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: 0x0
Windows Product Key: *****-*****-3KW49-RRCHB-3T8GX
Windows Product Key Hash: eGgStPE1PVOfBJX6m9q9uzUnvG4=
Windows Product ID: 00371-OEM-9308062-35067
Windows Product ID Type: 8
Windows License Type: COA SLP
Windows OS version: 6.1.7601.2.00010100.1.0.048
ID: {77FF310C-0F4C-4D3B-AA20-65EF2F45EEDB}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Professional
Architecture: 0x00000009
Build lab: 7601.win7sp1_ldr.180608-0600
TTS Error:
Validation Diagnostic:
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{77FF310C-0F4C-4D3B-AA20-65EF2F45EEDB}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010100.1.0.048</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-3T8GX</PKey><PID>00371-OEM-9308062-35067</PID><PIDType>8</PIDType><SID>S-1-5-21-2120667460-3136881451-535882566</SID><SYSTEM><Manufacturer>Gigabyte Technology Co., Ltd.</Manufacturer><Model>Z170X-Ultra Gaming</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>F20</Version><SMBIOSVersion major="3" minor="0"/><Date>20161104000000.000000+000</Date></BIOS><HWID>FB893607018400FE</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Mountain Standard Time(GMT-07:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, Professional edition
Description: Windows Operating System - Windows(R) 7, OEM_COA_SLP channel
Activation ID: da22eadd-46dc-4056-a287-f5041c852470
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00371-00186-080-635067-02-1033-7601.0000-0182017
Installation ID: 013465379396802394960135952653084400057175712533266492
Processor Certificate URL: SpcService Web Service
Machine Certificate URL: RacService Web Service
Use License URL: UseLicenseService Web Service
Product Key Certificate URL: PkcService Web Service
Partial Product Key: 3T8GX
License Status: Licensed
Remaining Windows rearm count: 3
Trusted time: 6/13/2019 11:19:24 AM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 6:9:2019 18:50
ActiveX: Registered, Version: 7.1.7600.16395
Admin Service: Registered, Version: 7.1.7600.16395
HealthStatus Bitmask Output:

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes, but no SLIC table
Windows marker version: N/A
OEMID and OEMTableID Consistent: N/A
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
SSDT SaSsdt SaSsdt
SSDT SaSsdt SaSsdt
SSDT SaSsdt SaSsdt
SSDT SaSsdt SaSsdt
SSDT SaSsdt SaSsdt
SSDT SaSsdt SaSsdt
SSDT SaSsdt SaSsdt
My System SpecsSystem Spec
4 Weeks Ago   #7

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Don,

The report is telling me that the key in use is from an OEM COA Sticker, Dell/HP/etc.
There is also an activation exploit present which is being used to bypass the lack of a SLIC Table.
This will also have changed the SHA hash value.
I have no idea what ELSE may have been incuded

If you clean install using a genuine Iso the system will turn Non-Genuine.

The image appears to be dated Jan 2017

Unfortunately forum policy dictates that help cannot be provided in these cases.

My System SpecsSystem Spec
4 Weeks Ago   #8


For some reason I purchaced a windows 7 ultimate and put it on my dell E6510 laptop. I would think I could get a hold of the Dell coa key for windows 7. I think it would be my option to install windows 7 coa on the dell laptop and release the windows 7 ultimate licence to use on my Gigabyte machine.
My System SpecsSystem Spec

 UPDATE trashed my OS stuck on " updating system settings"

Thread Tools

Similar help and support threads
Thread Forum
Windows Update - reset but still stuck on "Checking for Updates"
Hi I've been trying to set up a few second hand laptops for a charity youth club. One went without a hitch, one won't update Windows at all. It's running Windows 7 SP1, I've tried various fixes but nothing seems to be working. I've followed the instructions on the post. Attached is my CBS...
Windows Updates & Activation
Dowloaded update and stuck on "please wait" screen on reboot
My wife downloaded the most recent update for windows 7 pro. Upon reboot, the pc is stuck in the "please wait" screen. Have tried safe mode, safe more with networking. Nothing seems to work. Is anyone else having issues with the update? Any advice?
Windows Updates & Activation
Stuck at "Windows is finalizing your settings" after re-installing
Hello everyone, I recently bought a new Asus Notebook G56JR and installed Windows 7 on it. Didn't seem to have any problems. Today, all of a sudden, when I turned it on, it said that Windows failed to start and that I should go into recovery mode. And after this, the recovery loop occurred. It...
Installation & Setup
Tried updating manually and used belarc but "update not applicable.."
Update not applicable to my computer, ive tried going to windows download website, belarc said i have 24 missing microsoft security updates. I have Dell Inc XPS 630i windows 7. Computer properties says 32 bit but belarc says 64-bit ready so i'm not too sure what that means. i need Q2604115 -...
Windows Updates & Activation
Windows 7 set up stuck at "Personalised Settings"
I am a new member of hi! I have recently purchased the windows 7 upgrade version cd. So I installed it on my Vista Home Premium to upgrade to Win7 home premium. Everything during the installation went smoothly. I got to the log in screen and typed in my password....
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:43.
Twitter Facebook