Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Thunderbird Links don't work

13 Aug 2014   #21
Superluigi6

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by Callender View Post
Thanks for the video.

I'm wondering if you've got remote content blocked?

In Thunderbird set View> Message Body As> Original HTML and tick Display Attachments Inline.

I'd also suggest finding the sender in your address book and checking the following settings:

Attachment 329125
Nothing, and I did both of them.

EDIT: Somebody from another forum told me that this could just be a bug for Thunderbird 31.0, and/or that my profile is corrupted.


My System SpecsSystem Spec
.
13 Aug 2014   #22
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Thunderbird latest version

I suppose that it could be a bug. I don't think that it's a corrupted profile especially after your reinstall. #the test would be to try installing an older version of Thunderbird.

Here's a page with a link to old versions:

Index of /pub/mozilla.org/thunderbird/releases

(If you keep that profile that you saved using MozBackup you can restore it any time).
My System SpecsSystem Spec
13 Aug 2014   #23
Superluigi6

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by Callender View Post
I suppose that it could be a bug. I don't think that it's a corrupted profile especially after your reinstall. #the test would be to try installing an older version of Thunderbird.

Here's a page with a link to old versions:

Index of /pub/mozilla.org/thunderbird/releases

(If you keep that profile that you saved using MozBackup you can restore it any time).
Will anything happen if I downgrade?

EDIT: Somebody from another forum told me this:
"If the operating system's default browser is specified correctly as described
above, it is not necessary to specify an action for the HTTP / HTTPS content
type. To check this setting, select Tools | Options (Windows) or Thunderbird |
Preferences (Mac and Linux). Click on the Attachments page. If HTTP and / or
HTTPS are listing in the Content Type column, either delete the action or ensure
the specified action is correct."
My System SpecsSystem Spec
.

14 Aug 2014   #24
Superluigi6

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by Callender View Post
I suppose that it could be a bug. I don't think that it's a corrupted profile especially after your reinstall. #the test would be to try installing an older version of Thunderbird.

Here's a page with a link to old versions:

Index of /pub/mozilla.org/thunderbird/releases

(If you keep that profile that you saved using MozBackup you can restore it any time).
I just solved it from another forum. It is indeed a bug (https://bugzilla.mozilla.org/show_bug.cgi?id=974857), and I solved it by turning browser.fixup.hide_user_pass to false.

Thanks for the help anyways!
My System SpecsSystem Spec
14 Aug 2014   #25
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Problem solved

Very well done for finding the fix and posting it. It will help other users with the same problem!

If you decided to stick with IMAP for gmail here's some screenshots of settings that I find work best for me so you can use them if you like.

Thunderbird Links don't work-account-settings.jpg

No need to synchronize all messages:

Thunderbird Links don't work-account-settings-2.jpg

No need to sync all folders especially trash or junk:

Thunderbird Links don't work-items-offline-use.jpg

Thunderbird Links don't work-account-settings-3.jpg

Also it best to compact each folder on a weekly basis by right clicking folders then choosing "Compact"

Set folders to be compacted automatically too and maybe set cache to zero:

Thunderbird Links don't work-compact.jpg


My System SpecsSystem Spec
14 Aug 2014   #26
Superluigi6

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by Callender View Post
Very well done for finding the fix and posting it. It will help other users with the same problem!

If you decided to stick with IMAP for gmail here's some screenshots of settings that I find work best for me so you can use them if you like.

Attachment 329225

No need to synchronize all messages:

Attachment 329226

No need to sync all folders especially trash or junk:

Attachment 329228

Attachment 329227

Also it best to compact each folder on a weekly basis by right clicking folders then choosing "Compact"

Set folders to be compacted automatically too and maybe set cache to zero:

Attachment 329229
Thanks for all those tips, and thanks for the close-to-3-pages of help!
My System SpecsSystem Spec
02 Jan 2017   #27
kleis

Win 7 Pro 64 bit Ultimate SP1 (2009)
 
 

Callendar,
Sorry for dum question, but as I downloaded the TBird emailer application, well am I supposed to get new account opened in order to use the service, yes, I would guess but i was a little confused at the first step when it says once downloaded i would be presented with opening new account and was and got as far as my name in the field and in re-reading instructions it said to close any window proposing to open an email account. So, that's kind of where I got stopped and it also showed for $9? Or there was a flash or message indicating what I thought was a fee and anyway, i'll look for your possible response and carry on from there.
Thanks again for the link to the setup. I was also (just fyi) emailed a response from the Microsoft site where i put up thread and the word is that the Engineers at Microsoft are aware of the issues and are working on it. Also advised me to log in through Outlook.com and i did to see if files or sent emails there, and only those that from yesterday, are to the Dec. 23rd 2016.
Then the recommended alternate is to log on from another browser or device and i indicated that that was what i was working on at present in downloading and setting up another email account on different email (T Bird).
Thanks alot for your help.
My System SpecsSystem Spec
02 Jan 2017   #28
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

Quote   Quote: Originally Posted by kleis View Post
So, that's kind of where I got stopped and it also showed for $9? Or there was a flash or message indicating what I thought was a fee and anyway,
if your getting a $9 pay message, something is wrong, don't click it/do it.

On some systems I use Tbird portable from PortableAppsCom without any problems.

Mozilla Thunderbird, Portable Edition | PortableApps.com - Portable software for USB, portable and cloud drives

I'm on a system with Win Office/Outlook right now, so i can't test Tbird.
I'll get on a system with Tbird, update to the latest, and let you know if i have any problems.
I've been using Tbird portable for a long time now on some systems, no problems, no charges.
My System SpecsSystem Spec
02 Jan 2017   #29
MoxieMomma

OEM Windows 7 Ult (x64) SP1
 
 

Hi, @kleis:

Where did you get the Thunberbird installer?
There is NO COST, as it is free, open-source software.
(I am a bit worried that you somehow landed on a fake/rogue page offering a fake version or worse...)

There is only one trustworthy, official source:

Thunderbird - Download in your language
(this is the US page)

Thunderbird (this is the US Thunderbird main product page)

Also, FWIW, there is nothing wrong with the "portable" version of Thunderbird, as @DavidE mentioned.
Many people do use that version.
However, just be aware that it is not an official version written or supported by Mozilla.
It's up to you whether to choose the official, installed version or the portable one.

Also, much has changed for both Windows and Thunderbird since this thread was started more than 2 years ago.
In order to provide you with better, less confusing, individualized help, the forum mods/Admins may split off your post (and our replies to it) to a new, separate thread.

Thanks,
MM
My System SpecsSystem Spec
02 Jan 2017   #30
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

i agree.
i just updated a system with the Tbird portable version to v 45.6.0
no problems here.
i use the portable version for personal reasons/preferences, if the system doesn't have MS Office/Outlook email client installed.
My System SpecsSystem Spec
Reply

 Thunderbird Links don't work




Thread Tools




Similar help and support threads
Thread Forum
Link will not work in Thunderbird.
A similar problem to frodo23’s post but somewhat different though. I have a problem with a Thunderbird installation on Win 7. For a gift my 13 year old grandson is receiving a used laptop, I am the administrator and he is the second standard user. I am having trouble with Thunderbird...
Browsers & Mail
Can't change erroneous protocol for HTML links in emails (Thunderbird)
When clicking on any web links embedded in emails in my server, Thunderbird, Wordpad opens. In Control Panel/Default Programs/Set Associations I have already set all possible htm-type links in the extensions section to my chosen browser, Opera. But in the protocols section, the protocols for FTP,...
Browsers & Mail
email hyper links won't work.
Which ever place I get mail. Windstream, Hotmail, Windows Live Mail; when I receive a email with a link to click on it tells me can't do it check default programs. I did and it didn't help. I think these are called hyper links. I ran sfc /scannow, no problem found. I'm always running security...
Browsers & Mail
Links in Outlook 2010 don't work
Hi, I swear i had this problem before, and i posted a thread about it, but i cant seem to find it. Everytime i clink on a link in outlook 2010 i get this message. I'm the admin, and i have set no restrictions up. Thanks :)
Microsoft Office
Links don't work in any pdfs I download
Hi, I tried searching online for a solution but I only get results aimed at people making their own pdfs. I am trying to open links in pdfs from pther people. And in most cases, the cursor doesn't even change. It still looks like a text cursor. And even when it changes to a pointing hand,...
Software
Web links don't work under Win7
Hello everyone! :) I have a little problem with links not working in my Win7. Links in Skype, mIRC, Excel/Word to name one of my few most often used programs. I believe I've disabled UAC and it's notifications too. Here's a message I get when I try to launch a link from Excel/Word: ...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:50.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App



Windows 7 Forums